Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Google Chrome uses 500MB of memory to run

16 Aug 2011   #1
MaxPayne

Windows 7 Home Premium 64bit
 
 
Google Chrome uses 500MB of memory to run

I heard Google Chrome had some serious memory leak issues, so i opened task manager and at my disbelief Chrome was using approx. 500MB! If you dont believe me here's a screenshot of Task Manager, and btw i only had 3 tabs open..I think that is a serious memory issue, I am using Google Chrome 14 beta, but even beta's should not be using that much memory.... i guess its time to go back to firefox 6...




My System SpecsSystem Spec
.
16 Aug 2011   #2
pparks1

Windows 7 Ultimate x64
 
 

Perhaps it was a couple of pages that had some issues. I've not experience this type of issue with Chrome. Have you been able to reproduce it again?
My System SpecsSystem Spec
16 Aug 2011   #3
MaxPayne

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by pparks1 View Post
Perhaps it was a couple of pages that had some issues. I've not experience this type of issue with Chrome. Have you been able to reproduce it again?
On average chrome uses 400mb+ sometimes up to 650mb .
Can it be because I have 4mb of RAM? Most likely because Im using 14 and its still beta, i should just go back to 13 i guess.
My System SpecsSystem Spec
.

16 Aug 2011   #4
pparks1

Windows 7 Ultimate x64
 
 

Yeah, my Chrome (13)seems to be using 250MB at the present time. But on my 4GB system, I have only 32% of RAM in use...so I really don't have a problem with it. It may consume lots of RAM, but is very responsive and my box is very stable...so that's really all that matters.
My System SpecsSystem Spec
16 Aug 2011   #5
MaxPayne

Windows 7 Home Premium 64bit
 
 

hmm right now it says im using 56% of memory, welll i guess thats okk i will test with 13 and see how it goes..
I wish i could stay on 14,its a bit faster than 13..
My System SpecsSystem Spec
16 Aug 2011   #6
pparks1

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by MaxPayne View Post
hmm right now it says im using 56% of memory, welll i guess thats okk i will test with 13 and see how it goes..
I wish i could stay on 14,its a bit faster than 13..
how did you measure this speed increase? And what type of increase are you seeing?
My System SpecsSystem Spec
16 Aug 2011   #7
MaxPayne

Windows 7 Home Premium 64bit
 
 

Its because ive been testing 13 since it was on beta, and since chrome was on the beta channel, when 13 became final and 14 became beta, chrome automatically updated to 14 beta...
I wasnt aware that i was using 14 til i noticed one day that chrome was running noticeably faster than usual, so i checked the version and turns out that was the day 13 became final and 14 was beta so the reason chrome got faster was because i was on 14 beta.

I didnt measure the speed it just fells like it loads pages faster , and youtube videos rarely buffer now, and overall it feels faster too.
My System SpecsSystem Spec
16 Aug 2011   #8
MaxPayne

Windows 7 Home Premium 64bit
 
 

Nevermind i googled it and 500MB is average... so im good nevermind ..
My System SpecsSystem Spec
16 Aug 2011   #9
stve

Windows 7 Ultimate 64 bit
 
 

Nothing wrong if you have plenty of memory & the browser uses a lot of memory to speed up your browsing so long as it releases that memory when your system needs it. The browser should tailor its memory requirements according to how much memory is available.
My System SpecsSystem Spec
Reply

 Google Chrome uses 500MB of memory to run




Thread Tools




Similar help and support threads
Thread Forum
Google Chrome Not logging into Google account, white screen
Before I even say anything, I have tried to reinstall Chrome 3 times and the problem still stands. So my problem is that when I try to login to my Google account on Google Chrome, the web page goes white and Chrome does not log in. The steps I took are as follows: It starts on the regular...
Browsers & Mail
Memory Management BSOD when using Google Chrome
Hello everyone , I recently bought a new computer and have been getting Memory Management BSODs when using Google Chrome.I have played games for hours and it never happens. Only when using Chrome to browse websites. But it is probably not Chrome and more likely my ram. I just want to make...
BSOD Help and Support
BSOD using Google Chrome, Memory Management error 0x0000001a
Hi there, I'm having BSOD problems with my Dell XPS 15z laptop. I recently received a BSOD Memory Management error while using Google Chrome. I have searched several pages looking up for solutions, but with no results. Ran the usb boot version of Memtest86+ around 2 hours and reported no...
BSOD Help and Support
Should 'Google Chrome" being using this much memory?
When i have multiple taps open, chrome seems to run very slow and often doesn't load pages. I am using the stable version of chrome, my question is why is it using so much memory and is it normal? http://i758.photobucket.com/albums/xx224/ROiD_II_oJIPo/Untitled-1.png I don't think it is...
Browsers & Mail
Google Chrome v8 developer build hints at future of Chrome OS
more
News
Reclaim Memory in Google Chrome
More...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:08.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App