Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Failure to open links to other websites

27 Aug 2011   #1
guybc

windows 7 Pro 64
 
 
Failure to open links to other websites

using WIndows 7 pro. 64 bit and IE 9 -On any open web-pag'e links referring to other websites, usually in blue, opened easily to the new web page.
Now, L-clicking on the link shows the faint image of the address at bottom of the screen, but does not open a new web page.
A workaround by copying the URL and pasting will open the new page.
My security is set to medium-low.

This is an annoying new problem. Any suggestions on how to fix it?


My System SpecsSystem Spec
.

28 Aug 2011   #2
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Try re-registering IE's dll's. Download Capt Jack's IE Restorator and choose the re-register link.

SF IE Restorator - Troubleshooting General Issues with IE

A Guy
My System SpecsSystem Spec
28 Aug 2011   #3
guybc

windows 7 Pro 64
 
 

Thanks ffor the reply. I have done that without any change. The link you gave, for instance, doesn't work. At the same time, I can move around as before with links that refer within this forum.
My System SpecsSystem Spec
.


28 Aug 2011   #4
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

This link may help, they have a fixit that makes it easier. It will do no harm even if it doesn't help:

You cannot open a new Internet Explorer window or nothing occurs after you click a link

Also look here:

Links in will not open a new window or tab in Windows 7 IE8 - Microsoft Answers

A Guy
My System SpecsSystem Spec
28 Aug 2011   #5
well48

Windows 7 Pro 64bit w/ Virtual XP Mode
 
 

I had this happen after updates once.
1- Tools—Internet options— Settings button in Tabs area— Restore defaults.
2- click OK & OK then exit IE

3- Reopen IE, navigate back to Tab settings and set the way you want.
4- click OK & OK then exit IE

5- Open IE and do whatever. Hope that works for you too.
My System SpecsSystem Spec
29 Aug 2011   #6
guybc

windows 7 Pro 64
 
 

Thanks - that worked to the extent that there was a response to clicking on the link - BUT only opened a blank page. Can we go one step further?
My System SpecsSystem Spec
Reply

 Failure to open links to other websites




Thread Tools





Similar help and support threads
Thread Forum
Outlook won't open links if IE is open.
Well, I have searched and have not been able to find a solution to my particular issue: with IE9 set as default browser, when I click on a link in an Outlook message, the link will only open if IE is not already running. In other words, with IE closed if I click a link in Outlook, it will open, but...
Browsers & Mail
can not open only 2 websites
I have a client that has 9 work stations hardwired and 3 laptops wireless and 1 server hard wired and none of them can connect to 2 specific websites. The workstations are running Windows 7 Pro 64bit, laptops are Windows XP Pro and the server is Windows Server 2008 Standard R2 64bit. They were all...
Network & Sharing
cannot open links on websites
Hi all, I'm new here and have a problem opening links when I get on a website. I'm using a toshiba satellite laptop with W7 and IE9. The site I am talking about is Ebay. I am trying to sell some items and have to upload pictures to complete my listing and when I klick on the add photo tab, nothing...
Browsers & Mail
Unwanted links in e-mail messages and websites
Greetings all and sorry in advance for the poor description of the issue, the attached picture tells the story much better than I can. I noticed that text in my yahoo mail messages is getting turned into links automatically. This appears to be happening in both Chrome and Firefox. 1) Is this a...
Browsers & Mail
Help? Can't open certain websites
Hello, I just got a new HP laptop with windows 7 home premium. I am having trouble logging on to certain sites. So far MailChimp.com and iStockphoto are giving me problems. With Mailchimp, when I put in my user name and password, the page just reloads. It does not let me log in. With...
Browsers & Mail
Certain websites never open
I have a problem whereby my new windows 7 machine can connect to the internet, but will not open certain webpages. So for example I can get to Google (or this forum), but when I try Firefox web browser | Faster, more secure, & customizable | Mozilla Europe the browser seems to connect but the...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:01.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App