Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Some sites take much longer to load than others

17 Nov 2011   #1
strollin

W10 Pro desktop, W10 laptop, W10 laptop, W10 Pro tablet (all 64-bit)
 
 
Some sites take much longer to load than others

I'm having an issue on my laptop (Dell Inspiron 1520, Win 7 HP 32-bit, 3G RAM) that has me perplexed. Most sites I go to (such as SF here) load instantly yet other sites (such as newegg.com) take forever to load. I'm not talking about waiting for an image or two to finish loading but the page doesn't even begin to be rendered. The info line at the bottom of the browser window says "transferring data from xxx.com". It can take literally minutes to see the page. Sometimes hitting refresh helps but not always. Often if I select "Open link in a new tab" the page will load instantly, the problem mostly manifests itself when I simply click on a link.

I'm currently using FF 8.0 but I have tried IE 9 as well as the latest version of Chrome but see the same behavior. Other machines on my network don't have the problem.

I've tried clearing temp data, browser cache and history. I don't see anything unusual in my hosts file.

Anybody got any ideas as to why this is happening?


My System SpecsSystem Spec
.
17 Nov 2011   #2
DustSailor

Microsoft Windows 8.1 Pro 64-bit
 
 

Did you change any settings or edit the registry in its dealings with the internet (ie in an attempt to make it faster)?

Have you changed any wireless adapter settings other than its standard setup or any router settings other than its original setup?

Happens in both IE9 and FF huh? when did this start? Has it been going on a while now?
My System SpecsSystem Spec
17 Nov 2011   #3
NoN

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
 
 

I wouldn't be suprised that some adds/hacks on such site try to locate/track informations in your browser...newegg.com a perfect example!

You could try:
[link removed as per forum rules] Oops, sorry!

Better here:
IE9 - Allow or Prevent Websites to Request Your Location

You could also manage your add-ons to set tracking-protection list.
Internet Explorer - Enable or Disable Accelerator Add-ons
My System SpecsSystem Spec
.

17 Nov 2011   #4
strollin

W10 Pro desktop, W10 laptop, W10 laptop, W10 Pro tablet (all 64-bit)
 
 

@NoN - Went in and disabled the geo stuff in FF and in my limited testing it seems to have done the trick! Newegg.com loads instantly now. Very interesting.
My System SpecsSystem Spec
17 Nov 2011   #5
NoN

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
 
 

Quote   Quote: Originally Posted by strollin View Post
@NoN - Went in and disabled the geo stuff in FF and in my limited testing it seems to have done the trick!
Hope it will stay like that!
My System SpecsSystem Spec
Reply

 Some sites take much longer to load than others




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Internet Sound No Longer Works On Some Sites
I am new so forgive me if this post is not in the correct area. I have the latest Internet Explorer and have recently installed Avast (may or may not be relevant), I tried to listen to radio HEART on-line last night and it didn't work, it has done so before, there was no Internet sound slider in...
Sound & Audio
firefox wont load some sites if I type the url in?
if I enter (mysite.com or www.mysite.com, it wont load the site) all other sites work fine if I just enter the url. whats going on and how do I fix it? also happens with IE 10. ideas appreciated. thanks.
Network & Sharing
Won't load web sites ...get error 103
Please help. When logged in I try and go to a web site such as Washington Post or similar sites and can't load the web page...get error 103. However, when I am in safe mode as I am now all the web sites load right away..no problem. Can you help please? I'm running Windows 7 professional...
Browsers & Mail
Some sites won't load on wired connection only
Having a very strange problem on a brand new desktop computer. When i use the wireless connection, everything is great. When i switch to a wired connection, some sites load fine but others won't at all. I have other desktops on the same wired connection and they have no problems whatsoever. For...
Browsers & Mail
New Computer Won't Load HTTPS Sites, just hangs
Hey, Got this new computer here and sites using https or have used https in the past will not load. Main example I have is facebook. Going directly from the home page to facebook on IE9 it just hangs there which i open a new tab without http it loads fine. In firefox i can load the login page...
Network & Sharing
Ie 8 wont load some web sites
hello all im having this ongoing problem with Ie8. Icannot access certain webpages ie facebook, hotmail and some microsoft pages. With facebook its only the homepage that doesnt load i get waiting for http://www.facebokk.com/home.php? and half the page loads and that it. With hotmail i get...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:10.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App