Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet Explorer 8 lags terribly with more than 1 tab.


05 Dec 2011   #1

 
Internet Explorer 8 lags terribly with more than 1 tab.

I have completely reformatted and reinstalled my windows 7 OS on a new quad-core 4GB computer. internet explorer 8 continues to lag badly and use up nearly 100% cpu when more than one tab is opened. is the browser really that bad, or is there another possible problem? i am totally OK with firefox, i just am concerned that the problem is more than IE.

My System SpecsSystem Spec
.

05 Dec 2011   #2
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Hello Anna, and welcome to Seven Forums.

It could be a bad installed add-on on IE8 causing the issue. You could check by running the Internet Explorer (No Add-ons) in the Start Menu, All Programs, Accessories, System Tools. If it runs fine, then it's likely an a bad add-on. In your normal IE, disabe your add-ons and enable one by one testing after each time to see if you find the culprit causing this issue.

However, I would also recommend to update to IE9 as well through Windows Update.

If the above doesn't help, then you might see if resetting Internet Explorer may.

Hope this helps,
Shawn
My System SpecsSystem Spec
Reply

 Internet Explorer 8 lags terribly with more than 1 tab.




Thread Tools



Similar help and support threads for2: Internet Explorer 8 lags terribly with more than 1 tab.
Thread Forum
Solved nt kernal & system 25% CPU usage, internet lags Network & Sharing
Solved Freezes, lags and sometimes BSOD when connecting to Internet BSOD Help and Support
mediaplayer freezes and explorer lags Music, Pictures & Video
CPU usage spikes (100%) and windows lags terribly Performance & Maintenance
terribly slow performance Performance & Maintenance
Something terribly wrong with windows 7 General Discussion
video information and explorer/dllhost lags General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:55 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33