Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Impossible declaring Chromium as default browser

28 Jan 2012   #1

 
 
Impossible declaring Chromium as default browser

Hello

after an experience with SRWare Iron (a fork of Chromium) in which I declared it as default browser, I uninstalled it

SRWare Iron

Then I installed Chromium build continuous (cf last line). Chromium is the free version of Google Chrome (to resume).

Chromium continuous

The pb is : in my machine, it is now impossible declaring Chromium as default Browser.

It is OK in my other machine when SRW Iron has never been installed.

In fact the command is accepted but has no effect : everything occurs as if there were no longer any default browser.

It seems that for the system, Chromium is still SRW Iron. And, as it no longer exists...

Do you know how to fix it ? Thanks in advance !


My System SpecsSystem Spec
.

28 Jan 2012   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Hi Pierre and welcome to Seven Forums. Have you tried setting IE as the default browser? If that works you may then be able to set Chromium as the default.
My System SpecsSystem Spec
28 Jan 2012   #3

 
 

Quote   Quote: Originally Posted by kado897 View Post
Hi Pierre and welcome to Seven Forums. Have you tried setting IE as the default browser? If that works you may then be able to set Chromium as the default.
Hi and thanks for your answer.

No, I've just tried and it doesn't work : it would be too easy ! There is really a problem : collapsing between Iron (although uninstalled and formerly considered as Chromium) and Chromium itself.

I had already thought about it (I had already tried with Google Chrome and Firefox).

The symptoms are always the same : according to Chromium, Chromium is the default browser but :

1) it is not in the list "config panel, default programs" (all the other browser that I have already declared as default browser are in it).

2) Nothing occurs when I click on a link from an exterior program (here : Thunderbird) : with another default browser, the link is open in the browser.

3) htm and html files don't have any icon and are declared as "Iron html documents" when the arrow of the mouse passes on it.
My System SpecsSystem Spec
.


28 Jan 2012   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Have you tried reinstalling it and then removing it using using Revo Uninstaller. That may get rid of any afters. The link is in my signature.
My System SpecsSystem Spec
28 Jan 2012   #5

 
 

Thanks for your program. I have just installed it.

I'll try it and I'll tell you if it fixes the pb.
My System SpecsSystem Spec
28 Jan 2012   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

OK. Just be careful to review ant Registry entries it suggest to remove. It can be a bit indiscriminate at times.
My System SpecsSystem Spec
28 Jan 2012   #7

 
 

Yes, I suggest :

uninstalling Chromium entirely (parameters included) but normally (with your program or not ?).

reinstalling Iron

unistalling Iron normally (with your program or not ?)

doing a forced uninstallation of Iron with your program.

Is it a functionality difference between the registered or unregistered program ?
My System SpecsSystem Spec
28 Jan 2012   #8

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

That sounds a good plan. Use Revo for all the uninstalls. The main difference between the registered and free versions is the ability to handle 64bit programs. I think the browsers you are using are 32bit.
My System SpecsSystem Spec
28 Jan 2012   #9

 
 

Yes, It worked !!!

Well, thanks a lot, to you and your program !



I uninstalled Iron with your program, then I made the suggested scan and it remained a lot of records in the registry. I selected and deleted them as suggested. I did not need the forced uninstallation.

All the remainig had become OK.
My System SpecsSystem Spec
28 Jan 2012   #10

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I'm glad to hear it Pierre. Please come back if you have any further issues.
My System SpecsSystem Spec
Reply

 Impossible declaring Chromium as default browser




Thread Tools



Similar help and support threads for2: Impossible declaring Chromium as default browser
Thread Forum
Portable Browser :- How to be my Default Browser and/or use a URL Link Software
default browser Browsers & Mail
How to set IE as default browser for all user Browsers & Mail
IE 8 as default browser. Browsers & Mail
Best Chromium Web Browser Browsers & Mail
Declaring Security - IE8 blog News

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:14 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33