Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow loading on pages in either IE9 or Google Chrome

30 Jan 2012   #1
Knight56

Windows 7 Professional 64bit
 
 
Slow loading on pages in either IE9 or Google Chrome

Hello,

I have switched to another ISP a couple of days ago. Once my modem/router was set up and everything was a go. However, the issue on web browsing popped up and is persisting ever since. I had never experienced this such problem when I subscribed to the previous ISP.

The pages load way too slow in either IE9 or Google Chrome. Is there any solution for this problem?

On my other computer, running WinXP, the pages open blazing fast.

Any help to resolve?


My System SpecsSystem Spec
.

30 Jan 2012   #2
Knight56

Windows 7 Professional 64bit
 
 

Well, I have contacted tech support of ISP and was told that my DSL account has not been FULLY activated yet. So, I'll wait and see for tonight.
My System SpecsSystem Spec
30 Jan 2012   #3
stve

Windows 7 Ultimate 64 bit
 
 

Some ISP's are pretty poor at serving pages if you still have problems later on
DNS servers - Google Search
Google DNS & Open DNS are probably the two best for most people.
My System SpecsSystem Spec
.


30 Jan 2012   #4
Knight56

Windows 7 Professional 64bit
 
 

Thanks, Steves, for the information. I'd definitely resolve by doing like this!
My System SpecsSystem Spec
03 Feb 2012   #5
Knight56

Windows 7 Professional 64bit
 
 

Not resolved at this moment. Either the ethernet cables or network adapter is the cause of this problem. The tech support from the current ISP would recommend switching out cables and having the adapter tested further. So, I had disabled the adapter driver so that I could connect this PC wirelessly to a home networking router, using a USB network adapter. Everything looks GOOD now for web surfing!
My System SpecsSystem Spec
03 Feb 2012   #6
Knight56

Windows 7 Professional 64bit
 
 

Am planning to buy a PCI wireless network card...
My System SpecsSystem Spec
Reply

 Slow loading on pages in either IE9 or Google Chrome




Thread Tools





Similar help and support threads
Thread Forum
Odd Issues: Explorer taking 70k, Chrome not loading pages,system hangs
i dont know where exactly to put this since it spans such a massive amount of software and hardware anyways: I have a Dell Inspiron M1050 with an AMD Triple Core (2.3 Ghz) and an ATI Radeon 4250 HD Integrated. 4 Gb RAM 500Gb HDD Windows 7 Home Premium x64 (obviously) so, ive had this...
General Discussion
google chrome crashes and loads pages very slow
All day yesterday I was browsing the internet with no problems which includes me playing games and browsing the web today however. Whenever I go to youtube the videos load and play just fine but the thumbnails only appear black, after about a minute or so of watching a video the thumbnails will...
Browsers & Mail
All browser slow/not loading pages
Hello! I'm running Windows 7 for a couple of months, and recently none of my browsers will work normally. The connection often time outs, dns fails or it loads the page but with nothing but text :confused: (Some pages load, and the ones that don't load, work after refreshing the page a couple of...
Network & Sharing
IE9/Chrome loading pages very slowly.
I am using IE9/Chrome which is loading pages extremely slowly 40-60seconds. Often giving error that page not found. However strangely Youtube videos play fine and downloads (like from download.com) are done properly. Also, msn messenger not signing in properly usually in 6th or 7th attempt it logs...
Browsers & Mail
Chrome and IE loading pages very slowly
Hello, I have Sony Vaio Model name VPC119GX (Windows 7 Professional-SP 1, 64-bit, Intel(R) Core(TM) i7 CPU, 8.00 GB). My browsers (IE and Chrome) have become very, very slow; sometimes, nothing happens. Tests using speakeasy stall about half way through the down load part; I do not get to the...
Browsers & Mail
Chrome not loading web pages
Since Google was kind enough to automatically update chrome to 5.0.375.29 it wont load any pages at all. Any incites as to the cause?
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:35.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App