Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Mailto protocol missing


18 Feb 2012   #1

windows 7 ultimate 64 bit
 
 
Mailto protocol missing

Hi All

I cannot create a "mailto" shortcut that works. It appears that the mailto protocol is missing, Windows Live Mail is set as my default mail client in WLM settings, but it doe's not appear in the default program list. The only thing that shows up with any connection with WLM is "Windows Contacts"

I have been reading articles about this problem, and one suggested that a registry tweak in the "mailto" entry may repair the problem. However there is no "mailto" entry at the suggested location in the reg.

In default programs / Set program access and computer defaults / custom, I can choose WLM as my default email program, but when I return to that setting again it has reverted to "use current".

When I create a mailto shortcut it defaults it's association with Chrome, my default browser and carries a Chrome icon. I have re-installed WLM but that did nothing to resolve the problem.

Am running Windows 7 Ultimate.


If anyone can help, it will be most appreciated.........

Thankyou for your help...Abe

My System SpecsSystem Spec
.

18 Feb 2012   #2
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Hello Abe,

You can go into Default Programs (Set Associations option), and scroll down towards the very bottom until you see the MAILTO protocol if listed here instead (should be). From here, you can select MAILTO, click on the Change program button, and select to have MAILTO use Windows Live Mail again.

Mailto protocol missing-mailto.jpg

Hope this helps,
Shawn


My System SpecsSystem Spec
19 Feb 2012   #3

windows 7 ultimate 64 bit
 
 

Hi Shawn

Thanks for your advice....

I have been into associate file types or protocols, but there is no "mailto" protocol. I have compared the same items on my laptop running Windows 7 Home Premium and there are a lot more protocols mentioned including "mailto" which is associated with WLM.

I am thinking that this is an issue with my Windows 7 Ultimate and not WLM as I have re-installed this software to no avail..

Regards.........Abe
My System SpecsSystem Spec
.


19 Feb 2012   #4
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Abe,

I exported my MailTo protocol from my registry for WLM and attached it below as a REG file. If you like, you could download and merge the REG file, approve the merge (Run, Yes, Yes, OK), then restart the computer to hopefully have your MailTo back.


Attached Files
File Type: reg MailTo-WLM.reg (7.9 KB, 411 views)
My System SpecsSystem Spec
20 Feb 2012   #5

windows 7 ultimate 64 bit
 
 

Thanks Shawn I'll give it a try, and get back to you.

Abe
My System SpecsSystem Spec
20 Feb 2012   #6

windows 7 ultimate 64 bit
 
 

Hi Shawn

Tried the reg patch, but came up with a problem, when you try to merge it I get an error message "cannot import, error accessing the registry". I have added entries to the registry before and had no trouble, maybe I'm doing something wrong? Or maybe my Reg is corrupt?

have just realized that I do have the "mailto" entry in the reg "sorry shawn didn't scroll down far enough" but I cannot access it. Tried running regedit as admin and got this message........

"mailto cannot be opened an error is preventing this key from being opened, details: Access is denied"

Regards Abe
My System SpecsSystem Spec
20 Feb 2012   #7
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

What's the registry location of this mailto key?
My System SpecsSystem Spec
23 Feb 2012   #8

windows 7 ultimate 64 bit
 
 

Hello Again Shawn

I think it would be a good idea to give you some background on this problem.

Since installing Windows 7 I have had no need to create a “mailto” short-cut, so I have no idea if this is a recent problem, or if this has been evident since Windows 7 was installed without me knowing.

I have recently been having problems with creating URL short-cuts in as much that the short-cut would default to an IE9 short-cut and not Chrome which is my default browser. When I looked in default programs URL short-cut was associated with IE9 but the tick boxes were ticked but greyed out and could not be changed.

About two weeks ago I uninstalled IE9 and this seemed to solve that problem. It's only in the past few days that I have discovered the “mailto” short-cut problem.

After trying the patch that you so kindly sent me with no success, I decided to investigate all the “mailto” entries in the Reg. Two of the entries denied me access. I had a look at the permissions of these entries and found that I indeed did not have the right level of access. I changed the permissions of both entries and rebooted.

Now “mailto” has appeared in the list of protocols, associated with “unknown program”. I tried to change the program, but the only program that appears is Google Chrome obviously not my e-mail client, however there is no option to browse for or indeed see more programs. WLM is still not listed in default programs.

I have since done a reinstall of WLM, still with no success. I have also tried the patch again, but that tells me that access is still denied.

Thanks again for your help.........

Sorry about the wordy reply.......Abe.
My System SpecsSystem Spec
23 Feb 2012   #9
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Abe,

You might take a look in Set Program Access and Computer Defaults to see if you may be able to enable access and select Windows Live Mail as the default email program. Afterwards, see if you may be able to select (check) MAILTO for Windows Live Mail in Default Programs.

Name:  WLM.jpg
Views: 181
Size:  112.6 KB


My System SpecsSystem Spec
23 Feb 2012   #10

windows 7 ultimate 64 bit
 
 

Hi

WLM is not listed in "Set your default programs".

However it is listed in "Set program access and computer defaults" under "custom" but if I choose it, it makes no difference and when I go back into Set Program access again the "use current" is selected

Mailto appears in "Associate a file or protocol" and is associated with "Unknown program" I cannot change this program, my only option if I try to is Chrome.

Will try gpedit route and let you know

Thanks Abe
My System SpecsSystem Spec
Reply

 Mailto protocol missing




Thread Tools



Similar help and support threads for2: Mailto protocol missing
Thread Forum
Using Gmail for mailto Browsers & Mail
Mailto missing from registry (& Associate File Type or Protocol List) Browsers & Mail
Missing HKEY_LOCAL_MACHINE\Software\Classes\mailto General Discussion
Gmail as default mailto Browsers & Mail
Mailto links in IE to go to Google Apps Browsers & Mail
Missing IPV6 Protocol Network & Sharing
Windows Mail and Win 7 Mailto: Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:56 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33