Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Fix for repairing Windows Live Mail that actually works...


26 Feb 2012   #1

Win 7 32bit
 
 
Fix for repairing Windows Live Mail that actually works...

Hello all...

Before you read on...just know I am not an IT Pro nor am I a PC "geek at home"...I just found a solution to this particular problem and know from reading on the internet many people have this same problem...So just bare with me and understand that I am writing this to the best of my knowledge, but I do have the solution...

I have been reading about how people (including me) are having trouble with uninstalling Windows Live Mail that is a part of Windows Live Essentials on Windows 7 Home Premium O/S (in my situation).

I have had a corrupt Windows Live Mail error for about 2 weeks now. Any time I tried to reply to an email, an error window appeared telling me that Live Mail was corrupt (I cannot remember the error message word for word, but if anyone else cannot reply to emails and gets an error message when clicking on the "reply" button...I can help).
I tried uninstalling it and it was not in my Programs and Features nor in Revo Uninstaller nor my IOBit File Shredder. I was besides myself. I tried uninstalling the "complete" Windows Live Essentials but to no avail...

So, finally after tons of researching, I found the answer...
I achieved this by just clicking around all the different folders in WLE.

This particular file path IS the one that is used to REPAIR Windows Live Mail:

C:\Program Files\Windows Live\Installer

Copy and paste the above file path into the "search programs and files" in your start menu.
Just follow the steps and choose the option to repair Windows Live Mail...
It is that simple!!

I sure hope I was able to help others out with my solution...

My System SpecsSystem Spec
.

26 Feb 2012   #2

Win7 H.Prem. 32bit+SP1
 
 

The more experienced users do it in 'Programs and features' by selecting WLE then repair.
My System SpecsSystem Spec
26 Feb 2012   #3

Win 7 32bit
 
 

I am sorry Roderunner I think that perhaps you did not read the section in my post where I said it was NOT in my programs and features, and Revo did not show it nor did my IO Bit File Shredder. I have looked every where and it was showing up in program files but it was NOwhere to be removed. Hence, my solution was in the post there to get it working again.
My System SpecsSystem Spec
.


27 Feb 2012   #4

Win7 H.Prem. 32bit+SP1
 
 

Sorry Vivie, all I did was to look to see if it was on mine, it is.
My System SpecsSystem Spec
27 Feb 2012   #5

Windows 8 Pro w/MC 32-bit
 
 

Quote   Quote: Originally Posted by Vivie View Post
...it was NOT in my programs and features...
That's right "Windows Live Mail" is not listed separately in Programs and Features. "Windows Live Essentials" is listed. That is what you hightlight and click "uninstall/change" at the top to get the repair dialog. The repair actually applies to all the installed components of the Essentials package, including Mail.
My System SpecsSystem Spec
27 Feb 2012   #6

Win 7 32bit
 
 

Roderunner...

It's fine...
My System SpecsSystem Spec
27 Feb 2012   #7

Win 7 32bit
 
 

roncerr,

I do know it is not listed individually. The WLE was nowhere to be found. It was NOT in my programs and features, it was not seen by Revo Uninstaller, nor by IO Bit File Shredder. But yet, when I clicked on it, the program opened and looked as if it was going to work and nothing, I kept getting file errors telling me that my program was corrupt. And I am talking about ALL the WLE programs in it...but my Live Mail was most important to me. NOW, it is back and working well. One cannot remove something that is not showing up anywhere and does not have an uninstaller.

So, by searching around in the WLE file folder, I was able to find the file path (mentioned in my original post), that repaired Live Mail and also placed WLE back IN all the above mentioned.

So, there is my solution for anyone that may get te same problem.

BTW, going to Microsoft's site and reinstalling WLE does NOT work either. During the install, it will tell you that WLE is already installed on your PC...so if you cannot uninstall it (because it does not appear anywhere and does not have an uninstaller) you will find my solution to work.

Best always,

Viv
My System SpecsSystem Spec
27 Feb 2012   #8

Win7 H.Prem. 32bit+SP1
 
 

So Viv you not just a pretty face, your both.
My System SpecsSystem Spec
27 Feb 2012   #9

Win 7 32bit
 
 

@Roderunner...

Well thank you kind sir...
My System SpecsSystem Spec
17 Feb 2014   #10

Windows 7 Home Premium 64 bit
 
 
Windows Live Mail is not responding

I tried to search the following link to repair my WLM and it got no results in searching.
C:\Program Files\Windows Live\Installer
My System SpecsSystem Spec
Reply

 Fix for repairing Windows Live Mail that actually works...




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:00 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33