Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to connect to certain websites (Browser/Connection Independent)

20 Apr 2012   #1

Windows 7 Home Premium 64-bit
Unable to connect to certain websites (Browser/Connection Independent)


I have been struggling with accessing certain websites while using my laptop, HP Envy 14; Intel i5 CPU; Windows 7 Home Premium x64. For example, while I am able to navigate to Google, performing a search containing the word "statistics" results in a deactivation of google `instant' and a "Problem loading page" error that prevents me from accessing the search results. There are many other such 'keywords' that result in the same thing. The problem is not limited to google (yahoo, ask, or virtually any search engine gives the same). The "Problem loading page" error is not even limited to searches, as it occurs for certain websites too, though indirectly through searches as that is how I locate most of the websites I visit. I was using Firefox 11.0 when I first noticed this issue, but it is the same if I switch to IE9.

The problem is not limited to my home internet connection, but occurs for every network I connect to. Interestingly, if I run a web browser through my Virtual Linux machine the problem disappears and I have no issues connecting to any websites. I have tried running SpyBot S&D to see if it was a malware issue and CCleaner to see if it went away if I cleared all my old settings / temporary files. Unfortunately, neither helped. I hope to be able to solve this problem as it is extremely aggravating, as I don't really know what the cause could be. If you have any suggestions, or need any information, let me know. I ran HijackThis and attached the log file.

Also, I checked the 'hosts` file using HijackThis additional tools and it was empty.


Attached Files
File Type: log hijackthis.log (18.4 KB, 11 views)
My System SpecsSystem Spec
22 Apr 2012   #2
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

Welcome to Seven Forums bdizzle329. Try this, it will reset the hosts file to Windows default.

Copy and paste these lines in Note pad.

@Echo on
 attrib -h -s -r hosts
 echo localhost>HOSTS
 attrib +r +h +s hosts
 ipconfig /release
 ipconfig /renew
 ipconfig /flushdns
 netsh winsock reset all
 netsh int ip reset all
 shutdown -r -t 1
 del %0
Save as flush.bat to your desktop.

Right click the .bat file and choose Run as Administrator. Your computer will reboot itself.

See if that helped. A Guy
My System SpecsSystem Spec
22 Apr 2012   #3

Windows 7 Home Premium 64-bit

Hey A Guy. Thanks for the welcome.

So, I tried the running the flush.bat (as administrator), but the problem persists. Based on your experience, what are typical causes for these types of problems? Thanks for your help.
My System SpecsSystem Spec

22 Apr 2012   #4
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

A malware infection is a definite possibility. Since your linux connects and works fine, it may not be an internet issue. I would d/l and install Malwarebytes, and scan in normal mode, and safe mode. You can also easily perform a clean start to see if there is an obvious conflict.

Troubleshoot Application Conflicts by Performing a Clean Startup

A Guy
My System SpecsSystem Spec

 Unable to connect to certain websites (Browser/Connection Independent)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
I have a Win 7 Ultimate PC 64 bit and a AMD based processor with Realtek LAN controller. The issue is that though i have only a single LAN connection through a WiMax connection and the router gives only one IP address to the PC, the Networks and Sharing Center shows two different networks with same...
Network & Sharing
Help. Windows unable to connect to SSID. WI-FI connection.
I see many threads like this but doest help me at all. Sorry My Computer(Desktop) just suddenly " Windows unable to connect to SSID ". First it is connect w/ yellow warning sign and then that. I don't what cause that. Other Computer and Devices here at home is connected with no problems at...
Network & Sharing
Browser does not connect websites unless I re-enter URL or hit F5
This problem started about a month ago. Many sites (not all) will not connect anymore unless I re-enter the URL or press F5 repeatedly. A few sites will not connect at all. Downloads give a message that the file or program cannot be downloaded, but if I press “try again”, it says resuming,...
Browsers & Mail
I have internet connection but cannot connect to any browser
Last night i was using my pc but suddenly my internet disconnected, i use modem cable it says i have internet connection but when i go to anybrowser or i try to update any software it says i dont have internet connection i tried ipconfig/renew , netsh winsock or ip reset but still didnt got any...
Network & Sharing
Unable to connect to many websites - please help
Ok, So I've had this problem for quite a while now and have tried to solve it without asking anywhere but I'm dumbfounded on what to do next. My computer simply will not connect to certain websites, particularly, no matter what browser I use. I have checked the hosts file, run a...
Browsers & Mail
Unable to connect to Ad-hoc connection
Hello everyone, I have 2 laptops both have windows 7 and use usb modem to connect to internet, and use Ad-hoc to share connection on 2nd laptop, usually i share connection from my personal laptop for my other laptop but since past few days i am getting error on my other laptop that window...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:45.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App