Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Internet Explorer 9 - sporadically slow

25 Apr 2012   #1

Windows 7 Ultimate 64 bit
 
 
Internet Explorer 9 - sporadically slow

Hi guys,

I have a really strange issue with Internet Explorer 9. 95% of the time I launch it and everything is pretty much instant. However occasionally it will hang for a few secs on 'waiting for reply'. Tends to happen to all web pages but more specifically noticed it on Google.com and Yahoo.com.

It never used to be this way. I have a fibre to cabinet broadband connection and everything is fast. I cannot pinpoint when this started happening. Nothing new on the laptop has been installed, some windows updates a couple weeks ago but in the aftermath of installing these all was fine.

The problem may of existed a lot longer but I had not noticed. The really strange thing is it tends to manifest itself most after poking around in the network/sharing center. I am always looking at the strength of the wifi connection and checking the connected speed of the 5g wifi. Tends to happen most after I've been in here and then launch internet explorer. Slight pause of 3 or 4 seconds and then the page is there (google being my homepage). But not every time. So it's strange. Does anyone else see similar? Especially after poking around just generally looking in the network and sharing center?

Things I have tried is clearing the IE cache, flush DNS. I could change the DNS settings but namebench revealed my current ones were fastest. Oh and Mozilla seems to be responsive all the time. So I am thinking it's more IE9 only showing this odd behaviour. Other than that all is good on the laptop, no other problems.

Thanks,
Wayne

My System SpecsSystem Spec
.

26 Apr 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium 64Bit
 
 

My System SpecsSystem Spec
26 Apr 2012   #3

Windows 7 Professional x64 Service Pack 1
 
 

Try clicking the gear icon in the top right. Then, click on the Programs tab in the window that pops up. Then click on Manage addons. Disable everything except Java and Adobe Flash player. Also, keep Microsoft Silverlight.
My System SpecsSystem Spec
.


28 Apr 2012   #4

Windows 7 Ultimate 64 bit
 
 

I disabled add ins but no difference. It's very occasional but nonetheless noticeable. Even happens when accessing the router homepage so it's not a net issue. Does not seem to happen with mozilla so must be an IE9 issue. I tried flushing DNS too. Wish IE10 was available now to try.

Any other ideas or similar happening with others?

Cheers.
Wayne
My System SpecsSystem Spec
28 Apr 2012   #5

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium 64Bit
 
 

what version are you using actually? since you're windows is x64bit, consider using the x32bit version of ie9. also take a look here Is Internet Explorer slow? 5 things to try - Help & How-to- Microsoft Windows
My System SpecsSystem Spec
28 Apr 2012   #6

Windows 7 Ultimate 64 bit
 
 

It's the 32 bit version I am using. Will try the reset later. Thanks. Just odd it happens sporadically. If something was iffy you'd think it'd be like it all the time!
My System SpecsSystem Spec
Reply

 Internet Explorer 9 - sporadically slow





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:47 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33