Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Strange Not A Valid Email Address Error Message

30 May 2012   #1

Windows 7
 
 
Strange Not A Valid Email Address Error Message

Hi Everyone,

I've been experiencing a weird error message in Windows 7 - when I have to enter my email address to sign up for things in various places I get a strange error message saying this is not a valid email address. This happens irrespective of which browser I use (Chrome, Firefox, Safari) and across numerous websites and some applications like iTunes.

I tried typing my email adddress in Notepad, then copying into the relevant place and I was able to complete the registration without this error message, so the problem is not the email address. It's almost like Windows is doing something with the formatting of the address, that my browsers / programs don't like.

I've virus scanned the machine and actually done a complete clean install of Windows 7, but I still have this problem.

Anyone have any ideas what the issue could be???? Be very grateful for any help.

Many Thanks

F

My System SpecsSystem Spec
.

30 May 2012   #2

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

Which email service do you use? Or is the problem occurring with multiple email providers?
My System SpecsSystem Spec
30 May 2012   #3

Windows 7
 
 

Quote   Quote: Originally Posted by marsmimar View Post
Which email service do you use? Or is the problem occurring with multiple email providers?
Hi Marsmimar,

Thanks for replying. The problem occurs when I use any email address in a registration form, whether it's a corporate email or web based email like Gmail, but as I say, if I copy the email address into Notepad, then paste the same email address into the forms, the email address is accepted, which indicates the problem isn't the validity of the email address itself, but something else in the process of entering it directly which is why I was wondering if there is some sort of Windows setting that I'm missing or something...

The problem is cross browser as well, so it's not linked to a specific browser...

Thanks

F
My System SpecsSystem Spec
.


30 May 2012   #4

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

Couple more questions if I may. When did this problem first appear? Had you installed any new programs or updates just prior to the problem occurring? You say you did a clean install. Did you try logging in to any websites before installing windows updates? After installing WU but before installing any other programs or apps? It almost sounds like something on your machine may have changed permissions somewhere, somehow. I found this previous Seven Forums post. The OP finally determined that something that was loaded by the computer manufacturer was preventing him from logging in to websites.

http://www.sevenforums.com/browsers-...-websites.html

Don't know if this will help or not but it may provide a clue. Go to safe mode with networking via advanced boot options. Try logging in to some websites using one or more of your email addresses. You could also try a clean boot to troubleshoot problems.

Advanced Boot Options

Troubleshoot Application Conflicts by Performing a Clean Startup
My System SpecsSystem Spec
30 May 2012   #5

Windows 7 home premium x64
 
 

Could you post a screenshot and a copy\paste of your notepad text ?
My System SpecsSystem Spec
30 May 2012   #6

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

Quote   Quote: Originally Posted by cyclic View Post
Could you post a screenshot and a copy\paste of your notepad text ?
Hello Colin and welcome to the dilemma. Hope your engineering skills can come up with a fix.
My System SpecsSystem Spec
30 May 2012   #7

x64 (6.3.9600) Win8.1 Pro & soon dual boot x64 (6.1.7601) Win7_SP1 HomePrem
 
 

Please do not post your real address, instead express the address in an example:

My-email_address%20@SomeDomain.com

Are there any spaces or special characters in the address? It is not consistant, right (numerous sites/form, some applications). So it appears to me that there might be a code page issue. What is your default language / code page set to

English (us) Western Latin, UTF-8 ?
My System SpecsSystem Spec
Reply

 Strange Not A Valid Email Address Error Message




Thread Tools



Similar help and support threads for2: Strange Not A Valid Email Address Error Message
Thread Forum
Strange error message Backup and Restore
Email error message Browsers & Mail
Task Scheduler Error message “…arguments are not valid.” Performance & Maintenance
strange arma 2 'error message' Gaming
Strange Error Message in Event Viewer BSOD Help and Support
Strange error message Software

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:25 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33