Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Why does my internet explorer and google chrome take so long to start?

24 Jun 2012   #11
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

You might also try a clean start to see if it's a program interfering.

Troubleshoot Application Conflicts by Performing a Clean Startup

A Guy


My System SpecsSystem Spec
26 Jun 2012   #12
Cyanide

Windows 7 Home Premium x64 Service Pack 1
 
 

Yea I think it fixed the problem. My google chrome is a lot faster now. I haven't checked IE7 yet, but im not taking chances until i fix my installing IE9 problem. so i'll mark this topic as fixed thanks for the help!
My System SpecsSystem Spec
28 Jun 2012   #13
Gornot

Windows 7 Home Premium x64
 
 

No problem, glad you sorted it out
My System SpecsSystem Spec
Reply

 Why does my internet explorer and google chrome take so long to start?




Thread Tools





Similar help and support threads
Thread Forum
Internet Explorer 11 & Google Chrome - Help with Performance
I need help with IE 11 and Google Chrome. I had IE 11 running pretty smoothly and fast. Now, all of a sudden, its slow again. The performance of the computer is fine. I am wondering if I should disable any add ons?
Browsers & Mail
Google Chrome on initial startup takes too long to load
Hi, so after using google chrome for about a year and having no problems whatsoever, just today I encountered one where the initial startup takes a very long time about 10-15 minutes, and this is only on initial launch, as when I keep chrome open any new chrome windows I launch load normally which...
Browsers & Mail
Sound on google chrome and internet explorer only works on youtube
my sound just randomly stopped working on google chrome and internet explorer it only works for certain things like youtube but doesn't work for facebook or other video sites. just before it happened i had been visiting some proxy sites could this have damaged it? perhaps a virus of some sort?...
Sound & Audio
No sound In Google Chrome, Firefox or Internet Explorer, but wmp works
Hello, Everything Was fine Until two days ago. I have audio in Windows media player, CD's, games and programs but for some very odd reason, I get absolutely NO audio in any browsers. That includes Google Chrome, FF, IE and even Safari. I have re-installed all browsers, re-installed java/flash...
Sound & Audio
Internet Explorer, Google Chrome and Firefox WON'T OPEN!
:mad: Irritating! I was on the Channel 4 website watching videos, then I closed Google Chrome, opened iTunes (which incidentally doesn't work now either, keeps freezing), tried to go back into Google Chrome, no joy, neither with Firefox or IE. They just won't open! What's going on here?!
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:19.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App