Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Why does my internet explorer and google chrome take so long to start?

18 Jun 2012   #1
Cyanide

Windows 7 Home Premium x64 Service Pack 1
 
 
Why does my internet explorer and google chrome take so long to start?

Okay,

I'm not really sure how to explain this besides what I have to say now. My google chrome, and Internet explorer 7 take forever to startup. My Internet explorer freezes upon opening and my google chrome takes so long to load. My friends say its my Internet connection or my computer sucks. But I'm not sure about the cause, so is there anything I can do to speed up the time it takes my browsers to load?


My System SpecsSystem Spec
.
19 Jun 2012   #2
Gornot

Windows 7 Home Premium x64
 
 

This is peculiar as Chrome and IE are quite different.

Even before I finished reading your post I thought that the latest update to Adobe Flash might cause this, but then I remember that Chrome has its own version of Flash built-in.

So perchance this may be due to Java loading slowly? This is just a shot in the dark, though.
Do you have the latest update for Java 7? or Java 7, in fact, at all? The v7 release is somewhat new...
My System SpecsSystem Spec
19 Jun 2012   #3
Cyanide

Windows 7 Home Premium x64 Service Pack 1
 
 

I'm not even sure. I have a Java setting on my laptop but I don't keep track of my Java versions. But it hasn't updated in a while.

E: I have Java 6. Is there a way I can install Java 7
My System SpecsSystem Spec
.

20 Jun 2012   #4
Gornot

Windows 7 Home Premium x64
 
 

Just uninstall Java 6 then go to the Java website, download and install the newest available version of Java.
See if that helps.
My System SpecsSystem Spec
22 Jun 2012   #5
Cyanide

Windows 7 Home Premium x64 Service Pack 1
 
 

I will uninstall it but I cant update it until I get my Internet problem fixed.
My System SpecsSystem Spec
23 Jun 2012   #6
Gornot

Windows 7 Home Premium x64
 
 

You can always use another computer to download an offline installer and transfer it to your PC via flash drive...
My System SpecsSystem Spec
23 Jun 2012   #7
Cyanide

Windows 7 Home Premium x64 Service Pack 1
 
 

I don't have another computer. I have a tablet and a kindle fire.
My System SpecsSystem Spec
23 Jun 2012   #8
Gornot

Windows 7 Home Premium x64
 
 

If you can, download it to your tablet, then just connect it to the PC and transfer the exe then run the installer. Here's the link to the download you need:

http://javadl.sun.com/webapps/downlo...BundleId=64152

P.S: This is a direct link (though this is not the best practice on the forum, I posted a direct link to ease the problem for the OP)...
My System SpecsSystem Spec
23 Jun 2012   #9
Cyanide

Windows 7 Home Premium x64 Service Pack 1
 
 

Sweet. Thanks. Ill send it to my laptop in a moment and fill you in on the details about the browser startups.
My System SpecsSystem Spec
24 Jun 2012   #10
Gornot

Windows 7 Home Premium x64
 
 

Good.
Mind you, this might not be the solution to the problem at all, like I already said, this is just a blind shot in the dark. Still, updating Java is important for security reasons, so at least that will be out of the way.
My System SpecsSystem Spec
Reply

 Why does my internet explorer and google chrome take so long to start?




Thread Tools




Similar help and support threads
Thread Forum
Internet Explorer 11 & Google Chrome - Help with Performance
I need help with IE 11 and Google Chrome. I had IE 11 running pretty smoothly and fast. Now, all of a sudden, its slow again. The performance of the computer is fine. I am wondering if I should disable any add ons?
Browsers & Mail
Google Chrome on initial startup takes too long to load
Hi, so after using google chrome for about a year and having no problems whatsoever, just today I encountered one where the initial startup takes a very long time about 10-15 minutes, and this is only on initial launch, as when I keep chrome open any new chrome windows I launch load normally which...
Browsers & Mail
Sound on google chrome and internet explorer only works on youtube
my sound just randomly stopped working on google chrome and internet explorer it only works for certain things like youtube but doesn't work for facebook or other video sites. just before it happened i had been visiting some proxy sites could this have damaged it? perhaps a virus of some sort?...
Sound & Audio
No sound In Google Chrome, Firefox or Internet Explorer, but wmp works
Hello, Everything Was fine Until two days ago. I have audio in Windows media player, CD's, games and programs but for some very odd reason, I get absolutely NO audio in any browsers. That includes Google Chrome, FF, IE and even Safari. I have re-installed all browsers, re-installed java/flash...
Sound & Audio
Internet Explorer, Google Chrome and Firefox WON'T OPEN!
:mad: Irritating! I was on the Channel 4 website watching videos, then I closed Google Chrome, opened iTunes (which incidentally doesn't work now either, keeps freezing), tried to go back into Google Chrome, no joy, neither with Firefox or IE. They just won't open! What's going on here?!
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:31.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App