Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: (Loading issues )Need help with Google Chrome

18 Jul 2012   #1

Microsoft Window 7 Home Premium 64bit
(Loading issues) Need help with Google Chrome

Does anyone using Chrome have loading issues with facebook, windows live mail and such? I really like Chrome but like to fix this problem. To view the pages I have to reload/refresh to get them visable to read. Here's some screenshots.

Thank you all for your help!

My System SpecsSystem Spec
19 Jul 2012   #2

Microsoft Window 7 Home Premium 64bit

Hello everyone! I have solve the problem, it was a chrome extention called Pop up blocker. Awesome!!
My System SpecsSystem Spec
20 Jul 2012   #3

Windows 7 Home Premium 64bit

Wow! Your pop up blocker sure blocks everything.
My System SpecsSystem Spec


 (Loading issues )Need help with Google Chrome

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Google Chrome cursor alignment issue and fullscreen issues
So I have no idea what I did in the last 10 min but for some reason my browser (chrome) isn't aligning the cursor with the context menus and youtube fullscreen is the top left corner of the entire video. I haven't changed my resolution, I have tried setting chrome settings back to default, I have...
Browsers & Mail
Google Chrome Not logging into Google account, white screen
Before I even say anything, I have tried to reinstall Chrome 3 times and the problem still stands. So my problem is that when I try to login to my Google account on Google Chrome, the web page goes white and Chrome does not log in. The steps I took are as follows: It starts on the regular...
Browsers & Mail
Odd Issues: Explorer taking 70k, Chrome not loading pages,system hangs
i dont know where exactly to put this since it spans such a massive amount of software and hardware anyways: I have a Dell Inspiron M1050 with an AMD Triple Core (2.3 Ghz) and an ATI Radeon 4250 HD Integrated. 4 Gb RAM 500Gb HDD Windows 7 Home Premium x64 (obviously) so, ive had this...
General Discussion
Google Chrome not loading.
hi guys, Recently I transferred my entire OS on to a new hd When i restarted my pc with the data all on the new boot drive all seemed fine, however my google chrome does not work. A grey screen appears with all the tabs saying "untitled".:huh: Thanks in advance for any help:)
Browsers & Mail
Slow loading on pages in either IE9 or Google Chrome
Hello, I have switched to another ISP a couple of days ago. Once my modem/router was set up and everything was a go. However, the issue on web browsing popped up and is persisting ever since. I had never experienced this such problem when I subscribed to the previous ISP. The pages load way...
Browsers & Mail
Google Chrome Rendering Issues
Hi all. Since yesterday I've been having Rendering Issues with Google Chrome. (See Screenshot 1 and 3. It's not just on Wikipedia). And sometimes, it just fails to load and says "This Link is Broken" (See ScreenShot 2) While on FireFox and even IE it loads just fine. I'd changed my DNS settings to...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:18.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App