Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Google.co.uk always loads in Japanese?

24 Aug 2012   #1
Willp789

Windows 7 Home Premium 32bit
 
 
Google.co.uk always loads in Japanese?

When I open Google.co.uk in Chrome it comes in Japanese. Chrome points out that it's in Japanese (as if I didn't know!) and translates it. once it's in a badly translated English version under I'm feeling lucky and Search it says Google is offered in English. Once clicked the page is properly English - like normal. After I restart the comuter it goes back to Japanese! My account settings are set to English. This happens on two computers running Chrome. Please Help!


My System SpecsSystem Spec
.

24 Aug 2012   #2
BrightBlessings

Win7 Pro-64 Bit
 
 

Don't know if this will help you - anyhow have a gander.

Google.com automatically takes me to another Google site - Web Search Help
My System SpecsSystem Spec
25 Aug 2012   #3
Willp789

Windows 7 Home Premium 32bit
 
 

Thanks BrightBlessings... your link appears to have helped me
My System SpecsSystem Spec
.


27 Aug 2012   #4
vetvadi

Windows home premium 64 bit
 
 

you save that one also

https://www.google.com/webhp?hl=en&tab=ww google global


beside www.google.com/nrc
My System SpecsSystem Spec
Reply

 Google.co.uk always loads in Japanese?




Thread Tools





Similar help and support threads
Thread Forum
Japanese text
(Sorry if this is in the wrong board, didn't exactly know where to post it) Hey guys I'm new to the forums, should be interesting as I'm new to Windows 7 (previously used XP and Vista) so I can learn things about my new OS. I'm running Windows 7 Home Premium 64-bit version which came...
Customization
Nothing Loads In Google Chrome
Well today when i go to browse on chrome. Nothing loads up. If i click on a bookmark, the loading spins for a few mili seconds and stops and nothing loads but internet explorer still works. What is happening
Browsers & Mail
google chrome crashes and loads pages very slow
All day yesterday I was browsing the internet with no problems which includes me playing games and browsing the web today however. Whenever I go to youtube the videos load and play just fine but the thumbnails only appear black, after about a minute or so of watching a video the thumbnails will...
Browsers & Mail
Japanese Win 7 Ultimate - Text Input in Japanese
Dear All, Sorry if this is in the wrong place, couldn't spot a Language/Region sub forum. Anyway, I hope someone can help with the following problem: 1. My PC is a Japanese Dell that came pre-installed with Win 7 Home. 2. I used Windows Anytime Upgrade to bump it up to Win 7 Ultimate. 3. I...
General Discussion
Memory Dump- might need some Japanese
My computer is a Fujitsu with I think its Windows 7 Professional (Japanese Version) using wireless link to Fiber Internet Connection. Intel. OEM Everything is about 11 months old. Just shutdown via Memory Dump twice.
BSOD Help and Support
Flash drive driver loads-unloads-loads....
I bought a FlashVoyager 16GBGT in September for use with my XP pro machine and all was fine. I have now upgraded to Windows 7 Pro 32-bit and I can no longer use the flash drive. When I plug it into a port the Autoplay window pops up for a few seconds and then disappears, then reappears, then... and...
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App