Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Chrome can't open the first page when it starts

09 Sep 2012   #1
bonedriven

Windows 7 Ultimate 64bit
 
 
Chrome can't open the first page when it starts

This applies to my home page as well. Similarly, when I click on a link from mail client or other windows, which will automatically be opened in my default web browser Chrome, the page will load forever and never be opened. Refresh doesn't work either. But if I copy the link and open in a new tab, it can be opened normally.


My System SpecsSystem Spec
.
10 Sep 2012   #2
exoTron

Windows 7
 
 

I used to have a similar issue with my Chrome last year (the then current version is an outdated anyways) The problem consisted of Chrome not opening any page from the startup tab at least for a minute after it loaded. Even if you copy/paste the address in the startup tab and hit Enter, the address line will automatically get cleared and nothing would happen. If I opened a new tab and pasted the link instead, all would be fine.

Sounds somewhat different to your problem, however, as you say the page loads forever. Are you using Chrome 21?

I guess a reinstall would fix the issue.
My System SpecsSystem Spec
Reply

 Chrome can't open the first page when it starts




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
chrome open a page in background
is there any way for chrome to open a link in background by default right now i have to press ctrl + left mouse click in chrome i am using laptop so pressing middle mouse button is not an option for me forgive my poor english
Browsers & Mail
Chrome won't open, Java control panel won't open..
Chrome goes to a page that never loads then hangs and the Java Control panel won't open just the box frame of it will show. I've done just about everything I possibly can to remove java from the computer with exception to a re-format; something I'd rather not have to do. Chrome works in the...
Software
chrome launches on login black background, before explorer starts
hmm this is a wierd one. after resolving a system problem (public directories getting locked out, admin profile getting locked out) by creating new users, running a series of malware removal tools, chrome and or windows is doing something very oddd. on login of (new) admin account, and...
Browsers & Mail
Chrome does not work, no web page opens. Opens as a blank page.
I've been experiencing this issue and at last I was able to solve it yesterday. Right Click to Google Chrome exe file, select Properties. In the opened window select Compatibility column, Set Compatibility Mode to Windows 7. Mine was set to Windows XP SP2, that was the problem... For more...
Browsers & Mail
WMP starts when trying to open MKV files without playing the clips
Hi I'm having some strange issue lately. I'm using KMPlayer as my default media player and Win7 Codecs by Shark007(for other players that don't come with integrated codecs). I usually use the integrated codecs within KMPlayer and everything works fine. However, for some time now every...
Music, Pictures & Video
Chrome Gets XSS Filter and Starts Disabling Outdated Plug-Ins
More - Chrome Gets XSS Filter and Starts Disabling Outdated Plug-Ins - Softpedia
News


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:57.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App