Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: All browsers are not opening

12 Sep 2012   #1
eatingstick

Windows 7 Home Premium 64bit
 
 
All browsers are not opening

Hi all,
I'm new on this forum so please be patient.
Working with a Toshiba Satellite L650 laptop with Windows 7 Home Premium 64bit.
All of my browsers have suddenly stopped working (IE, Firefox and Chrome).
I click on the icon, the "loading" mouse pointer shows up and then nothing happens.
I've tried restarting my computer, checking for updates and doing a virus scan... nothing is working.
I am now writing from another computer because I'm not able to access any webpage from the one that's having problems.
My Avast antivirus says my computer is clean and I have no way of downloading any other software since browsers are not opening.
Skype is working so I'm guessing the internet connection itself is ok.
Can anyone help please?
Thanks



My System SpecsSystem Spec
.
14 Sep 2012   #2
UsernameIssues

W7 Pro SP1 64bit
 
 

Welcome to the Seven Forums.

Try a scan with this tool:
What is Windows Defender Offline?
Either burn a CD or use a USB flash drive.
My System SpecsSystem Spec
14 Sep 2012   #3
eatingstick

Windows 7 Home Premium 64bit
 
 
still not working

Hi UsernameIssues,
first of all thank you for replying.
I downloaded the offline defender, installed it on a pendrive, booted the laptop with it and it found a "risky" keygen file. I had the defender take care of it even though it was a "safe" keygen. Had the defender do another scan and it said everything was ok.
After that I uninstalled google chrome, installed it again and it's still not opening (same thing happens with firefox and IE).
Can you recommend anything else?
Thanks again.
My System SpecsSystem Spec
.

14 Sep 2012   #4
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Go to Internet Options/Settings/Connection/Lan and make sure Proxy is unchecked.
My System SpecsSystem Spec
14 Sep 2012   #5
eatingstick

Windows 7 Home Premium 64bit
 
 

internet options in the browser?
I am connecting through wi-fi and not LAN.
My System SpecsSystem Spec
14 Sep 2012   #6
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Do you have any/or browsers that work? If so which.
My System SpecsSystem Spec
15 Sep 2012   #7
UsernameIssues

W7 Pro SP1 64bit
 
 

Please open Task Manager and select the tab named Processes.

Please try and start IE.

Is IE showing in the list of things running?

If you saw IE show for just a second, then something is shutting it down.

Consider starting with step 3 from gregrocker's tut: Troubleshooting Steps for Windows 7
My System SpecsSystem Spec
15 Sep 2012   #8
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Welcome to Seven Forums eatingstick. 2 things to try to see if you have internet connectivity at all.

Open an advanced command prompt

Start> In search box type cmd> Right click on cmd.exe in results above and choose Run as administrator> When the command prompt opens type ping www.sevenforums.com> Enter

Does it perform the ping and give results? Or does it say it cannot connect?

Also you can boot to safe mode with networking, and see if you can open browsers there and connect to the net.

Safe Mode

If you can connect in safe mode, try a clean start and see if something is blocking your browsers.

Troubleshoot Application Conflicts by Performing a Clean Startup

Let us know the results. A Guy
My System SpecsSystem Spec
16 Sep 2012   #9
eatingstick

Windows 7 Home Premium 64bit
 
 

@Layback Bear non of my browsers (IE, FF, Chrome) are working.
@A Guy I am able to use skype and online gaming so internet connection is not the problem.
@UsernameIssues The browsers open up in the task manager and then disappear, I will try to follow those steps and post back.
My System SpecsSystem Spec
15 Nov 2012   #10
alkarim77

Windows XP
 
 

Dears,

I am also facing the similar problems. Working with a Toshiba Satellite laptop with Windows XP. All of my browsers have suddenly stopped working (IE, Firefox and Chrome).I click on the icon, the "loading" mouse pointer shows up and then nothing happens. I've tried restarting my computer, checking for updates and doing a virus scan... nothing is working.
I am now writing from another computer because I'm not able to access any webpage from the one that's having problems.
My Avast antivirus says my computer is clean and I have no way of downloading any other software since browsers are not opening. Yahoo messenger is working so I'm guessing the internet connection itself is ok.
Can anyone help please?
Thanks
My System SpecsSystem Spec
Reply

 All browsers are not opening




Thread Tools





Similar help and support threads
Thread Forum
Internet browsers not opening or responding
Hey there. Recently on my dads computer, there have been some problems trying to open any internet browser. The only one that responds with anything is Mozilla, which flags an error, saying ''Couldn't load XPCOM". The others are completely unresponsive, not opening or giving errors of any sort. ...
Network & Sharing
Issues With Opening Internet Explorer 9/10 and Maxthon Web Browsers??
Hello. I am having an issue with Windows 7's Internet Explorer 9 (or version 10 too -- I tried what I am going to say here too without any difference to version 9) and Maxthon web browser. Simply, when I click on many hyperlinks of most websites' webpages or even clicking on any on of...
Browsers & Mail
BSOD opening different browsers
hello in past few days i'm continuously experiencing BSD crash due to clicking on firefox, chrome and even excel! i don't know what's the main problem so i uploaded all dump files to my dropbox can any one please help me? thanks
BSOD Help and Support
web browsers are not opening
Guys need help, non of my browsers are even opening. Whenever i click on IE or mozila browser icon, no response is there. I need to fill an online exam form .so it is very imp. Kindlysuggest any way out. Iam posting this using my phone
Browsers & Mail
Browsers are opening as buttons on the taskbar only
When I try and open Firefox and/or IE 9, they will only open as buttons on the taskbar. No window on the desktop. I can preview them with Aero peek but when I right click on the taskbar button and select maximize, restore, minimize nothing happens. I have looked at the properties on all of the...
Browsers & Mail
Browsers, Windows system tools not opening.
Whenever I try to open any browser except IE(Mozilla/Chrome/Opera) or even any Windows System Tools like msconfig,cmd,system information or even System Restore, an alert box is popped up saying : 'The version of this file is not compatible with the version of Windows you're running. Check your...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:00.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App