Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: google chrome crashes and loads pages very slow

11 Nov 2012   #1
bigboi972

Microsoft Windows 7 Professional 64-bit
 
 
google chrome crashes and loads pages very slow

All day yesterday I was browsing the internet with no problems which includes me playing games and browsing the web today however. Whenever I go to youtube the videos load and play just fine but the thumbnails only appear black, after about a minute or so of watching a video the thumbnails will eventually load up and appear as they should. I have included an image to show exactly what im talking about. Also at different times of the day today I noticed that my browsing experience would be very slow on my laptop not allowing me to watch videos while still allowing me to play games that required me to be connected to the internet and while doing so I had no lag/latency and when I tested my connection on two ipads and an additional laptop neither device had any of these issues. Only my current laptop. I have tryed using system restore to restore my pc back to a point in time where this issue did not happen but that has not worked I have tryed using firefox and the issue still occurs. I have even reinstalled chrome and cleared chromes browser cache and history along with its cookies as well.

http://img594.imageshack.us/img594/4180/problemft.jpg


My System SpecsSystem Spec
.
11 Nov 2012   #2
Injust

Windows 7 64-bit
 
 

Looks like you have at least 8 different extensions :O
Disable each of them and try again. Also, go to about:flags and disable anything that you have enabled.
Also, run command prompt (press Windows+R, enter "cmd.exe" without the quotes, and press enter), and the command is:
Code:
ipconfig /flushdns
.
My System SpecsSystem Spec
11 Nov 2012   #3
bigboi972

Microsoft Windows 7 Professional 64-bit
 
 

what is about flags. What do you mean by that
My System SpecsSystem Spec
.

11 Nov 2012   #4
Injust

Windows 7 64-bit
 
 

That just means that you haven't messed with the experiments
Follow the other instructions.
My System SpecsSystem Spec
11 Nov 2012   #5
bigboi972

Microsoft Windows 7 Professional 64-bit
 
 

ok i did everything you said also what does the ipconfig /flushdns do i got a message that says "flushed the dns resolver cache" thanks again ill see how this works for the rest of the night
My System SpecsSystem Spec
Reply

 google chrome crashes and loads pages very slow




Thread Tools






Similar help and support threads
Thread Forum
IE 11 & Google Chrome is Slow
My 2 browsers which are IE 11 and Google Chrome have slowed down again. I had IE 11 running fast. Now, it's slowed down again. The performance of the computer seems fine.
Browsers & Mail
Windows running Slow as well as Google chromes Web pages
Hello everyone in the last two weeks I have been having problems with my windows loading all my programs extremely slowly as well as Google Chrome browser loading a new tab slowly (I have a 100MB internet so it's not that.) I Have ran superantispyware, Malwarebytes and Spybot with none of them...
Performance & Maintenance
Browser Google Chrome is slow.
I ran malwarebytes, did the cleanup, and it is still slow. What else can I download for free to fix it?
Browsers & Mail
Google Chrome BSOD's and Aion game crashes
Not certain if this is the appropriate forum, but was suggested in gaming forum to post here instead. Have been plagued with repeated aion game crashes since start. Someone who looked at error report said it might be a video driver issue, but after trying to update every drtiver I can think of...
BSOD Help and Support
Nothing Loads In Google Chrome
Well today when i go to browse on chrome. Nothing loads up. If i click on a bookmark, the loading spins for a few mili seconds and stops and nothing loads but internet explorer still works. What is happening
Browsers & Mail
Slow loading on pages in either IE9 or Google Chrome
Hello, I have switched to another ISP a couple of days ago. Once my modem/router was set up and everything was a go. However, the issue on web browsing popped up and is persisting ever since. I had never experienced this such problem when I subscribed to the previous ISP. The pages load way...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:45.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App