Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: IE9 did not finishing installing on Windows 7 64-bit

17 Dec 2012   #1
captain123

Microsoft Windows 7 Enterprise SP1 64-bit
 
 
IE9 did not finishing installing on Windows 7 64-bit

Hi,

I did a clean install of Windows 7 64bit Enterprise Edition. Downloaded the IE9 offline installer i.e. IE9-Windows7-x64-enu.exe but was never able to install it. The error is: "Internet Explorer did not finish installing. For more information, see the Internet Explorer Troubleshooter. This link is also on your desktop for later reference." The OS came with IE8 as default, the interesting thing is that when I go to Programs and Features > Turn Windows Features on or off, I see IE9 there not IE8 ! As I said I was never able to install IE9. Things I tried:

-Removed IE8 from Turn Windows Features on or off, rebooted, tried installing IE9 cleanly
-Tried in Safe Mode with and without networking
-Turned AV/firewall off
-Run in CMD sfc /scannow
-Tried Windows Update, but it never comes up as an update
-Checked Programs and Features > View Installed Updates, not there also
-Run the Windows Install Cleanup Tool
-Tried installing using Windows Clean boot
-Run Windows Update Readiness Tool from MS but found no errors

No matter what I did I always came up with the same error described above. Can someone help please ?

Thank you.


My System SpecsSystem Spec
.

17 Dec 2012   #2
liverpal

Windows 7 SP1 Ultimate x86
 
 

try online installer! I also ever faced same problem! Don't forget to open IE, who knows it's just upgraded to IE9 by checking at ''about' and also check for update patch for IE as IE has many security issues
'
My System SpecsSystem Spec
17 Dec 2012   #3
captain123

Microsoft Windows 7 Enterprise SP1 64-bit
 
 

Quote   Quote: Originally Posted by liverpal View Post
try online installer! I also ever faced same problem! Don't forget to open IE, who knows it's just upgraded to IE9 by checking at ''about' and also check for update patch for IE as IE has many security issues
'
Can you please clarify what you mean by online installer ? I have already tried the online installer provided in the Browsers link section of this forum, error is exactly the same as with the offline one. Can you provide a link for it ? If you are referring to Windows Update - IE9 does not show up under the list with avaialble updates. It looks like Windows thinks that IE is already updated to IE9, but in fact if you open the about section on the browser it show IE8 and it completely looks like it
My System SpecsSystem Spec
.


17 Dec 2012   #4
liverpal

Windows 7 SP1 Ultimate x86
 
 

I mean online installer that is from m$ website! I did some trials actually until it completely installed in win 7 with good internet connection! Yes, windows update for IE; though I rarely use IE, every update for it is always installed since IE is vulnerable web browser!
My System SpecsSystem Spec
17 Dec 2012   #5
captain123

Microsoft Windows 7 Enterprise SP1 64-bit
 
 

Quote   Quote: Originally Posted by liverpal View Post
I mean online installer that is from m$ website! I did some trials actually until it completely installed in win 7 with good internet connection! Yes, windows update for IE; though I rarely use IE, every update for it is always installed since IE is vulnerable web browser!
As I said this is not working for me, any other suggestions please ?
My System SpecsSystem Spec
17 Dec 2012   #6
liverpal

Windows 7 SP1 Ultimate x86
 
 

My System SpecsSystem Spec
17 Dec 2012   #7
LittleJay

Windows 7 Home Premium 64bit SP 1
 
 

Quote:
Removed IE8 from Turn Windows Features on or off, rebooted, tried installing IE9 cleanly
So at the moment, if you click on the IE icon, no web browser comes up at all?

I ask because you said that you turned IE8 off in "Turn Windows Features On or Off" and that even though IE9 didn't finish installing, it now (IE9) shows up in the listing. I just checked for IE9 under "View installed updates", but didn't see it listed, even though it is indeed the version that is installed on this computer. And yes, my original Windows 7 install came with IE8 as well.
My System SpecsSystem Spec
06 Jan 2014   #8
captain123

Microsoft Windows 7 Enterprise SP1 64-bit
 
 

Yes, when I removed the check mark right next to IE8 in turn Windows features on and off the browser is no longer showing up, there is no IE icon to click on.
My System SpecsSystem Spec
06 Jan 2014   #9
captain123

Microsoft Windows 7 Enterprise SP1 64-bit
 
 

Hi Guys,

The issue is still not solved after all that time ! All suggestions are welcome, thank you !
My System SpecsSystem Spec
06 Jan 2014   #10
ThrashZone

Win-7 H-Premium 64-bit sp1
 
 

My System SpecsSystem Spec
Reply

 IE9 did not finishing installing on Windows 7 64-bit




Thread Tools





Similar help and support threads
Thread Forum
Windows 7 gets stuck after installing restart @ Finishing Installation
Hey there, i did some searching beforehand, but cant find anything satisfying my specific needs for my troubles... I spent the whole day installing and researching... In case anyone knows where i can find further help, please let me know. System Specifics: Every part of the computer is...
Installation & Setup
Windows 7 Setup Freezes After "Finishing Installation" with Intel Q963
(Note, this is a mirror of a very similar thread over on the Microsoft forums) So I got this Optiplex 745 and figured I could just throw in a hard drive, install Windows 7, and everything would be good. This has actually been the most frustrating setup I've ever experienced - full details...
Installation & Setup
Finishing A Build, Opinions?
Sorry if this is in the wrong thread, appeared to be the most logical place to put it. I try not to clutter forums with stuff like this so I do apologize. I'll try to keep the fluff to a minimum. Was going to do a new build 7 months ago, bought parts, some stuff broke, didn't finish it, and...
PC Custom Builds and Overclocking
Build Needs Finishing
Sorry if this is in the wrong section. Rant: (Optional Info) I bought new parts to rebuild my pc during September, I put it all together and it worked for a few minutes till I shut it off. The next day I tried to start it up and it worked for 30 seconds before it crashed at the loading...
PC Custom Builds and Overclocking
Windows 7 problem after finishing install
Hello there, Ive been having a problem installing Windows 7. I have a Gateway P6860 FX, Windows Vista Home Premium 64x, that has its own RECOVERY Partition. The thing is, when I try to upgrade from Vista it tells me I cannot upgrade from 32 to 64x (although I have a 64x Vista) so I proceed to...
Installation & Setup
Need help finishing the setup
i have a error(prk) finishing the install. Please help me
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:50.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App