Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Internet Explorer 8 Bug

03 Oct 2009   #1

Windows 7 Professional x64
 
 
Internet Explorer 8 Bug

When running Internet Explorer 8 and you open a new tab it randomly crashes and the usual error options come up asking to send info to Microsoft, close program or debug the program.

It's a real pain but does it happen to anyone else?

My System SpecsSystem Spec
.

03 Oct 2009   #2

Windows® 8 Pro (64-bit)
 
 

did you check in event viewer or reliability report for any clue?
My System SpecsSystem Spec
03 Oct 2009   #3

Windows 7 Ultimate SP1 x64
 
 

Same happens to me. I found a fix thought google, but it only works during THAT session, the next time you start OS same problem. I switch to FireFox for now.
My System SpecsSystem Spec
.


03 Oct 2009   #4

Win7x64
 
 

Quote   Quote: Originally Posted by QuackPot View Post
When running Internet Explorer 8 and you open a new tab it randomly crashes and the usual error options come up asking to send info to Microsoft, close program or debug the program.

It's a real pain but does it happen to anyone else?
In addition to what Dinesh said, try selectively disabling your IE add-ons until the problem no longer occurs. Iexplore is a bit like a "container" process - on most people's machines there are non-default modules (of varying code quality) running in there.

SFC /SCANNOW wouldn't go astray either, just in case one of the IE modules is itself corrupted.
My System SpecsSystem Spec
03 Oct 2009   #5

 

Not exactly off-topic, but certainly divergent -

For many builds, IE8 will frequently prompt me to setup my preferences. As many times as I have seen the screen, I should be able to describe it better, but... I can't.

I just click Ask Me Later and continue to use my previously selected prefs.
My System SpecsSystem Spec
03 Oct 2009   #6

Windows 7 Ultimate SP1 x64
 
 
Here is the fix I spoke of in my ealier reply.

To resolve this issue, re-register the DLL files that are related to Internet Explorer. To do this, follow these steps:

1. Click Start, and then click Run

2. Type regsvr32 urlmon.dll in the Open box, and then click OK.

3. Click OK when you receive the following message:

■DllRegisterServer in urlmon.dll succeeded
4. Repeat steps 1 through 3 for the rest of the DLL files by replacing the regsvr32 urlmon.dll command in the Open box with the following commands:

■regsvr32 actxprxy.dll
■regsvr32 shdocvw.dll
■regsvr32 mshtml.dll
■regsvr32 browseui.dll
■regsvr32 jscript.dll
■regsvr32 vbscript.dll
■regsvr32 oleaut32.dll
Now your IE8 Open in New Window/Tab feature, should work simply fine. __________________
My System SpecsSystem Spec
04 Oct 2009   #7

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by Antman View Post
Not exactly off-topic, but certainly divergent -

For many builds, IE8 will frequently prompt me to setup my preferences. As many times as I have seen the screen, I should be able to describe it better, but... I can't.

I just click Ask Me Later and continue to use my previously selected prefs.
I've had that as well. I can only hope there will be an update to fix this on the 22nd.

Quote   Quote: Originally Posted by KnowOne View Post
To resolve this issue, re-register the DLL files that are related to Internet Explorer. To do this, follow these steps:

1. Click Start, and then click Run

2. Type regsvr32 urlmon.dll in the Open box, and then click OK.

3. Click OK when you receive the following message:

■DllRegisterServer in urlmon.dll succeeded
4. Repeat steps 1 through 3 for the rest of the DLL files by replacing the regsvr32 urlmon.dll command in the Open box with the following commands:

■regsvr32 actxprxy.dll
■regsvr32 shdocvw.dll
■regsvr32 mshtml.dll
■regsvr32 browseui.dll
■regsvr32 jscript.dll
■regsvr32 vbscript.dll
■regsvr32 oleaut32.dll
Now your IE8 Open in New Window/Tab feature, should work simply fine. __________________
I'll give that a go. +rep.
My System SpecsSystem Spec
Reply

 Internet Explorer 8 Bug





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:08 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33