Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Who has installed ie10? and what do you think?

08 Mar 2013   #31
hollyoaks777

windows 7
 
 

Quote   Quote: Originally Posted by AddRAM View Post
It`s OK, I don`t like the small address area, I am staying with IE8, I like it. A browser is a browser, nothing to loose sleep over.
Snap, they have changed it far to much, it looks much like Firefox but at least you get a small google add on with Firefox with IE9 and 10 you don't. Therfore I will be staying with IE8 and when it's no longer supported I will move to another browser but it won't be IE9 or 10 or 11 unless they change it.


My System SpecsSystem Spec
.
11 Mar 2013   #32
flashbgone

Window 7 Home Pemium 64 bit
 
 

I like it overall. The only thing that plucks me is that I still have to install Adobe Flash activex control to use some web sites. I'm not going to Install Adobe Flash though. I'll just no longer visit those web sites. I may miss my online news radio though. This is a problem.
My System SpecsSystem Spec
11 Mar 2013   #33
Scottyboy99

Windows 7 Ultimate 64 bit
 
 

I actually liked IE10. Normal web browsing on external sites seemed excellent. What I could not get past was severe delays accessing 'internal stuff' through the web browser. If I wanted to visit my router's web page on 192.168.1.1 it would often take about 10-15 seconds of 'waiting for response from ......' before it loaded the admin page. Same went for accessing one of NAS drives admin pages on 192.168.1.8, similar delay. I even had intermittent delays accessing my ftp drive. Totally miffed really. Why external 'web' pages were great and internal stuff was prone to wait for response (sometimes quick access but no real pattern).

That was a deal breaker for me - although now youtube is doing HTML5 video I noticed IE10 is much more fluid and less glitch running full screen video than IE9. Totally torn. I am tempted to try IE10 again. I updated via website before, maybe I should do it via windows update this time now it is being offered.

Would flushing DNS help this sort of thing with trying to access internal devices via their browser UI?

Thanks,
Wayne
My System SpecsSystem Spec
.

11 Mar 2013   #34
cyclic

Windows 7 home premium x64
 
 

I thought about it, read its details and decided I needed it as much as I need W8, which would be never. Yes I have tried W8 but it only took a few hours before I found IT very trying.
My System SpecsSystem Spec
11 Mar 2013   #35
UsernameIssues

W7 Pro SP1 64bit
 
 

Quote   Quote: Originally Posted by Scottyboy99 View Post
...Would flushing DNS help this sort of thing with trying to access internal devices via their browser UI?

Thanks,
Wayne
Nope - there is no DNS involved when surfing to 198.168.1.8 or the like. There is no domain to turn into an IP address (which is what DNS does). You are already starting with an IP address for most internal devices. Maybe clearing the temp files might help, but I don't see how or why temp files would matter much.
My System SpecsSystem Spec
11 Mar 2013   #36
Scottyboy99

Windows 7 Ultimate 64 bit
 
 

Ok thanks. I will try some point over the next couple days to redeploy IE10 via windows update and see what happens. I am totally perplexed at what I initially saw with problems / delays accessing internal device admin pages. No such problem with firefox 19 which provides instant access and smooth HTML full screen playback.
My System SpecsSystem Spec
11 Mar 2013   #37
Scottyboy99

Windows 7 Ultimate 64 bit
 
 

Well I tried to update again via windows update. Same issues with accessing some internal devices browser interfaces. Other than that I will say it seems very fast and otherwise good. But I don't really notice the speed difference running a cache SSD. as much as I hate being behind on updates the intermittent delays to my device interfaces outweighs the good so I went back to IE9. Suspect it's early bugs and compatibility problems as the devices were designed when IE8 was the king. Maybe in time IE10 will iron out some niggles. Til then it's IE9 for me, it's more compatible across the web and really doesn't seem much different
My System SpecsSystem Spec
18 Mar 2013   #38
myarmor

Windows 7 Professional x64 Retail
 
 

Well, it's ok I guess. Except one thing.. I have Forte Agent 7.0, and after installing IE10 instead of opening
the mail client when a mailto link is clicked in FF19.0.2 it repeatedly starts IE (1-2 per second).
Setting it to use Agent as default (inside Agent) or set it to use Agent in FF doesn't help.
I guess they've made the mailto protocol handling incompatible with its previous iteration or something.

I'm apparently not alone experiencing this as I noticed someone complained about the same, but with another email client.
My System SpecsSystem Spec
18 Mar 2013   #39
GeneO

Windows 10 Pro. EFI boot partition, full EFI boot
 
 

Was IE9 color managed? I don't know, I skipped IE9.But IE10 is and that is one of my requirements for photography.
As far as performance, it is about equal to Firefox, which has been my main stay.

Is your system ICC Version 4 ready?
My System SpecsSystem Spec
19 Mar 2013   #40
UsernameIssues

W7 Pro SP1 64bit
 
 

Quote   Quote: Originally Posted by GeneO View Post
Was IE9 color managed? I don't know, I skipped IE9.But IE10 is and that is one of my requirements for photography.
As far as performance, it is about equal to Firefox, which has been my main stay.

Is your system ICC Version 4 ready?
I see no difference between IE9 and IE10 on that test page.
My System SpecsSystem Spec
Reply

 Who has installed ie10? and what do you think?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
How to go to IE10 from IE11 if it was never installed
Hi, I am running into issues with IE11 not working well in my environment and would like to drop down to IE10. However IE10 was never installed via Windows Update, so when I uninstall IE11 in installed updates, I end up back on IE8. But then when I try to update to IE10 I get a 9c59 error, and...
Windows Updates & Activation
Cannot run ie10, cannot install ie9/11 (ie10 installed)
ok, I believe this is due to some bad windows update, but there isn't a list that i can locate to uninstall. I've already tried force uninstall all remnants, using: --- FORFILES /P %WINDIR%\servicing\Packages /M Microsoft-Windows-InternetExplorer-*11.*.mum /c "cmd /c echo Uninstalling...
Windows Updates & Activation
installed HD 2600 pro card, installed AMS driver, but no ccc software?
I was wondering if this would help? http://www.sevenforums.com/graphic-cards/195195-fix-catalyst-control-center-ccc-will-not-open-install.html I see no evidence that the AMD driver installed at all. Right click desktop does not show ccc, and ccc is not in the lower right panel. Windows...
Graphic Cards
IE9 Update Won't Disappear Though Already Installed, IE10 Update Fails
Hello, I am running on a machine running Windows 7 Home Premium x64. Other Windows Updates are working fine, but for some reason, the Windows Update for IE9 keeps appearing (and failing) even though IE9 is already installed. The update for IE10 (as well as the manual installer) also fail. ...
Windows Updates & Activation
MIXDJ ???? installed IE10 in win7 and suddenly it shows up as search
page for every new tab in IE10? what is it and how to ged rid of it? How did it get there? I installed ie10 from the ms windows site
System Security
Problem reinstalling ie9 after ie10 installed
Good day all. I tried ie 10 on windows 7, was not satisfied. Tried to unistall it from control panel/turn windows features on or off by uncheck Internet explorer 10, after that no ie available, tried to install ie 9 or ie 10 again with no luck as it says "Internet Explorer did not finish...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:57.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App