Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Firefox 3.5.3 Problem

10 Oct 2009   #1
Ghamper

Windows 7 Ultimate 32-Bit
 
 
Firefox 3.5.3 Problem

I hate for my first post to be a problem but I have no where else to turn. I am currently running Firefox 3.5.3 and Windows 7 Ultimate now when I open a web page in firefox it opens fine but its like the page freezes as soon as it opens. For example if I load up Facebook and then click someones page it doesn't load the page unless I move my mouse first. It does this on my downloads window as well and its become quite an annoyance. Any help is greatly appreciated.


My System SpecsSystem Spec
.

10 Oct 2009   #2
Zen00

Windows 7 Ultimate x64
 
 

I'm running the same version and have no problems. It just might be a problem with your install.
My System SpecsSystem Spec
11 Oct 2009   #3
rsvr85

Windows 7 Ultimate x64
 
 

Hi Ghamper, welcome to sevenforums

Open a command prompt and type taskkill /f /im firefox.exe

Then type this into your 'run' box. %programfiles%\Mozilla Firefox\firefox.exe -safe-mode

If that still doesn't do the trick, completely uninstall firefox reboot and reinstall firefox, let us know.
My System SpecsSystem Spec
.


11 Oct 2009   #4
Ghamper

Windows 7 Ultimate 32-Bit
 
 

Thanks for the help guys. I ended up having to uninstall then reinstall but now it works fine. Once again thanks.
My System SpecsSystem Spec
11 Oct 2009   #5
Zen00

Windows 7 Ultimate x64
 
 

Your welcome, hope your next problem doesn't require the reinstall.
My System SpecsSystem Spec
11 Oct 2009   #6
rsvr85

Windows 7 Ultimate x64
 
 

Glad you got it sorted in the end. Did you try safe mode or did you just go straight for a reinstall?
FEBE extension for Firefox is great for when these sort of things happen
My System SpecsSystem Spec
11 Oct 2009   #7
Ghamper

Windows 7 Ultimate 32-Bit
 
 

Quote   Quote: Originally Posted by rsvr85 View Post
Glad you got it sorted in the end. Did you try safe mode or did you just go straight for a reinstall?
FEBE extension for Firefox is great for when these sort of things happen
Yes actually I did try the safe mode first with the same result so I just reinstalled.
My System SpecsSystem Spec
Reply

 Firefox 3.5.3 Problem




Thread Tools





Similar help and support threads
Thread Forum
I'm having a problem with firefox
Since I've had firefox, everytime I go on google and click back after I've clicked a link google gets cleared so I have to refresh the page to continue what I was doing. Any idea why this is happening?
Browsers & Mail
Firefox Problem; Help Please
Hi, Am hoping someone might have any thoughts on this. Started today; never had this problem before. No new downloads, or anything that I know of has changed. Using Firefox. All the shortcuts I have placed on the upper bar work just fine. Clicking one goes right to that site.
Browsers & Mail
Firefox Problem
Hi, I have a problem with firefox that is it stopped to ask to save passwords on sites, I uninstalled it and reinstalled again but nothing changed, any ideas?
Browsers & Mail
FireFox Tab problem
For some reason i cant open a new tab unless i hit ctrl T and when i do, i get a powered by Ask thing. what do i do? This just randomly started happening.
Browsers & Mail
Odd Firefox 3.5.6 Problem
For the past few weeks, I have been experiencing a weird problem on a single website. It doesn't happen in IE, only Firefox. When I go to the Washington Examiner news site, and scroll a bit down the page, the page will reload and jump to a google search page! The words that I supposedly "searched"...
Browsers & Mail
Firefox problem
Hi guys, Well basically, i've been getting this problems lately, if i click on a link or anything on firefox, the toolbar at the top where the minimise, restore down and the cloes button is at, it says 'not responding' for a split second during the item i click on the link or sometimes if i...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App