Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot open links.......

25 Apr 2013   #1
rickory

vista home preminum
 
 
Cannot open links.......

Using win7 64 bit and IE9.........I use Facebook and Twitter for Family news and General info.Recently I have been having problems opening links on these sites and some others like Yahoo,NYT..
When I click the link nothing happens.When I right click the link and "open" shows up in the menu I can open the link......But "open" does not always show up.
Something has changed.I have check Internet Settings and all others.
Nothing appears to be different then before. Can someone provide what could have changed?? and/or give some direction??


My System SpecsSystem Spec
.

25 Apr 2013   #2
BrightBlessings

Win7 Pro-64 Bit
 
 

See if restoring to default will help. Default File Type Associations - Restore Select the one for URL and see if this helps.
My System SpecsSystem Spec
26 Apr 2013   #3
rickory

vista home preminum
 
 

No dice....Thanks any other idea's??
My System SpecsSystem Spec
.


28 Apr 2013   #4
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Is this consistent? Left click doesn't open links? Does the same happen using IE x64? If it is consistent, try re-registering a file

Press Windows key (the key with the windows flag)+R> In run box type regsvr32 urlmon.dll> Enter (or click OK)

You should get a success message. If no help, re-register the following using the same instructions

regsvr32 Shdocvw.dll

regsvr32 Msjava.dll

regsvr32 Actxprxy.dll

regsvr32 Oleaut32.dll

regsvr32 Mshtml.dll

regsvr32 Browseui.dll

regsvr32 Shell32.dll

A Guy
My System SpecsSystem Spec
29 Apr 2013   #5
ThrashZone

Win-7 H-Premium 64-bit sp1
 
 

Sounds like a third party security update has altered functionality.
My System SpecsSystem Spec
30 Apr 2013   #6
rickory

vista home preminum
 
 

Thanks for all your suggestions......I reset IE9 using the tools and adv.menu. It seems to have corrected the issue.FYI..I had switched to Chrome and Foxfire and had the same problem.After the IE9 reset the problem was resolved. This is a great Forum...Thanks again.This forum has helped me several times over.
My System SpecsSystem Spec
30 Apr 2013   #7
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Glad you got it sorted. Thanks for sharing the fix. A Guy
My System SpecsSystem Spec
Reply

 Cannot open links.......




Thread Tools





Similar help and support threads
Thread Forum
Outlook won't open links if IE is open.
Well, I have searched and have not been able to find a solution to my particular issue: with IE9 set as default browser, when I click on a link in an Outlook message, the link will only open if IE is not already running. In other words, with IE closed if I click a link in Outlook, it will open, but...
Browsers & Mail
Links only open in IE - Can't change it
I am having a very weird issue all of a sudden. Usually if links start opening in IE all I have to do is open Firefox and set it as my default browser and all is good. Unfortunately this isn't working and I've noticed something very odd. Here is a screenshot of IE's Program Associations ...
Browsers & Mail
cannot open links
Hi folks, im having problems opening links within web pages,even on this site when I click on a link within a web page it opens another web browser but just goes blank..any suggestions? using windows 7 64 bitand ie10
Browsers & Mail
Cant open links
Whilst trying to make Adobe Reader X1 work I have inadvertently upset the settings on my computer, (somnething that has happened before) and cannot open any links on my screen. A while ago someone in the forum sent me an address where I picked up the Microsoft Trouble shooting site and I was able...
Browsers & Mail
Cannot open links in IE 8 in a new Tab
I have recently upgraded to a new PC Running Win 7 Home Premium 64 bit. When using IE8 I cannot open a link in a new tab. I tried to open a thread on the main forum page by right click on link and click 'Open in new Tab'. All I get is a new tab with 'connecting' in the tab heading and a...
Browsers & Mail
IE 8 won't open links?
Running Win7-64 and IE8-32. McAfee Internet Security. All up to date After 5 months of IE8 working fine in the last 3 weeks IE8 acts weird when trying to open links. On "some" pages links will open o.k. with a left click BUT even on the same page they will not open or will open with a...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:48.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App