Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow internet browsing

13 Jul 2013   #31
tim696969

Windows 7 Home Premium
 
 

There is no drop down menu. I ran it a 2nd time and it found no threats.


My System SpecsSystem Spec
.
13 Jul 2013   #32
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Ok that's good . Speed is still slow ? Are you connected wirelessly or wired
My System SpecsSystem Spec
14 Jul 2013   #33
tim696969

Windows 7 Home Premium
 
 

Yes, still slow. I am connected wirelessly. Like I said, when I connected directly to the cable modem, my speed was fine.
My System SpecsSystem Spec
.

14 Jul 2013   #34
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Whats the speed on wifi and on wired
My System SpecsSystem Spec
14 Jul 2013   #35
tim696969

Windows 7 Home Premium
 
 

Wireless Download .13 MBPS, Upload is .28 MBPS. Wired Download 3.42 MBPS and Upload is .87 MBPS.
My System SpecsSystem Spec
14 Jul 2013   #36
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

What is the model of the wireless router
My System SpecsSystem Spec
14 Jul 2013   #37
tim696969

Windows 7 Home Premium
 
 

Asus rt-n12
My System SpecsSystem Spec
14 Jul 2013   #38
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Have you checked to see if there is a firmware upgrade
My System SpecsSystem Spec
14 Jul 2013   #39
tim696969

Windows 7 Home Premium
 
 

Ok, now it's works fine. I guess unplugging the router once was not enough. The second time to check the direct connection speed and unplug the router and plug it back in again worked! It's so tempermental I guess.
My System SpecsSystem Spec
14 Jul 2013   #40
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Glad you fixed your issue .
My System SpecsSystem Spec
Reply

 Slow internet browsing




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Slow Internet Browsing Problem
Hi, I installed Windows 7 couple weeks ago and found out that the Internet browsing is really really slow. I reinstalled it twice and the same thing is happening. My computer has 4GB of RAMS and on E8400 processor so I dont think it's my computer's problem. I have tried IE8, Firefox, Google...
Browsers & Mail
Slow Internet Browsing
My machine is presario cq62, with an intel i5 processor. i do experiencing an extraordinary slowness in both browsing and downloading. I Tried re-installing OS several times, and was not successful. I'm using avg antivirus package. I'm using Google crome as current browser. Cooling fan is also...
Browsers & Mail
Internet browsing slow with IE9
When I use IE9 to browse the internet it sometimes is very slow. I have run an internet speed test program (speedtest.comcast.com) which hangs when testing IE9. I then started Chrome and the internet browsing was fast. I ran the speed test program and the speed was what I expected. I switched...
Browsers & Mail
slow internet browsing
At my home network my pc runs just nicely. But today I moved it to my friends place and for some reason all surfing is really slow, like google.com takes up to 30-40 seconds to load. Using my laptop computer it loads in about a second on the same network. I am on a 4mb/500kb connection and...
Network & Sharing
slow download and internet browsing
Hi I seem to have joined the many that are having problems with slow download speeds using Windows 7. I recently bought a well speced HP Pavillion with Windows 7 64-bit. Since I turned it on for the first time I have painfully slow download speeds. A broadband speed test showed download speed...
Network & Sharing
VERY Slow internet browsing speed.
I installed windows 7 64-bit the other day and i've noticed that browsing the internet is VERY difficult. Sometimes pages will only half load (missing graphics etc) or not load at all. I have tried chrome, IE and firefox and they all have the same issues. As another example, no youtube videos load...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App