Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow browser loading for the first time!

18 Sep 2013   #1
keivi

Windows 7 Professional
 
 
Slow browser loading for the first time!

Every time when I turn on the computer or after a restart, it takes a while for the system to get going as usual, but the problem is no matter how much time passes, for the first time I open any browser after the computer was turned on, it takes too long to even the browser's window. This happens for every browser. I have tried emptying the cache to no avail, disabling different add-on and the problem still persists. Any help would be appreciated.


My System SpecsSystem Spec
.
18 Sep 2013   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

My System SpecsSystem Spec
19 Sep 2013   #3
keivi

Windows 7 Professional
 
 

Sorry for the delay, I run the System File Checker and the diskcheck command and all system files and local discs showed no corruption. Also the malware scans below showed nothing more than some tracking cookies, which I don't believe are the source of the problem.
My System SpecsSystem Spec
.

20 Sep 2013   #4
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

No probs I am late myself. It might be an idea to get some specs from the machine kievi see this
System Info - See Your System Specs
My System SpecsSystem Spec
20 Sep 2013   #5
UsernameIssues

W7 Pro SP1 64bit
 
 

Quote   Quote: Originally Posted by keivi View Post
...the first time I open any browser after the computer was turned on, it takes too long to even the browser's window...
How long is too long? Can you give us the time in seconds or minutes?

It is normal for the first start of any app to take longer the first time. How long it takes depends on several things. Like ICit2lol said, we need to see your System Specs.
My System SpecsSystem Spec
20 Sep 2013   #6
keivi

Windows 7 Professional
 
 

Here are my system specs


For some odd reason, if I start the browser from the desktop shortcut, it loads considerably faster to open the home page, the problem it seems is only with the taskbar shortcut. If I open the browser from the taskbar, it takes average 1 minute and a half, sometimes more and if I don't click it again to open a second browser window it takes even more, from the desktop shortcut it takes 15 to 20 seconds.
My System SpecsSystem Spec
20 Sep 2013   #7
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Is the GPU driver u to date mate if not try this AMD Radeon

You might try reseating the GPU and RAM sticks anyway.
My System SpecsSystem Spec
20 Sep 2013   #8
keivi

Windows 7 Professional
 
 

Yeah the drivers are up to date, just tried resetting the sticks, no difference.
My System SpecsSystem Spec
20 Sep 2013   #9
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

I would look in msconfig/Startup and see if you have a lot of other things loading at boot that could be slowing things down.
What anti virus programs are you using.
Check and see if you have any programs that run scans at boot or are checking for updates.

We still need your specs using this.
By Brink:
System Info - See Your System Specs
My System SpecsSystem Spec
21 Sep 2013   #10
keivi

Windows 7 Professional
 
 

Thanks, it seems that too many processes where loading at boot and that slowed it down. Also a re-install of Mozilla and Chrome helped. Thanks a bunch.
My System SpecsSystem Spec
Reply

 Slow browser loading for the first time!




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
browser not loading webpages
please help guys. my Mozilla Firefox and Google chrome does opens up but keeps on loading continuously without any improvement, but other applications like Skype works very fine. :(
Browsers & Mail
Forever loading web browser
This always happens when after i watch couple videos from youtube and then the internet stops working. The browser takes forever to load. The loading bar just keeps spinning doesnt load the page at all. This happens to all the web browsers. The internet is connected but it doesnt work at all. Its...
Browsers & Mail
Browser goes blank about loading website
Hello, I am new to this forum. I am currently facing some problems in loading webpages from browsers. I have tried every browers with me like Firefox, IE and Chrome. But every time i enters an url, it loads the url( as i can see the title bar showing the website title) but the browser shows the...
Browsers & Mail
Browser Not Loading Up :(
I try to access Google chrome and click the icon or the .exe, it shows the loading cursor and then just does nothing, completely forgets about it! I try internet explorer and still nothing. I Use my antivirus software (avast) to scan but it finds nothing. I Try cCleaner but now cCleaner wont...
Browsers & Mail
Slow browser, slow internet, random audio ads: virus?
So yeah, I've these problems for the past couple days. My browsers (Opera and Firefox) used to load pages quickly, but now they're painfully slow. Opera lags and freezes often; Firefox doesn't, but it still takes a very long time to load pages. I'm also getting these occasional "invisible ads,"...
System Security
All browser slow/not loading pages
Hello! I'm running Windows 7 for a couple of months, and recently none of my browsers will work normally. The connection often time outs, dns fails or it loads the page but with nothing but text :confused: (Some pages load, and the ones that don't load, work after refreshing the page a couple of...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:25.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App