Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Google Chrome on initial startup takes too long to load

13 Oct 2013   #1
heatman323

Microsoft Windows 7 Home Premium 64-bit SP1
 
 
Google Chrome on initial startup takes too long to load

Hi, so after using google chrome for about a year and having no problems whatsoever, just today I encountered one where the initial startup takes a very long time about 10-15 minutes, and this is only on initial launch, as when I keep chrome open any new chrome windows I launch load normally which is nearly instantly. I have done every procedure herehttp://http://productforums.google.c...me/h1A_mmOEeqs though not separately and it still takes an incredibly long time for chrome to load on initial launch. Any help would be greatly appreciated!


My System SpecsSystem Spec
.
13 Oct 2013   #2
maxie

windows 7 home 64bit
 
 

Hi there .. Read the Tutorial below it might help speed things up ...

Chrome Browser Proxy Settings - Change to Speed Up
My System SpecsSystem Spec
14 Oct 2013   #3
heatman323

Microsoft Windows 7 Home Premium 64-bit SP1
 
 

Thanks for replying maxie! Though I regret to say I already tried that as when I arrived on the last window I already had the option unchecked, as well as the other checkboxes. I tried it still and hit OK twice and timed it till Chrome launch it was 7 mins.
My System SpecsSystem Spec
.

15 Oct 2013   #4
Dude

Windows 10 Pro X64
 
 

Try uninstalling and then reinstalling chrome and see if that helps.
My System SpecsSystem Spec
Reply

 Google Chrome on initial startup takes too long to load




Thread Tools




Similar help and support threads
Thread Forum
Computer takes a long time to load, constantly not responding.
Hi all, Recently my laptop is giving me issues, it took a long time to do anything at all. Some times it states that window explorer stops responding. I tried going into safe mode and use the sfc /scannow feature but it auto dismisses after 7% verification. I am not sure what's the cause of all...
Performance & Maintenance
Windows Explorer takes a long time to load?
What's going on with the icon on my taskbar? It takes 22 seconds to load Explorer. Every other link to a folder in Explorer is practically instantaneous, including the links in Start Menu.
Performance & Maintenance
Bios takes long time to load
I am having a sony vaio leptop RAM 3GB GPU ATI 4SERIES 1.5GB PROCESSOR AMD ANTHLON 2 DUAL CORE 2.1 GHZ my bios is taking 30 to 40 sec to detect the hard drive when booting up .. you can watch the video here of my lep boot up problem - YouTube i have not connected any external drive and still...
General Discussion
Album art takes long to load or doesn't load at all in explorer.exe
Im having this issue when I go to my Music folder/library in windows there is either no album art (in this case no icons in place of the album art either to suggest if its an mp3 or what not), or it takes a really long time for the album art to load on every peace of music. I have also tried to...
General Discussion
Takes a long time to load at welcome page
Recently, whenever i turn on my computer. It will take quite a while to load the welcoming page (The green page). Usually it took around 1-2 seconds. I've tried updating windows and anti virus scan but the problem still persist. Anyone have any idea what went wrong? Thanks! Im using home...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App