Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Can't browse Internet even though I'm connected

23 Oct 2009   #1

Windows Vista Home Premium x64
 
 
Can't browse Internet even though I'm connected

I just installed windows 7 home premium 64 bit, but for some reason, icant browse the Internet even though I'm connected. Ie thinks I'm not connected and nothing happens on firefox. I've tried the troubleshooter, disconnected and reconnected to the wireless network, and restarted my computer. Nothing changes.

I don't know if this is relevant but I got Microsoft tech support to help me download the file since I was having difficulties, and he somehow managed to disable all 3rd party programs. I'm not sure if that's related to this situation, and I don't know how to enable the programs again...

Any help would be appreciated!

My System SpecsSystem Spec
.

25 Nov 2009   #2

Windows 7
 
 
Same problem here...

Hey I'm having the exact same problem as Aeyara. I just updated to Windows 7 ultimate (64 bit) from Vista and I can't use IE or Firefox. My internet connection is recognized and I can use anything else that uses the internet (like iTunes, Live Messenger, Skype, etc.) but no browsers. I tried pretty much everything that has been suggested on forums (resetting IE, uninstalling Bonjour, unchecking the boxes in the LAN settings, etc.) but so far no luck.

Please help!
My System SpecsSystem Spec
25 Nov 2009   #3

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Quote   Quote: Originally Posted by andresmcm View Post
Hey I'm having the exact same problem as Aeyara. I just updated to Windows 7 ultimate (64 bit) from Vista and I can't use IE or Firefox. My internet connection is recognized and I can use anything else that uses the internet (like iTunes, Live Messenger, Skype, etc.) but no browsers. I tried pretty much everything that has been suggested on forums (resetting IE, uninstalling Bonjour, unchecking the boxes in the LAN settings, etc.) but so far no luck.

Please help!
I think that the first step would be to go to device manager and look for any problems. Problems will be clearly identified. Then come back and tell us what you have found.
My System SpecsSystem Spec
.


26 Nov 2009   #4

Windows 7
 
 

Ok, I checked the device manager and no apparent issues. One thing I did find is that my computer does not appear to have a valid IP address. I'm guessing this might be the problem, but how do I fix it?
My System SpecsSystem Spec
26 Nov 2009   #5

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Quote   Quote: Originally Posted by andresmcm View Post
Ok, I checked the device manager and no apparent issues. One thing I did find is that my computer does not appear to have a valid IP address. I'm guessing this might be the problem, but how do I fix it?
Hopefully the easy way will work. Right click on the network icon, bottom right. Then go to trouble shoot. If that does not work, please comeback and we will go from there.
My System SpecsSystem Spec
26 Nov 2009   #6

Windows 7
 
 

I ran a troubleshoot of Internet Connections, and the result is:

Problems found
Your computer appears to be correctly configured, but the
device or resource (www.microsoft.com) is not responding
My System SpecsSystem Spec
26 Nov 2009   #7

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Quote   Quote: Originally Posted by andresmcm View Post
I ran a troubleshoot of Internet Connections, and the result is:

Problems found
Your computer appears to be correctly configured, but the
device or resource (www.microsoft.com) is not responding
I am assuming that you have a dynamic ip address (it changes every time you shut off your modem). Easy solve number 2. Turn off your computer, turn off modem (on mine I have to unplug). Wait a few minutes, boot up then turn on modem. Are you on wireless?
My System SpecsSystem Spec
26 Nov 2009   #8

Windows 7
 
 

Yeah I'm on wireless and I've turned my computer off before. The IP addresses in this building are dynamic and on a three-month lease. I tried hooking up to ethernet before but I get the same error messages in IE and Firefox.
My System SpecsSystem Spec
26 Nov 2009   #9

Windows 7
 
 

No, turning off the computer and modem did not work. It's very strange that the internet is available for other programs, just not the browsers. I've got my firewalls turned off so that shouldn't be a problem.
My System SpecsSystem Spec
26 Nov 2009   #10

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Quote   Quote: Originally Posted by andresmcm View Post
Yeah I'm on wireless and I've turned my computer off before. The IP addresses in this building are dynamic and on a three-month lease. I tried hooking up to ethernet before but I get the same error messages in IE and Firefox.

Try this, take your Windows 7, and do a repair install, you may have to run it through twice. You should be able to get IE 8 to work at that point. Before that however, make a system restore and system image. In case something goes wrong you have a back up.
The problem began with the installation of 8, it has to be the cause.
My System SpecsSystem Spec
Reply

 Can't browse Internet even though I'm connected





Thread Tools



Similar help and support threads for2: Can't browse Internet even though I'm connected
Thread Forum
Connected to internet but cant browse Network & Sharing
Internet Connected but only able to browse Google sites Network & Sharing
Connected to Network no Internet access/Browse Sites. Network & Sharing
Solved Connected but can't browse anywhere (IE8) Browsers & Mail
Connected to the internet but cant browse websites Network & Sharing
Connected but cannot browse. Network & Sharing
im connected but i cant browse Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:10 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33