Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Browsing slow

27 Oct 2009   #1

Windows 7
 
 
Windows 7 Browsing slow

I have been trying to fix this problem for 4 days now, and I am pulling out my hair. I need help.

I have installed both IE8 and Firefox, both have the same problem. Google loads super fast...no problem there. But other web pages, load very slow, some times more than 5 minutes. In my head I hear the old 56k dial up sound off, but actually I am using high speed comcast 6m.

  • I have disabled the firewall, spyware. There currently is no virus protection.
  • Windows 7 Pro is a clean install.
  • Possibly unrelated, Norton 360 wont install. I mention it because it loads from the internet.
  • I have XP and Ubuntu working now, on the same router the Windows 7 machine is connected and they work fine.
I have done alot of internet seaching and have tried some stuff, asside from the stuff mentioned above. But truthfully I didnt believe this would work, but I am willing to try just bout anything.
  • reloading earlier versions of graphics and network adapter drivers.
  • turned IPv6 off on the driver.
  • Turned off Homegroup function of windows.
Ok, so any help you can give me is appreciated.

Thanks

My System SpecsSystem Spec
.

27 Oct 2009   #2

Window 7
 
 
same problem - I am pulling my hair out

I unable to bring up ebay, facebook, etc. Google, yahoo, work fine with fast results. Using and XP laptop on the same home network with no-one else working on the network had fast results.

Same result firefox and IE8
My System SpecsSystem Spec
27 Oct 2009   #3

Windows 7
 
 

I am connecting to the internet through my router. D-link 1310. I wonder if my/our routers have a conflict with IPv6? Does anyone know if that could be a possibility?
My System SpecsSystem Spec
.


28 Oct 2009   #4

Window 7
 
 
Works in Safe Mode

Ok - Spent 4 hours on MS support and learned a bit. If you start up in safe mode - with networking, the browsing speed is back to normal. Also, when doing a clean install on another machine - everything was fine. Not sure what to do but to go with clean install at this point
My System SpecsSystem Spec
28 Oct 2009   #5

Windows 7
 
 
Internesting

So, the question would be, what is happing to the network in windows 7, that is not happing to Windows 7 when in safe mode?

I dont know enough about safe mode, or network to do a proper analysis. Do any of you out there?

I will add one more symptem. I have noticed web sites that I have visited have steadily been coming up faster. Which goes for all the pages under the site, not just the root of the site. Wierd. Maybe there is some kind of cache working in Windows 7 that we dont know about?

Diplomatone
My System SpecsSystem Spec
29 Oct 2009   #6

Windows 7 Professional x64
 
 

One thing I've done is to go into the Advanced options tab and click on the Reset button near the bottom to reset user preferences.

Next, when I relaunch IE, I do the following:
  1. Turn off compatability mode
  2. Turn off ALL accelerators
  3. Turn off updates to all search engines
  4. Don't send stats to Microsoft

Once I've done this, I've noticed that IE launches quicker and the browsing speed has increased a lot. I still use Chrome more than anything, but when I have to use IE (which is rare), this has helped it tremendously.
My System SpecsSystem Spec
29 Oct 2009   #7

Window 7
 
 
Full install corrects the problem

Well - I went so far a purchasing a tool for cleaning register and this still did not correct the problem. Ebay (+ many others) would time out or bring up only slightly completed web pages. I gave up and used my install disk to do a clean install of Windows 7. After working through missing drivers etc everything was back to normal. When I returned to ebay the site came up in an instant. Turns out that all my old files are in easy reach as they are still on the machine sitting in an old.windows folder. Still need to re-install other software (office, quicken, etc).

After spending for 4 hours for the upgrade, the clean install only took 45 minutes. Also, I believe the entire machine is running much faster.

In summary - clean install = good, upgrade = bad.
My System SpecsSystem Spec
Reply

 Windows 7 Browsing slow




Thread Tools



Similar help and support threads for2: Windows 7 Browsing slow
Thread Forum
Solved Slow internet browsing Browsers & Mail
Windows 7 slow file and internet browsing. Browsers & Mail
Slow browsing. Browsers & Mail
slow internet browsing Network & Sharing
Slow browsing after Win 7 Pro 64 install Browsers & Mail
Browsing Slow - Windows 7 Professional, 64 bit Browsers & Mail
Windows 7 and web browsing very slow. Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:04 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33