Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Internet problem, help appreciated

28 Oct 2009   #1

Windows 7
Internet problem, help appreciated

Hello, this is my first post here--I'm not a tech savvy person, and I don't normally visit web forums, let alone post on them, but I'm having an issue and despite quite a lot of searching I have not found a solution. I thought you guys could help.

I bought a new laptop PC last night, windows 7, and I have had a curious internet problem. I can get onto google, I can use google, but I cannot actually get onto any other website. They all try to load for forever, but ultimately I get a gray page with the message "The connection was reset." This happens with any page I visit, if I wait long enough for it to load.

I have only experienced this issue on my home network, and only with my new computer--my desktop PC (Vista, and a wireless connection, just like my laptop) is just fine.

I've done an awful lot of searching to find an answer, nothing. It's not the anti-virus, as far as I can tell. I can ping any website from the laptop, it's just that I can only use google. Talk about a tease, eh?

Any suggestions? Any information I could provide to help with an answer? Thanks for taking the time to respond, like I said I'm not very tech savvy so it might help the conservation to assume I know less about what you're suggesting than you think I do

My System SpecsSystem Spec
28 Oct 2009   #2

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64

Have you updates the drivers for you new machine? Could you also give us a breif rundown of the new latop itself...such as what model it is and what components (you know of) are included
My System SpecsSystem Spec

 Internet problem, help appreciated

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
IP error appreciated guys
IP conflict error – “Another computer on this network has the same IP address as this computer. Contact you network administrator for help resolving this issue. More details are available in the Windows System event log” This is the message I get....any ideas how to resolve this from happening...
Network & Sharing
if the vpn is connected i have no internet help will be appreciated
hi I have PC which is running windows server 2003 , I have my files stored on it and i access them through vpn but when i connect the vpn my internet stops working and i have to unchecked ipv4 ""use default gateway ..etc"" in the vpn network settings then i will have no network access but i...
Network & Sharing
Internet connectivity problem, affects wired internet but not wireless
I am having Internet connectivity issues that only affect my computer and only affect it when I'm using a wired connection as opposed to a wireless connection. I would just use the wireless except that it's too weak here at my house especially in the room where I'm working and thus it's slow...
Network & Sharing
Stumped on Windows7 network problem-Help is appreciated
Greetings all, Reluctantly, I've returned to see if I can get some great minds to help me out here. I've got an unusual problem and I've tried just about everything there is to fix this. I have a laptop AND a desktop both running Windows 7 Ultimate. The laptop used to be able to connect...
Network & Sharing
Problem with my browsers help is appreciated
Alright so I just scanned my computer with AVG and it found a Trojan I moved those files to the vault and next thing I know my browsers wont load any pages. I've used Chrome and Firefox. I need to do a research paper please help.
Browsers & Mail
Very strange problem, Help appreciated
Hey guys, I have a strange problem that I cannot seem to work out. Ever since I have installed RC1 64 bit my volume seems to change in volume at random, when windows 7 is first booted up the volume is fine but after that it goes up and down at will. I have both a Audigy 4 24bit and Realtek...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 16:47.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App