Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Severe browser problem

29 Oct 2009   #11

Windows 7 Ultimate 64bit

Ok,thanks,maybe its not 7 compatable yet

My System SpecsSystem Spec

 Severe browser problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Severe problem with my computer. Can't open programs.
Something really bad happened with my computer. I can't open programs like My Computer, Recycle Bin, Personalizize, System, and many other programs. When i click on them, nothing appears. Another thing is, the Save As, Save, and Browse buttons don't want to open. Again, when i click on the...
General Discussion
Severe Browser Issues....
Hello! I just built a new rig and installed Windows 7 Ultimate on it. Anyway, it's been about a month now since then and I've had no problems until a couple of days ago. For the past couple of days I have been experiencing browser issues. It started with Google Chrome (I try not to use IE...
Browsers & Mail
Severe mouse movement problem! :(
Hi there, additional to other minor issues I do have a problem with weird mouse movements, which renders typing + doing anything on my Windows 7 Pro (x64) setup useless! Since today, the mouse focus changes randomly to somewhere else, which is especially annyoing, when I'm typing a password,...
Hardware & Devices
Severe disk-reading performance problem
I have a severe problem where reading a large file is fine for a short while, then it stalls, and takes forever to finish. This means things like Media Center and Media Player are intolerable. I've described all the details, including perfmon.exe graphs, in the file attached to this posting. ...
Performance & Maintenance
Severe "Unknown Devices"-problem!
Hi everyone, I recently got a disturbing problem on my studio workstation - I was stupid enough to install iTunes, realized the havoc it made to services and general resources so I uninstalled it. Unfortunately my 4-port USB-Hub ceased to serve me afterwards, had to reset and move it to the...
severe problem,need urgent help!!!
hi... i always got this problem since i bought dell studio 1737.and i searched on web,and noticed that this is more common with dell laptops... i have windows 7 ultimate x64 and when i try to burn windows 7 image on dvd using ultra iso to make a bootable disk,it says DVD R/RW requires settings to...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:01.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App