Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Youtube videos not playing

29 Oct 2009   #1
timothyp

Windows 7 x64 bit
 
 
Youtube videos not playing

I have flash installed, with firefox and opera, and cant get youtube vids to play in either. I can play dailymotion and everything else, but not youtube. I keep getting "an error ocurred, please try again later". i have the latest version of flash and shockwave installed. I uninstalled and reinstalled, rebooted, uninstalled browsers, everything i can think of, but nothing. FYI, i was having this problem with vista as well. But with vista, it was only opera that wouldnt play the vids. Any help?


My System SpecsSystem Spec
.
29 Oct 2009   #2
timothyp

Windows 7 x64 bit
 
 

just installed Google Chrome and get the same error message. also tested on IE and the same thing.
My System SpecsSystem Spec
29 Oct 2009   #3
timothyp

Windows 7 x64 bit
 
 

I resolved the issue. I had IDM set to automatically download files from certain sites, once disabling it, i was able to view the vids.
My System SpecsSystem Spec
.

06 Jul 2011   #4
coolmr2000

Windows 7 Professional x64
 
 
Solution

If anyone experiences the same, on IE try this:
1. Close all IE sessions
2. Start IE, clear all history, cookies, etc. everything. Close IE.
3. Go to Control Panel, type "Flash" in the Search Control Panel box, you'll see Flash Player (32 bit).
4. Run it, starts the Flash Player Settings Manager. Click on the Storage tab, if not already shown, click on Delete All... The "Delete All Site Data in Flash Player" dialog appears, check all options to delete everything, then select Delete Data. Since you're here, check that the other settings make sense to you.
5. Close the Flash Player Settings Manager.
6. Start IE
My System SpecsSystem Spec
07 Jul 2011   #5
mr pc

Windows 7
 
 

Fix appears to not have worked for IE 9.0 - no change for FF 3.6/Opera/Chrome...

and now Youtube doesn't work in FF 5.0 (which it did just a few minutes before)

I would advise anyone with working youtube video for FF 5.0 (but are trying to fix thier IE) NOT to use this fix.
My System SpecsSystem Spec
Reply

 Youtube videos not playing




Thread Tools




Similar help and support threads
Thread Forum
Faults when playing videos from YouTube
I have a problem with YouTube videos to IE10, however, is there a way where you can fix it, I'm using the latest version of Adobe Flash Player
Browsers & Mail
BSOD when playing YouTube videos
Hi All, thanks in advance for your help :D I have a brand new pc, Haven't had any issues with it even playing new higher end games like Thief. But I have got a BSOD twice now, and they both occurred under the same circumstances. When watching a video on youtube (this dosnt happen 99.9% of...
BSOD Help and Support
Videos on YouTube Not Playing Properly
I'm having an issue with YouTube videos on Firefox 22 not playing properly they will wait for about a minute and all the YouTube controls will come up, Videos are playing just fine on IE10 though, is there any way to where I can fix the issue on Firefox I am using the latest version of Adobe Flash...
Browsers & Mail
Crashes when playing YouTube videos
So yeah, I have this problem where every time I start to play a YouTube video, my screen will flicker a little then go black, permanently. I then have to force a power off to get Windows working again. I can't figure out if it is Windows, FireFox, the Nvidia driver or the Flash plugin that's...
BSOD Help and Support
BSOD on FB and playing videos on Youtube.
System Specs. -Windows 7 x 86 32Bit -Original OS, Windows 7 -Windows 7 reinstalled fresh. -PC age and hardware 9-10 months old approx Attached file as instructed. It has been re-occuring when i play videos (Youtube, Online streaming) and anything to do with fb games as well. Sometimes...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:39.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App