Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Firefox "Connection Untrusted"

21 Jul 2014   #1
Foster426

Windows 7 Home Premium x64
 
 
Firefox "Connection Untrusted"

My computer came with Windows 7.
Around this time last year I updated to Windows 8, and the 8.1.
Yesterday I removed 8 and went back to 7.
Now Firefox has a "Connection Untrusted" warning before going into most websites. REALLY annoying.
I've tried changing the clock on my computer like most other forums say to no avail.
I turned of Windows Firewall to see if that was the problem and it wasn't.
This is REALLY annoying. I've never had to deal with this before. Any suggestions?


My System SpecsSystem Spec
.
21 Jul 2014   #2
Not Myself

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

This belongs in the Browsers & mail forum.

Start here, and note the link on its first line:

Error loading secure sites - MozillaZine Knowledge Base
My System SpecsSystem Spec
21 Jul 2014   #3
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Foster426,
Have you tried another browser? If you have a browser problem always try another one or two browsers that way you determine if it is a Windows problem or a specific browser problem!
My System SpecsSystem Spec
.

21 Jul 2014   #4
Foster426

Windows 7 Home Premium x64
 
 

I'm using Chrome right now. IE works also.
All of this didn't start happening until I removed windows 8.
My System SpecsSystem Spec
21 Jul 2014   #5
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

If you are saying that there is no problem with Chrome or IE then uninstall Firefox using Revo uninstaller, reboot Windows and reinstall Firefox.
My System SpecsSystem Spec
05 Dec 2014   #6
kd the don

windows 7 pro 32
 
 

if you had installed any software which effects your browser like avast antivirus which detects any malicious website ,which interfers with your browser then uninstall it if it is installed on a wrong date or time and reinstall it
My System SpecsSystem Spec
Reply

 Firefox "Connection Untrusted"




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Mozilla Firefox, error "The connection was reset"
Hi, I am running Windows 7 Home Premium. Toshiba Laptop. I recently upgraded to the new version of Mozilla Firefox (23.0.1) and when I tried to go on Facebook it came up with this error: The connection was reset The connection to the server was reset while the page was loading.
Browsers & Mail
"Local Area Connection" missing in "Change adapter Settings".. Plz hlp
I have to set up a Broadband connection. But Local Area connection icon is missing. Someone told "drivers" could be missing... I installed few. But the problem is as it was.. please guide me in this regards.. Thank you Screen shots Attached
Network & Sharing
Sony Vaio Laptop "stopped" connecting to WiFi connection " Limited acc
Hi, I am hoping you can help me with my problem. My main laptop (Sony Vaio VPCCB15FG) in the last week just stopped accessing the internet via WiFi. It says it has Limited Acess but I have no idea how to fix it. The other 3 computers in the house (Custom desktop, Toshiba Net book, Samsung...
Network & Sharing
"No Network Access" and "Limited Connection/Connectivity" ?
Hey, I am really hoping someone can help me solve this problem, it's driving me up the wall! When I started using my computer this morning everything was fine, and then "no network access" kept appearing, along with "limited connection/connectivity". I would troubleshoot the problem, but then at...
Network & Sharing
""Local Area Connection" Doesn't have a valid ip config "
i Recently bought and hp windows 7 computer 64 bit and it was fine but two weeks later it does this it was working few hour ago and now it saids this ""Local Area Connection" Doesn't have a valid ip config" what does that mean? i couldnt fix it, i turned off the router, modem did a pc recovery...
Network & Sharing
I have "DHCP" how can I use "Static" IP on a wireless connection?
I don't know if this is the right place, but I seriously need some help. I've got an IP that changes every time my "gateway" (router) is reset. First of all, I'm using windows 7 ultimate 32 bit. AND IIS. (Internet information services) or something like that.. It's really annoying, because...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App