Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Browsers do not load pages properly!

20 Sep 2014   #11
maxie

windows 7 home 64bit
 
 

Do you have the Intel Management Engine Interface Driver Installed ..


Look in Programs and Features ...


My System SpecsSystem Spec
.
20 Sep 2014   #12
FarCry3

8.1 64bit
 
 

I have Intel Mangement Engine Components ?
My System SpecsSystem Spec
20 Sep 2014   #13
FarCry3

8.1 64bit
 
 

I notice that after restart , in about 5 minutes , first pages which i load are fine but then...
My System SpecsSystem Spec
.

20 Sep 2014   #14
maxie

windows 7 home 64bit
 
 

Okay so lets try this Driver for Windows7 ...

By the way the Chipset is basically the same in Windows8 as Windows 7 ...



Download the Driver and Uninstall the old Driver ..


Then point Windows to the Path of the new Driver ..



Product Support | Dell US
My System SpecsSystem Spec
20 Sep 2014   #15
FarCry3

8.1 64bit
 
 

You mean the Network driver? And i have to download OS 7 version ??
My System SpecsSystem Spec
20 Sep 2014   #16
maxie

windows 7 home 64bit
 
 

That Version you have seems to be Unstable ...


So it may be worth trying an older Version ..
My System SpecsSystem Spec
20 Sep 2014   #17
FarCry3

8.1 64bit
 
 

WOW, I installed that and now it seems to work fine. I will browse for few hours to verify it is OK now. Many thanks for the help!! ! ! I will mark the thread as solved as soon as i assure its fine. ! Best forum ever.
My System SpecsSystem Spec
20 Sep 2014   #18
maxie

windows 7 home 64bit
 
 

Most welcome .. Let it run for a couple of Days before you mark the Thread as solved ...
My System SpecsSystem Spec
Reply

 Browsers do not load pages properly!




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Specific web pages only load slowly on all browsers
When I log into my work's website, I can log in on the main page and navigate it fine. However, there are several pages within my company website that load extremely slowly. I mean, they take over 10 minutes to load. The pages are my company mail inbox, my schedule, and the page where I bid for...
Browsers & Mail
No browsers will load pages, even with strong DSL connection!:(
I have look around this forum some, but I am extremely tired from staying up all night trying to figure out what is wrong! I have a Dell Inspiron 1440 laptop running windows 7 home premium 64bit. This all started when I click on my google chrome and seen the home page was dosearches.com, so I tried...
Browsers & Mail
Multiple pages in my browsers wont load
I have no idea what this is, I have cleaned my registry from CCleaner, Ran my antivirus, rebooted, I have basically tried everything. Many pages just keeps on going in an endless loop. A few examples: Images from Imgur.com Images from Tinypic.com Download page for Microsoft Security...
Browsers & Mail
Images do not load properly in all browsers
Hi guys, I couldn't figure out how to fix this by myself, so I need to post this annoying problem in here. Most images couldn't load properly in some websites, i.e Tumblr. I tried all different browsers, they are acting the same. I tried clearing all caches, cookies, etc in all browsers with...
Browsers & Mail
Some pages do not load in any of the browsers
Hi all i am new to this forum :D I just formatted my windows 7 a month ago and re-installed it . Few weeks ago i changed my modem to Netgear N150 modem + router . After that Most of the websites don't load . Eg : Facebook , yahoo , ms support , etc . I was scanning for any malware or virus but i...
Browsers & Mail
Connected to Internet but CANNOT Load Pages in Browsers
For a few months now, a few times a day, I'll be surfing fine but after awhile my browser (Firefox or IE) cannot load any pages, it'll say something like cannot load page. But I notice my downloads are still going (in Firefox or µTorrent, etc.) and my VoIP still works. I"m on a WIRED...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:48.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App