Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Opera 12.17 suddenly not working with SOME https sites

19 Oct 2014   #11
morph000

Windows 7 64 bit
 
 

Callender - I tried your site and got RC4, 128 bit so ok there.
With a port viewer (I use Nirsoft CurrPorts but tried opview but made no difference) all Opera remote ports are 127.0.0.1 but Kaspersky shows port 443 connections to remote host so all getting routed to Kaspersky THEN to the website via 443 so effectively the same thing.
Not sure where your security prefs pic comes from. I Use Kaspersky Internet Security 2013 suite.

I have used Chrome but hated it plus it causes a whole range of other issues ranging from email to HTML association screw ups through to non-working hyperlinks in XLS's...
Major PAIN to try and fix.


Just noticed - Google no longer redirects to the https equivalent. Guess they are aware of the problem now ..


My System SpecsSystem Spec
.
19 Oct 2014   #12
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Opera 12 - Security Preferences

To get to security preferences type:

about:config

in the address bar and press enter.

Scroll down and expand security preferences.

Make sure OSCP Validate Certificates is checked along with the other settings shown in the screenshot in Post #8 in this thread.

However there are even more settings available and you get to them like this:

To enable or disable specific security protocols, from the menu, go to Settings > Preferences > Advanced > Security. Check or uncheck the protocols you want to enable or disable.

If you want to select ciphers to enable or disable, click the "Details" button.

Compare your settings with mine. Those highlighted in red are unchecked - everything else is checked.

Opera 12.17 suddenly not working with SOME https sites-security-protocols.jpg

On another note it might be wise to follow the general advice given in the link below if you haven't already done so:

How to configure Opera 12.x for safer internet browsing

If it still doesn't work the only other suggestion that I've go is to temporarily disable Kaspersky and try visiting problem sites to see if you can connect. If it works then it's a Kaspersky issue.


My System SpecsSystem Spec
19 Oct 2014   #13
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

RE: Other browsers. I have six browsers (installed or portable) as they all have different strengths and weaknesses. I don't have Chrome but do have a Chromium based browser installed.
My System SpecsSystem Spec
.

20 Oct 2014   #14
morph000

Windows 7 64 bit
 
 

Yep to everything ! Same as yours...
Sticking with KIS disable ssl scan option for now until a better fix comes along.
Thanks for the input !

3/11/2014 - still works fine with Google etc now but some sites using https images no longer display those images.

Secure connection: fatal error (1066)
Unable to verify the website's identity (OCSP error).
The response from the online certificate validation (OCSP) server was too old.

Sounds like the sites need to fix their certificates to fix this...
My System SpecsSystem Spec
19 Feb 2015   #15
mcortis

still XP SP3
 
 

Hi,

I had the same problem, with the certificates.
Opera 12.17 and some URL (google, yahoo...).

I forgot that I changed (the day before) the date of the computer to may 2015, and as the certificates are valid from.... to... (before may)

I put the date today (in the interval OK for certificate valid), and everything come OK.

Michel
My System SpecsSystem Spec
Reply

 Opera 12.17 suddenly not working with SOME https sites




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Can't update Windows and All HTTPS sites produce an error and more
It all started with the installation of a Asus Sonar DG sound card or perhaps a coincidence. The installation from its Cd did not seem to want to complete although it did seem to be at 100% so in rebooting I heard sounds but I installed it again nevertheless and all installed correctly. And then...
General Discussion
IE 10 won't let you access HTTPS sites
My neighbor just recently restored his Toshiba laptop back to factory settings, the Win7 load when he first bought the laptop. After if finally got all the updates applied, he tried to access one of his banking sites and entered id and password, clicked submit and the page reloaded and cleared out...
Browsers & Mail
How do i block HTTPS access to Social networking sites
I am trying to block HTTPS access to social networking sites at work. the web filtering service we use is barracuda but they are not configured to block HTTPS only HTTP sessions.(unless they can, but we have not figured it out yet). is it possible to block access via group policy in Active...
System Security
Some sites won't open with "http" but with "https"
From some days I am experiencing this strange problem in Firefox. i am unable to open some sites with the "http://" address in Firefox it don't shows any error message or anything just a blank page. but if i edit there url to "https://" sites open normally. this is really annoying. please...
Browsers & Mail
New Computer Won't Load HTTPS Sites, just hangs
Hey, Got this new computer here and sites using https or have used https in the past will not load. Main example I have is facebook. Going directly from the home page to facebook on IE9 it just hangs there which i open a new tab without http it loads fine. In firefox i can load the login page...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App