Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: I'm having a problem with firefox

19 Oct 2014   #1
crashhat

Microsoft Windows 8.1 with Bing 64-bit 9600 Multiprocessor Free
 
 
I'm having a problem with firefox

Since I've had firefox, everytime I go on google and click back after I've clicked a link google gets cleared so I have to refresh the page to continue what I was doing. Any idea why this is happening?


My System SpecsSystem Spec
.
20 Oct 2014   #2
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

First, what version of FF do you have? This problem seems to have started in version 26, I've never seen it and I've been using FF since v7.

In doing a search on google - firefox google search results clear after using back button - I came up with this Helpful Reply: https://support.mozilla.org/question...#answer-485663, solution #2 seems to do the most good.

There have also been reports that using google's, instant results, will also cause this behaviour.
My System SpecsSystem Spec
20 Oct 2014   #3
crashhat

Microsoft Windows 8.1 with Bing 64-bit 9600 Multiprocessor Free
 
 

I have the newest version of firefox, I think it's version 32?
My System SpecsSystem Spec
.

20 Oct 2014   #4
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

The latest and greatest is v33.0. If you're not sure which version you have, go to and click on Help up in the Menu bar then click on "About Firefox" at the bottom of the drop-down menu,.

Depending how you have your Updates set, Firefox (FF) will either take off and update automatically or you will have to click on the Check Updates button. Then in order for the update to take effect FF needs to be restarted. In all my updates, FF restored my session after the restart.

If you do need updating, test the situation you're having with the blank google search to see if the update corrected your problem.

If it didn't; Did you get a chance to look over that link I provided, the one right after Helpful Reply?
My System SpecsSystem Spec
20 Oct 2014   #5
crashhat

Microsoft Windows 8.1 with Bing 64-bit 9600 Multiprocessor Free
 
 

Quote   Quote: Originally Posted by Anak View Post
The latest and greatest is v33.0. If you're not sure which version you have, go to and click on Help up in the Menu bar then click on "About Firefox" at the bottom of the drop-down menu,.

Depending how you have your Updates set, Firefox (FF) will either take off and update automatically or you will have to click on the Check Updates button. Then in order for the update to take effect FF needs to be restarted. In all my updates, FF restored my session after the restart.

If you do need updating, test the situation you're having with the blank google search to see if the update corrected your problem.

If it didn't; Did you get a chance to look over that link I provided, the one right after Helpful Reply?
I don't see help in the drop down menu in the top right

UPDATE: i found the help icon and updated firefox, it seemed to fix the proplem. Thanks for the info Anak
My System SpecsSystem Spec
20 Oct 2014   #6
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

That's great to hear crashhat! Your welcome, and Thank you for posting back.

Give it a few days, a week, to make sure everything is working okay and if it is, you can come back and finalize your thread by marking it solved.
If you're sure now you can do it now, if something does go awry later on you can always re-mark it Unsolved.

Its the green button next to the orange Post Reply button that only you can see because it is your thread.


You've probably already noticed , but I'm over at your other thread, sounds like you've some cleaning to do.
My System SpecsSystem Spec
21 Oct 2014   #7
crashhat

Microsoft Windows 8.1 with Bing 64-bit 9600 Multiprocessor Free
 
 

It started doing it again.
My System SpecsSystem Spec
21 Oct 2014   #8
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Even after you did a factory restore? Don't forget, I'm monitoring two threads of yours.
My System SpecsSystem Spec
21 Oct 2014   #9
crashhat

Microsoft Windows 8.1 with Bing 64-bit 9600 Multiprocessor Free
 
 

Quote   Quote: Originally Posted by Anak View Post
Even after you did a factory restore? Don't forget, I'm monitoring two threads of yours.
Yes even after I did the factory restore. I don't get it, I seemed to fix the problem when I updated FF, then I did the restore and it's back to doing the crap it used to do.
My System SpecsSystem Spec
21 Oct 2014   #10
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Define Restore,
Did you simply use System restore to an earlier time,
Or did you use a factory restore partition to out of the box condition,
There's a huge difference
Cheers.
My System SpecsSystem Spec
Reply

 I'm having a problem with firefox




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Firefox Problem; Help Please
Hi, Am hoping someone might have any thoughts on this. Started today; never had this problem before. No new downloads, or anything that I know of has changed. Using Firefox. All the shortcuts I have placed on the upper bar work just fine. Clicking one goes right to that site.
Browsers & Mail
Firefox Problem
Hi, I have a problem with firefox that is it stopped to ask to save passwords on sites, I uninstalled it and reinstalled again but nothing changed, any ideas?
Browsers & Mail
FireFox Tab problem
For some reason i cant open a new tab unless i hit ctrl T and when i do, i get a powered by Ask thing. what do i do? This just randomly started happening.
Browsers & Mail
Odd Firefox 3.5.6 Problem
For the past few weeks, I have been experiencing a weird problem on a single website. It doesn't happen in IE, only Firefox. When I go to the Washington Examiner news site, and scroll a bit down the page, the page will reload and jump to a google search page! The words that I supposedly "searched"...
Browsers & Mail
Firefox 3.5.3 Problem
I hate for my first post to be a problem but I have no where else to turn. I am currently running Firefox 3.5.3 and Windows 7 Ultimate now when I open a web page in firefox it opens fine but its like the page freezes as soon as it opens. For example if I load up Facebook and then click someones...
Browsers & Mail
Firefox problem
Hi guys, Well basically, i've been getting this problems lately, if i click on a link or anything on firefox, the toolbar at the top where the minimise, restore down and the cloes button is at, it says 'not responding' for a split second during the item i click on the link or sometimes if i...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App