Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: google is really annoying me.

13 Dec 2014   #1
flogit

windows 7 home premium 64bit
 
 
google is really annoying me.

I’m beginning to think about this Acer laptop that I bought running windows 8.1.
Maybe it’s the machine it self.The biggest issue is google takes ages to come on and ready to use,I can click on the google icon on the taskbar and go upstairs then come back down and google still aint ready to use.
I have cleaned out all the history in google run ccleaner done all the info that I found on line when ‘’google comes up and running’’,Not only on the windows 8 its slow on the windows 7.
Have tried the dns auto – speedyfox- Anvi browser repair tool.
Have also disabled any addons.
Has anyone please got some idea that can assist me out here as it’s really annoying me.
Thanks.


My System SpecsSystem Spec
.
13 Dec 2014   #2
maxie

windows 7 home 64bit
 
 

Does it happen when you use other Browsers ? ... Have to checked for Viruses and Malware ? ...
My System SpecsSystem Spec
13 Dec 2014   #3
flogit

windows 7 home premium 64bit
 
 

Yea,Have checked all malware etc,I must say that when I tried IE it was better than google.
Thanks for reply and help of course.
My System SpecsSystem Spec
.

13 Dec 2014   #4
maxie

windows 7 home 64bit
 
 

Have you tried disabling hardware acceleration under Advanced Settings ? ....
My System SpecsSystem Spec
13 Dec 2014   #5
Barman58

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu
 
 

As most if not all Browser comparisons rate Chrome as a close second to Firefox in speed terms with IE lagging several places behind It looks like this is an issue of your set-up.

It may be a good idea to completely remove chrome, and then re-install to eliminate any chrome configuration or file issues ....

full step by step to removal is available here ... Uninstall Google Chrome Completely from your Computer (Windows 7, XP or OSX)

Once you have removed the existing set-up, and the Sync data on google servers, if you have this enabled, you can re-install and re-check loading and working times on A completely fresh Add-on Free install .

If you find that this cures the issue, you can then install only those add-ons your really need. Allways install any add ons One at a time and run the sytem for a while before you add anything else, in order to highlight where any possible degradation of usability occurs
My System SpecsSystem Spec
13 Dec 2014   #6
flogit

windows 7 home premium 64bit
 
 

Maxie I did check that it was already unchecked,But one thing under the tab manage search engines there are always a lot of there ones there which i have to delete.
My System SpecsSystem Spec
13 Dec 2014   #7
maxie

windows 7 home 64bit
 
 

I am sure your Addons caused most of that ... Nigel has given you excellent Advice ...
My System SpecsSystem Spec
13 Dec 2014   #8
gregrocker

 

In addition does the PC still have the factory install? If so that is the worst possible install of Win7 one can have, larded with bloatware and duplicate utilities which interfere with better versions built into Win7. That's why most tech enthusiasts won't even run such an install but instead Clean Reinstall - Factory OEM Windows 7.

Everything needed is in the blue link to get and keep a perfect install just like a million others have done without a single complaint or return with problems by those who stick with the tools and methods given.
My System SpecsSystem Spec
14 Dec 2014   #9
flogit

windows 7 home premium 64bit
 
 

Well I'm back with an update for you guys.
I followed all the info disabled all the addons (didn't have many) I only left one addon that is the Lastpass manager.
Did uninstall and a fresh install of google,And turned the W8 Acer lappy on this morning and I thought here we go so went to open google and it took 45seconds to get ready to use.
Waited about an hour or so later and tried again and it took only 15seconds,So its a puzzle when I start up the lappy why does google take so long??
Many thanks to all who contributed.
My System SpecsSystem Spec
14 Dec 2014   #10
Barman58

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu
 
 

Check MSconfig for anything you don't need to start at boot. I'd also check any non MS Services that are set to auto start, which could be utilising a lot of processor cycles or especially those that go on-line to check the net for updates Etc.

I use Autoruns from Microsoft for a more detailed look at start-up items than MSConfig, It shows more or less everything that starts in a system, It can be a little daunting at first but is nirmally well worth it, It's fully doccumented at the linked site
My System SpecsSystem Spec
Reply

 google is really annoying me.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Google’s reCAPTCHA (Mostly) Does Away With Those Annoying CAPTCHAs
Source A Guy
News
Google Chrome Not logging into Google account, white screen
Before I even say anything, I have tried to reinstall Chrome 3 times and the problem still stands. So my problem is that when I try to login to my Google account on Google Chrome, the web page goes white and Chrome does not log in. The steps I took are as follows: It starts on the regular...
Browsers & Mail
Annoying BASS Bug,,,Ummm, Really Really Annoying Bass Bug.....
OK, I'm the only one with this issue that I could find... Nobody on this forum has this, REALLY,,,,REALLY,,,,#@%&!#,,,,Annoying Bass bug problem... Every time I start W7 the Bass is @ -12,,,,making my notebook sound tinny,,,,and I have beatsaudio in this and the sound is AMAZING,,,or should be at...
Sound & Audio
Google Chrome causing annoying unicode character bug to some apps
Hej, i have an annoying issue, both with x32 & x64 : If i launch the actual apps* before i launch chrome, asian language shows fine, however if i launch them after chrome, some of those language won't show normally, there will be something like ㅁㅁㅁㅁ instead of them. This happens with few different...
General Discussion
Google Apps - Google Hosted Email for my small business
I don't even know if this belongs here but I have had such fine folks on this forum, here I am. I have followed Google's instruction to Authenticate email at their control panel. I am getting awful lot of spoofing.
Browsers & Mail
Google censors gun/ammo/accessories on Google shopping - thoughts?
Opinions on Google's choice to no longer allow shopping for guns/ammo/accessories in Google shopping?
Chillout Room


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:00.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App