Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Should I run Ccleaner if browsers are slow?

13 Jan 2015   #111
Jesse Williams

Windows 10 Home 64-bit
 
 

I've got some options here. Which one do I choose?

Kaspersky Rescue Disk. Graphic Mode
Kaspersky Rescue Disk. Text Mode
Hardware Info
Boot from Hard Disk
Reboot
Shut Down


My System SpecsSystem Spec
.
13 Jan 2015   #112
maxie

windows 7 home 64bit
 
 

My System SpecsSystem Spec
13 Jan 2015   #113
Jesse Williams

Windows 10 Home 64-bit
 
 

Can I run this on my cousin's old Windows Vista PC? It won't boot into the normal operating system. Will it fix it?
My System SpecsSystem Spec
.

13 Jan 2015   #114
Jesse Williams

Windows 10 Home 64-bit
 
 

No threats were detected on my system.
My System SpecsSystem Spec
13 Jan 2015   #115
maxie

windows 7 home 64bit
 
 

Yes it will run on Vista not likely it will fix it though
My System SpecsSystem Spec
13 Jan 2015   #116
Jesse Williams

Windows 10 Home 64-bit
 
 

Okay
My System SpecsSystem Spec
13 Jan 2015   #117
Jesse Williams

Windows 10 Home 64-bit
 
 

Well. It was our old desktop. His mother knows how to fix computers better than I do. But, they've been so busy with getting there new house ready. I figured it might help if I run it on the computer to see what it detects. Because, more than likely it's a bug or something. Vista computers were known for getting bugs and viruses in their time.
My System SpecsSystem Spec
13 Jan 2015   #118
maxie

windows 7 home 64bit
 
 

All depends what is wrong with it Jesse ... If you have the Vista Disc should be easy fixed ..
My System SpecsSystem Spec
13 Jan 2015   #119
Jesse Williams

Windows 10 Home 64-bit
 
 

Unfortunately, I don't have one.
My System SpecsSystem Spec
13 Jan 2015   #120
maxie

windows 7 home 64bit
 
 

No problem it can be Downloaded ...

Vista ISO - Download and Create Installation DVD or USB
My System SpecsSystem Spec
Reply

 Should I run Ccleaner if browsers are slow?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Browsers Vey Slow
Last week I had a catastrophic failure. I donít need to get into details but bottom line is that Windows 7 (x64) had to be completely installed from scratch. My buddy at the shop had the foresight to save all my data files before formatting and installing. Everything is back running well except my...
Browsers & Mail
Windows Explorer and now Browsers slow / timing out
These two issues may or may not be related, but both seem to have started recently: Windows Explorer (not Internet explorer) just sits there for ages (several minutes) before actually displaying the contents of my computer. The structure on the left is all there but the right side where all...
Performance & Maintenance
Suddenly very slow browsing, all browsers
Since two days ago all my browsers function very slow. A new tab can take 15 seconds to open, typing in addressbar has very long delay (I type an address and hit Enter, it takes up to 20 seconds for first letter to appear, then other letters appear one in every 0.5 to 1 second). Typing this post...
Browsers & Mail
Slow Browsers Startup
Hi, Recently I have noticed that IE9 and Firefox 5 take a really long time to load up on startup, whereas Opera loads up instantly on startup. I have tried disabling all add-ons for both these browsers, as well as disabling all startup entries to see if these have an effect. I have also ran...
Browsers & Mail
Browsers Slow, Torrent speed fine.
Hi All, I have just upgraded to Win 7 Ultimate x64, I had no problems installing Win 7 (fresh Install) The computer is a I5 2500k, Asus P8P67 m/b, GTX 560ti GPU, 8g ram, OCZ 120gb ssd, I haven't connected the 2 tb storage just yet, Not sure if you need that info or not. The Problems...
Network & Sharing
Browsers Slow, Torrent speed fine
Hi All, I have just upgraded to Win 7 Ultimate x64, I had no problems installing Win 7 (fresh Install) The computer is a I5 2500k, Asus P8P67 m/b, GTX 560ti GPU, 8g ram, OCZ 120gb ssd, I haven't connected the 2 tb storage just yet, Not sure if you need that info or not. The Problems seems...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:41.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App