Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Should I run Ccleaner if browsers are slow?

08 Jan 2015   #41
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Quote   Quote: Originally Posted by jessejamestw23 View Post
Here are the results from the desktop. It is connected through a LAN (Ethernet) connection.

Speedtest.net by Ookla - My Results
They're better but not by much. I wanted to see if there was a big difference that your wi-fi may be causing the slowness.

Quote   Quote: Originally Posted by jessejamestw23 View Post
Also, it usually goes out in the afternoon when it does go out.
That's what everyone else is complaining about: Coosa Cable Co Reviews - Pell City, AL 35125

Quote   Quote: Originally Posted by jessejamestw23 View Post
What do you mean, have we had any other interaction with them...other than sign up?
Had you talked to coosa about the slowness, service interruptions, how was your customer experience with them, from your question apparently not; See above link.


Did you have the slowness when you were with centurylink?


My System SpecsSystem Spec
.
08 Jan 2015   #42
Jesse Williams

Windows 10 Home 64-bit
 
 

No. I don't remember having any trouble with speeds out of CenturyLink.
My System SpecsSystem Spec
08 Jan 2015   #43
maxie

windows 7 home 64bit
 
 

One can always Complain ...
My System SpecsSystem Spec
.

08 Jan 2015   #44
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Have you tried any of the steps in the troubleshooting guide I posted at the bottom of my post#36? They may help while you're with coosa.

Here's another guide: CCleaner - Delete Junk Files
My System SpecsSystem Spec
08 Jan 2015   #45
Jesse Williams

Windows 10 Home 64-bit
 
 

I started on it, but didn't finish it.
My System SpecsSystem Spec
08 Jan 2015   #46
maxie

windows 7 home 64bit
 
 

Might be a good idea to Finish it ...
My System SpecsSystem Spec
08 Jan 2015   #47
Jesse Williams

Windows 10 Home 64-bit
 
 

When, I tried uploading those files, it said they were invalid.
My System SpecsSystem Spec
09 Jan 2015   #48
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Could you be more specific?

What files, and who or what said they were invalid, do you mean the Hosts file?

If that's it, describe in detail the steps you took to prepare it for uploading.
My System SpecsSystem Spec
09 Jan 2015   #49
Jesse Williams

Windows 10 Home 64-bit
 
 

When I tried uploading the host files to the forum, it said they were invalid. I saved them to my desktop.
My System SpecsSystem Spec
09 Jan 2015   #50
maxie

windows 7 home 64bit
 
 

Try it again Jesse you must have done some thing wrong ... Read Post 36 for the Instructions ...
My System SpecsSystem Spec
Reply

 Should I run Ccleaner if browsers are slow?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Browsers Vey Slow
Last week I had a catastrophic failure. I donít need to get into details but bottom line is that Windows 7 (x64) had to be completely installed from scratch. My buddy at the shop had the foresight to save all my data files before formatting and installing. Everything is back running well except my...
Browsers & Mail
Windows Explorer and now Browsers slow / timing out
These two issues may or may not be related, but both seem to have started recently: Windows Explorer (not Internet explorer) just sits there for ages (several minutes) before actually displaying the contents of my computer. The structure on the left is all there but the right side where all...
Performance & Maintenance
Suddenly very slow browsing, all browsers
Since two days ago all my browsers function very slow. A new tab can take 15 seconds to open, typing in addressbar has very long delay (I type an address and hit Enter, it takes up to 20 seconds for first letter to appear, then other letters appear one in every 0.5 to 1 second). Typing this post...
Browsers & Mail
Slow Browsers Startup
Hi, Recently I have noticed that IE9 and Firefox 5 take a really long time to load up on startup, whereas Opera loads up instantly on startup. I have tried disabling all add-ons for both these browsers, as well as disabling all startup entries to see if these have an effect. I have also ran...
Browsers & Mail
Browsers Slow, Torrent speed fine.
Hi All, I have just upgraded to Win 7 Ultimate x64, I had no problems installing Win 7 (fresh Install) The computer is a I5 2500k, Asus P8P67 m/b, GTX 560ti GPU, 8g ram, OCZ 120gb ssd, I haven't connected the 2 tb storage just yet, Not sure if you need that info or not. The Problems...
Network & Sharing
Browsers Slow, Torrent speed fine
Hi All, I have just upgraded to Win 7 Ultimate x64, I had no problems installing Win 7 (fresh Install) The computer is a I5 2500k, Asus P8P67 m/b, GTX 560ti GPU, 8g ram, OCZ 120gb ssd, I haven't connected the 2 tb storage just yet, Not sure if you need that info or not. The Problems seems...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:47.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App