Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: FF v35.0.1 Reset Error (but loading page fine)

03 Mar 2015   #11
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Interesting information and questions! As far as I know Comodo Secure DNS does not use https.

See: Encrypted connection - News / Announcements / Feedback - DNS

I prefer something that blocks connection to known malicious sites hence my preference for Norton DNS. I had looked at OpenNIC some time ago but as far as I can work out it doesn't offer malicious site blocking.

I see that it's one of the DNS servers that does support DNSCrypt project official homepage

You might want to look into that. Personally I've never used it but if you want encryption it might be the answer.


My System SpecsSystem Spec
.
04 Mar 2015   #12
remm

Win 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by Callender View Post
As far as I know Comodo Secure DNS does not use https.

See: Encrypted connection - News / Announcements / Feedback - DNS
Thanks for that!

Quote:
I prefer something that blocks connection to known malicious sites hence my preference for Norton DNS.
(Did you mean Comodo DNS like you said earlier?)


Quote:
I had looked at OpenNIC some time ago but as far as I can work out it doesn't offer malicious site blocking.

I see that it's one of the DNS servers that does support DNSCrypt project official homepage

You might want to look into that. Personally I've never used it but if you want encryption it might be the answer.
How great! Will look into that in more depth at day's end. FTR the AV I use blocks known malicious sites, so not such a concern to me personally if the DNS server doesn't. Though it never hurts to have multiple layers of security and in other areas I certainly do.

Thanks again for the helpful info and links. Very much appreciated! Cheers!
My System SpecsSystem Spec
04 Mar 2015   #13
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I meant that personally I prefer Norton DNS but switched to Google DNS to see if it resolved connection issues and when it did I then switched to Comodo DNS for the time being. My intention would be to go back to Norton DNS in the near future. It does sometimes block domains that my main AV doesn't (Comodo CIS & Firewall)

My System SpecsSystem Spec
.

04 Mar 2015   #14
remm

Win 7 Ultimate 64-bit
 
 

OK, gotcha! LOL... I am a little O.C. about my computer setup too... always tweaking, adjusting, preening. Computers are pets with USB ports.
My System SpecsSystem Spec
Reply

 FF v35.0.1 Reset Error (but loading page fine)




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
The connection to the server was reset while the page was loading
I get this message when I try to look at the national-lottery website, but that's the only website I've found so far that has the problem. It only started doing this a couple of weeks ago, but I haven't installed any new software (except for automatic updates) for about 3 months. I've tried:...
Browsers & Mail
BSOD only on cold boot, 100% fine after warm reset
I've been having problems with my rig and the only piece I haven't replaced is my processor. I have literally replaced every piece of hardware. And am maybe coming to the conclusion that it is a compatibility problem with my Intel i7-920 and my Asus rampage iii gene mobo. I've updated BIOS,...
BSOD Help and Support
websites not loading - error on page "500 internal server error nginx"
For the last 2 days, I am not able to access all google sites and facebook.com from my windows 7 PC. When I tried to access these websites, I am getting a blank page with the error message "500 internal server error -nginx". Can you please suggest me what could be the cause for this issue and how...
Browsers & Mail
Flashing cursor on cold boot, but all is fine upon reset?
I've done lots of searching and know that the "blank screen except a flashing cursor on boot" problem is pretty common, but haven't found anything like what I'm experiencing. When I power on after a full shutdown, I get a blank screen except for a flashing cursor in the top left corner of both...
General Discussion
Having trouble loading my cd onto laptop, works fine in stereo
Hey guys, I'm having trouble loading an audio cd on my laptop. The cd itself works just fine in my car stereo so I know there's nothing wrong with it, but it will not load when I put it into my computer. All my other CDs will load with no problems. When I insert the disk it makes a funny...
Media Center
'Lag' occurs when first loading a website though reported ping is fine
Ever since I reinstalled Windows 7 Pro on my desktop, new websites (or websites I've left alone for a 'while') are slow to visit on my UK broadband connection. I'm sure there are dozens of potential sources for the problem, but I'll try and be as specific as possible. I'm techy (since I program...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:42.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App