Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Browsing Slow - Windows 7 Professional, 64 bit

07 Nov 2009   #1
Helen

Windows 7 Professional
 
 
Browsing Slow - Windows 7 Professional, 64 bit

I just clean installed Windows 7 Professional, 64 bit on my computer. Browsing on IE8 is soooooooooooooooo slow. I thought 7 was supposed to be faster.


My System SpecsSystem Spec
07 Nov 2009   #2
richc46

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Helen, I just cleaned installed 7 with IE 8 and everything is very fast. I think that you have a bad installation. Try this, take your original installation DVD, insert it into your machine and go through the process as though you are going to install. However, at the point that you are asked, indicate that you want to make a repair. Basically anything that is not working correctly will be changed. I think that you will be happy with the outcome. Once you are happy, install all of your programs and make a system image. Save it. If you ever have a problem you can use the system image to make your OS, just like it was when you were satisfied. Let me know how it works out.

Check to be sure that your computer has the proper specs for 7.
My System SpecsSystem Spec
18 Mar 2010   #3
Jerry120

Windows 7 Professional 64-bit
 
 
Slow internet

Quote   Quote: Originally Posted by richc46 View Post
Helen, I just cleaned installed 7 with IE 8 and everything is very fast. I think that you have a bad installation. Try this, take your original installation DVD, insert it into your machine and go through the process as though you are going to install. However, at the point that you are asked, indicate that you want to make a repair. Basically anything that is not working correctly will be changed. I think that you will be happy with the outcome. Once you are happy, install all of your programs and make a system image. Save it. If you ever have a problem you can use the system image to make your OS, just like it was when you were satisfied. Let me know how it works out.

Check to be sure that your computer has the proper specs for 7.
I have the same problem. Repair did not solve it. I have downloaded and installed the latest drivers for my Marvell Yukon Ethernet Controller, which helped slightly, but there is still a major problem. I ran speakeasy.com/speedtest and find that I'm getting about an order of magnitude slower download speed than I should. The ATT guys came out, made a number of changes including new lines, but nothing helped. They confirmed that I am getting full speed to the modem, and from the modem, using another computer, so I know my computer is the problem. My wife and I are on the same modem, when I unplug mine she is fine, when I plug in mine hers slows down. My motherboard has a unique feature; I can connect to the internet without loading the operating system. In that case, running speedtest, I get the full download rate, so the problem is not in my hardware, must be in my operating system. I don't know how to go any further. Please help.
My System SpecsSystem Spec
18 Mar 2010   #4
Bill2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Run CMD as admin and type the following command.

netsh int tcp set global autotuninglevel=disabled

Hit enter.
My System SpecsSystem Spec
18 Mar 2010   #5
Desslok

Windows 7
 
 

Win 7 and IE8 is lightning fast for me, even on my little netbook. What I have seen slow it down is :
1. Antivirus programs -one I had to uninstall was AVGfree
2. Anti-spyware - Adaware rel time scanner was causing problems.
3. The Cox communication security bundle they give you free, had to uninstall.
4. Firewall programs - not set correctly.
My System SpecsSystem Spec
18 Mar 2010   #6
Jonathan_King

Windows 7 Professional x64
 
 

If the above 2 suggestions don't work, try uninstalling the driver for your network adapter in Device Manager.

Reboot, and let Windows automatically install the drivers.
My System SpecsSystem Spec
18 Mar 2010   #7
dajogejr

7 Pro 64 Bit
 
 

No issue at home or work for me. 64bit on ATT Cable connection at home (6 down, 1 up) and T1s at work-32 bit, 1.5 down and up.
My System SpecsSystem Spec
19 Mar 2010   #8
Seven Eleven

Windows 7 Professional x64 SP1
 
 

no problems with IE8 here.

could be a problem with anti-virus-spyware-firewall that you are running.
My System SpecsSystem Spec
19 Mar 2010   #9
Helen

Windows 7 Professional
 
 

Got the problem solved. Our NetGear Network needed to be updated. Love Windows 7 now!
My System SpecsSystem Spec
19 Mar 2010   #10
Jonathan_King

Windows 7 Professional x64
 
 

Great, thanks for posting!

Feel free to ask any more questions you might have.
My System SpecsSystem Spec
Reply

 Browsing Slow - Windows 7 Professional, 64 bit




Thread Tools





Similar help and support threads
Thread Forum
Slow internet browsing
I all of a sudden have slow internet browsing after getting messages for java updates. I disabled the Java add on so I don't get the message anymore but the browsing using either IE or Google is slow. I deleted temporary internet files and cookies and checked with my ISP. I ran malwarebytes scan...
Browsers & Mail
Windows 7 slow file and internet browsing.
Recently my compaq presario CQ56 has been running alot slower than usual, I have scanned with Spybot SnD, ESET and Free Malwarebytes, none of them found any viruses. I have a lower spec computer and it is faster on the same internet connection so I know it isnt the connection. This has only been...
Browsers & Mail
Updrade to WIN 7 Professional 64-bit, slower browsing speed
Hey all, I upgraded my OS from WIN 7 Home 64-bit, to WIN 7 Prof 64-bit and my browsing speed decreased dramatically. I primarily used Chrome before, but browsing is practically impossible on it now. So now I use Firefox 4 since its been decent with me. I have no clue what went wrong since the...
Network & Sharing
Slow browsing.
Hey guys. Had my new machine 4 or 5 months now, running great. Very high spec. Just yesterday, I was using Google Chrome and it just suddenly... wouldn't load ANY pages. My internet is working fine. So I used Firefox instead, as that seemed to be working fine. But today, that's being really...
Browsers & Mail
Windows 7 and web browsing very slow.
Hey guys. I bought and installed my Windows 7 like 1 month ago and it was working like a charm untill it started to get very slow like a week ago. It's acting very strangely. From pressing the boot button to actually work on the desktop it takes about 5minutes. I have removed all unnecessary...
Performance & Maintenance
Windows 7 Browsing slow
I have been trying to fix this problem for 4 days now, and I am pulling out my hair. I need help. I have installed both IE8 and Firefox, both have the same problem. Google loads super fast...no problem there. But other web pages, load very slow, some times more than 5 minutes. In my head I...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:59.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App