Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unable to open multiple websites in any browser

13 May 2015   #1
susan8231

Windows 7 Professional 32 bit
 
 
Unable to open multiple websites in any browser

I shut down my computer for a few days while away from home. After turning it back on, I'm unable to open various websites in any browser - Firefox, IE and Chrome. I've uninstalled my anti-virus software and turned off Windows firewall. Any suggestions as to the problem?


My System SpecsSystem Spec
.
13 May 2015   #2
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

If you are just clicking an icon or a favourite try putting the URL in the address bar and clicking Enter. If that doesn't work what error message are you getting? Forgive me for suggesting this but are you sure you are online whn trying to open a site?
My System SpecsSystem Spec
13 May 2015   #3
MoxieMomma

OEM Windows 7 Ult (x64) SP1
 
 

Quote:
I've uninstalled my anti-virus software and turned off Windows firewall
Quote:
Forgive me for suggesting this but are you sure you are online whn trying to open a site?
And, if you ARE online, I wouldn't conduct too much troubleshooting with neither your AV nor your firewall up and running...
It's a great way to catch computer cooties in a hurry.

<just a suggestion>
My System SpecsSystem Spec
.

13 May 2015   #4
susan8231

Windows 7 Professional 32 bit
 
 

Yes, I was online and entering the complete URL's. However, the problem has been solved. It was caused by my ISP providing some extremely slow speeds. After contacting tech support about the slow speed, all of the websites are now opening. I was not aware that download speeds could affect the accessibility of some websites. Anyway, problem solved. Thanks for the help.
My System SpecsSystem Spec
Reply

 Unable to open multiple websites in any browser




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
BSOD - no gaming - multiple apps open(VS, Word, email, browser)
I hope this is not a repost, but your site says I have nothing ever posted and I did 6 days ago. Here is what is going on: BSOD when just doing what I consider to be normal surfing, working in Word, VS etc. I have attached my file. It is worthy to note that I also had a freeze across my screens...
BSOD Help and Support
Unable to connect to certain websites (Browser/Connection Independent)
Hi, I have been struggling with accessing certain websites while using my laptop, HP Envy 14; Intel i5 CPU; Windows 7 Home Premium x64. For example, while I am able to navigate to Google, performing a search containing the word "statistics" results in a deactivation of google `instant' and a...
Browsers & Mail
multiple internet browser windows open automatically
Hello, I am running Windows 7 Prof x64. Recently, I have had a problem with multiple (sometimes 100+) internet browsers opening up automatically. This will happen even when I am not online. I have tried Firefox, Chrome and IE; all have the same problem. I have searched for malware, spyware,...
Browsers & Mail
Cannot login to certain websites in any browser
Hi, I recently bought a new Asus Laptop and am having difficulty login into some of my universities pages with the new computer (namely outlook web access and some library login pages). This happens regardless of connection type (LAN, WLAN and Mobile Broadband). I have reset IPCONFIG and other...
Browsers & Mail
IE8: Multiple internet explorer processes active with one browser open
Sometimes I will have 4-5 browsers open at once. I will then close all except one of them. When I go into task manager, Processes, there will still be 4-6 "iexplorer.exe" processes open. I don't want this. Why do they remain open after closing the browsers? Is there a fix for this?
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:01.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App