Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Browser slow

22 May 2015   #1
10beers

Win 7 Professional 32 bit
 
 
Browser slow

Hi guys, new here. Not sure if I posted in the right area. I'm having a problem with my other PC. I thought it was malware. I couldn't get rid of it. I formatted & when I got on line I'm having the same problem. When I write in a search, the letters are slow to come up. Going to a site, the spinning indicator jumps instead of spinning. I had some lightening in this area last week & wondering if it might have damaged something or is something just wearing out. I appreciate any help.


My System SpecsSystem Spec
.
22 May 2015   #2
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi and welcome toSevenForums,
If you don't have a surge protector it's very likely damage could of occurred

If you need some free scanners see if these find anything,
Review Jacee’s instructions to run Adwcleaner here post #7,
Ignore the title of the thread,
http://www.sevenforums.com/system-security/316404-instant-savings-app.html
On the BleepingComputer site use the button that looks like this,

You can use these free tools to see if they find anything,
Manually Update them before running full scans,
Try not to use your computer while the scans are running, (one at a time of course).
See this tutorial on how to download and run Malwarebytes,
http://www.sevenforums.com/tutorials/338716-malwarebytes-anti-malware-free.html
Also use the Custom scan option not the Threat scan,

Please Do Not clean/ Delete or Remove Any detections before posting the scan results first before review especially Malwarebytes,
http://www.malwarebytes.org/products/malwarebytes_free
SAS is safe to remove anything it finds
http://www.superantispyware.com/?tag=SUPERANTISPYWARE
This one is the longest up to 4 hours, the others are only about 45 minutes,
http://www.microsoft.com/security/scanner/en-us/default.aspx
My System SpecsSystem Spec
22 May 2015   #3
GokAy

Windows 7 Ultimate x64 SP1
 
 

Is your Avast free or paid? There is a bug with Avast at the moment, I wonder if it is affecting you.

Also monitor CPU usage, that kind of behavior happens here when CPU is high on load or internet connection is crippled.
My System SpecsSystem Spec
.

23 May 2015   #4
10beers

Win 7 Professional 32 bit
 
 

Thanks to both of you. I will into the info. It is connected to a surge protector. I use the free version of Avast. I use it also on the PC I'm using now (no problems). I'm also talking to Samuria & Jacee on your sister site. I will report on the results. Thanks again.
My System SpecsSystem Spec
23 May 2015   #5
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
Okay your in good hands then
My System SpecsSystem Spec
23 May 2015   #6
10beers

Win 7 Professional 32 bit
 
 

Thank you Thrash Zone, I'm happy to be here also.
My System SpecsSystem Spec
23 May 2015   #7
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

No problem
If you wish please post a link to your other question so we might follow your progress
Cheers.
My System SpecsSystem Spec
25 May 2015   #8
10beers

Win 7 Professional 32 bit
 
 

An update & solution to my problem. After a weekend of MS updates & trying anything I could think of I finally upgraded IE t(which wasn't working) to IE 11, it worked very well. I then uninstalled Firefox 38 & reinstalled Firefox 37, that solved my problem. There must be a problem with my pc & that version. I did uninstall avast & check the cpu & that didn't seem to be the problem. Thanks again to ThrashZone & GokAy for the support. I'll leave the thread open for a bit for any comments. Other than that this problem is solved.
My System SpecsSystem Spec
25 May 2015   #9
GokAy

Windows 7 Ultimate x64 SP1
 
 

Hey, glad you fixed your issue. I haven't done anything though.
You can mark it solved, the thread doesn't get closed doing so.
My System SpecsSystem Spec
25 May 2015   #10
10beers

Win 7 Professional 32 bit
 
 

Will do thanks again.
My System SpecsSystem Spec
Reply

 Browser slow




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Browser Running Slow
Last week my internet browser (FireFox) started loading very sluggishly almost at dial up speed. I ran Norton and it found no problems so I then reset my browser and still had the same issue. I then did a speed test and it said my Ping was 18 but my download speed was 0.4kbps and upload was...
Browsers & Mail
Web Browser extremely slow
Has anyone else experienced problems with IE9? All of the sudden, my browser is extremely slow in uploading web pages and I can no longer download streaming videos.
Browsers & Mail
Slow browser, slow internet, random audio ads: virus?
So yeah, I've these problems for the past couple days. My browsers (Opera and Firefox) used to load pages quickly, but now they're painfully slow. Opera lags and freezes often; Firefox doesn't, but it still takes a very long time to load pages. I'm also getting these occasional "invisible ads,"...
System Security
Is Your Browser Slow?
If you answered YES, then probably you are using Internet Explorer. I used IE for ten years or more. This past weekend the baseball site I frequent forced me to switch due to an overhaul of their site. I am now using Firefox 11 and it is much, much faster. If yours is slow, give Firefox a...
Browsers & Mail
Browser slow to open
Moved from Vista to W7 supposedly successfully. After a week or so of satisfactory operation the browser windows started to become slow to open. After having taken 2 or 3 seconds to open having clicked on the explorer icon it suddenly became 15. Likewise opening a JPEG with exploer or the...
Browsers & Mail
keyboard lag/browser slow
After my system has been up for a while I start to see some things get slow or sluggish. When I type the response is slow, what I type shows on the screen a sec. or two after I type it. Web page graphics are slow to come up. The overall speed of the system does not seem to be effected, just...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:24.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App