Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet browsing very slow after brand new installation of 64bit Win7

17 Jun 2015   #1
bigblocktowncar

Windows 7 Pro 64bit
 
 
Internet browsing very slow after brand new installation of 64bit Win7

Intel E2160 1.8ghz dual
2gb of RAM DDR2 5200
brand new Win 7 64 bit installation, all updates to SP1
IE 11

I upgraded my mom's computer from Vista to Win 7. It is an older machine that I bought her back in 2008 I think....I know that the RAM is on the low side, but I think there is some other sort of problem going on here.

It is like something is blocking web pages from loading....they do eventually, but browsing is very slow. Opening IE is quick as is loading up programs etc...not indicative of a "slow computer" or running out of resources.

Once IE is open it probably takes google 30-60 seconds to actually appear......but once it is up, the search is very fast like you would expect. Going into a webpage is also very slow. It is like the initial page load is slow and then searching is normal speed.

I turned off the windows firewall, but couldn't think of anything else. I noticed that the CPU usage and RAM usage are high going above 50% at times, but I found google results of people using Win 7 on even older, slower machines.

Any idea?


My System SpecsSystem Spec
.
17 Jun 2015   #2
GokAy

Windows 7 Ultimate x64 SP1
 
 

With 2 GB of RAM you would be better off with 32 bit.

Try another DNS server. "ipconfig -flushdns" afterwards - https://www.google.com/url?q=http://...6z2aXNcEi7K-Fw
Try a clean startup, it should help with RAM/CPU - Troubleshoot Application Conflicts by Performing a Clean Startup
My System SpecsSystem Spec
Reply

 Internet browsing very slow after brand new installation of 64bit Win7




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Slow internet browsing
I all of a sudden have slow internet browsing after getting messages for java updates. I disabled the Java add on so I don't get the message anymore but the browsing using either IE or Google is slow. I deleted temporary internet files and cookies and checked with my ISP. I ran malwarebytes scan...
Browsers & Mail
Multiple BSOD Brand New Win7 Pro 64bit 0x19 and 0x3b
Hey guys, I am at a loss here I have gotten multiple BSOD's on my new Laptop. I am currently trying to use the SF Diagnostic Tool to grab my dumps for uploading but getting a weird \\desktop not found error. I have downloaded and run the bluescreenview utility, I have attached screen shots...
BSOD Help and Support
Slow Internet Browsing
My machine is presario cq62, with an intel i5 processor. i do experiencing an extraordinary slowness in both browsing and downloading. I Tried re-installing OS several times, and was not successful. I'm using avg antivirus package. I'm using Google crome as current browser. Cooling fan is also...
Browsers & Mail
Internet browsing slow with IE9
When I use IE9 to browse the internet it sometimes is very slow. I have run an internet speed test program (speedtest.comcast.com) which hangs when testing IE9. I then started Chrome and the internet browsing was fast. I ran the speed test program and the speed was what I expected. I switched...
Browsers & Mail
slow internet browsing
At my home network my pc runs just nicely. But today I moved it to my friends place and for some reason all surfing is really slow, like google.com takes up to 30-40 seconds to load. Using my laptop computer it loads in about a second on the same network. I am on a 4mb/500kb connection and...
Network & Sharing
BSOD on brand new comp.. Win7 64bit
Analysis -------------------------------------------------------------------------------- Crash dump directory: C:\Windows\Minidump Crash dumps are enabled on your computer. On Wed 2010-05-12 오전 1:55:02 your computer crashed This was likely caused by the following module: ntoskrnl.exe
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:17.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App