Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Pages take a long time and unresponsive-all browsers

21 Nov 2015   #11
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Great. DNS servers seem to be a bit flaky sometimes!


My System SpecsSystem Spec
.
21 Nov 2015   #12
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

This is good news; Great help Callender!
My System SpecsSystem Spec
Reply

 Pages take a long time and unresponsive-all browsers




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Browsers do not load pages properly!
Hello everyone, im new here. I have a problem with my new laptop i have recently bought. Dell Inspiron 7537 15inch OS 8.1 (after upgrade from 8.0) 16gb RAM, Samsung SSD SM 841 256gb. Lets go to the point - When i try to load a page, usually i have to refresh that page, because i get an error like...
Browsers & Mail
Almost all browsers are dead, not loading any web pages.
As I type this I am using Safari as this is the only browser that loads any web pages. When I try to load a web page in ANY other browser it's just a white screen, it tries to connect, and gives me the "This webpage is not available" page. The only one that works aside from Safari is the Steam...
Browsers & Mail
browsers doesn't display web pages without proxy
I have a dsl cable internet connection and I use proxy sometimes. Recently my browsers couldn't open any webpage without activating proxy. I used to ping some domains and I got replies and I looked at proxy setting in any browser and choosed no proxy , but when I try to open a website It says for...
Browsers & Mail
Some pages do not load in any of the browsers
Hi all i am new to this forum :D I just formatted my windows 7 a month ago and re-installed it . Few weeks ago i changed my modem to Netgear N150 modem + router . After that Most of the websites don't load . Eg : Facebook , yahoo , ms support , etc . I was scanning for any malware or virus but i...
Browsers & Mail
Connected to Internet but CANNOT Load Pages in Browsers
For a few months now, a few times a day, I'll be surfing fine but after awhile my browser (Firefox or IE) cannot load any pages, it'll say something like cannot load page. But I notice my downloads are still going (in Firefox or µTorrent, etc.) and my VoIP still works. I"m on a WIRED...
Network & Sharing
randomly unresponsive, then long reboot
I've been trying to track this down, and fix it, since I built this system 5 months ago. Now I'm getting desperate... when all else fails, ask for help. Problem: every few days, or occasionally twice a day, my system will become very slow. Programs become unresponsive, (even pulling up the task...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:03.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App