Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: internet connection problem after system sleeps

15 Nov 2009   #1

Windows 7 64
 
 

Hello,

When my computer goes to sleep, when I start it back up, my internet shows it is connected. But nothing works. I get connection errors and also my email does not work. Will not download or send mail. If I restart, then everything is fine. I have a cable internet.

Any suggestions are greatly appreciated!

Greg the bear

Thanks for the idea. I tried it and below is a cut from the screen when I did the inconfig's. I tired to copy it here but it would not let me paste it in for some reason.

Anyway, it did not work. I still had to reboot my computer.

Everything was working good, until I loaded Yahoo Messanger. Is there something from it that could be causing my problem?

Thanks again

I believe that it has something to do with Yahoo Messenger 10. When I unloaded it, I quit having this problem. I seem to have another problem after doing so though. After doing so hyperlinks in my emails quit working. I found that if you load up Firefox, and unload it somehow it fixes it. I do not know about the unloading part, but it did start working after I loaded Firefox.

Hello,

I thought that I had this cured but it is back again. I have the power options setting on my computer as power saver. When my computer goes to hibernate, my internet connection is lost until I reboot. I at first thought that it was something wrong with Yahoo Messenger, but now I do not believe so. I'm thinking that it is something with the system going to sleep.

My system is a Dell XPS 710, I am running Win 7 64 bit. All else seems fine, just this problem.

All suggestions are appreciated. It is a big inconvenience having to reboot all of the time.

Thanks,
Greg


Thanks Jonathan, It did have the box "Allow the computer to turn off the device " checked. I am trying it unchecked. Hope this works.

As for the drivers, as near as I can tell I am up to date on them. I did have a lot of trouble with the sound driver at first, but I was able to get one that would work with Win 7 and now all is well on the sound front!

Thanks
Greg


Hello, Back again on this one! Did not work! Any more suggestions??

This has been a nagging problem that I have been having. Anybody have any suggestions?




Attached Images
 
My System SpecsSystem Spec
.

15 Nov 2009   #2

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Greg the bear View Post
Hello,

When my computer goes to sleep, when I start it back up, my internet shows it is connected. But nothing works. I get connection errors and also my email does not work. Will not download or send mail. If I restart, then everything is fine. I have a cable internet.

Any suggestions are greatly appreciated!

Greg the bear
Ho greg and welcome

try this next time you have the problem. type cmd in search> then
ipconfig /flushdns, then ipconfig /renew If that fixes the problem we know how to cure it


Hope this helps

Ken
My System SpecsSystem Spec
08 Dec 2009   #3

Windows 7
 
 
Same Problem - eithernet connection only

I have the same problem with my wired connection. My wifi works fine but the wired connection disconnects after sleep mode.
My System SpecsSystem Spec
.


19 Dec 2009   #4

Windows 7 64
 
 

I never had this problem before I upgraded to Win 7. Though I also updated to Yahoo Messenger 10 at the same time. Any ideas of how to fix this? Or is this something that I just have to accept and live with?
My System SpecsSystem Spec
08 Jan 2010   #5

Windows 7
 
 

Hey Greg - I have exactly the same problem on Windows 7 64bit (though I don't use it on a laptop). I have learned to live with it, but it has a really easy fix rather than a reboot every time.

Right click the little internet connection button in the corner, and click on 'Troubleshoot'. Fixes itself in <20 sec every time. Sorry I can't help with a permanent fix :/

J
My System SpecsSystem Spec
08 Jan 2010   #6

Windows 7 Home Premium 64bit
 
 

i have this problem but with WI FI

it takes about 30 - 60sec then i can connect.

Mine keep changing to i have connection then i dont
My System SpecsSystem Spec
08 Jan 2010   #7

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

My System SpecsSystem Spec
08 Jan 2010   #8

Windows 7 Ultimate 32 bit
 
 

Windows has always had some bugs in conjunction with sleep-standby-hibernate I always turn off any and all power saving settings do to this.

I would recommend to turn off the power saving settings on the wired/wireless adapters themselves also create a custom power plan.

Something else is on laptops the OEM usually puts some software of it's own on for power control which will override the settings applied from Windows itself I would recommend uninstalling such software.
My System SpecsSystem Spec
10 Feb 2011   #9

Windows 7 Pro at home, 2 Windows XP Pro where I volunteer
 
 
I'm with most of you in this thread?

I also have the same problem with sleep or hibernate with all of you above to a wired connection. The tray icon says "connected", but my browser (won't refresh site) & email client (won' get new emails or send) say "no"! I once was OK (Win 7 Pro) with an old (2Wire) modem/router (died in Dec. 2010) but failed with 2 brands of modem/router!
My System SpecsSystem Spec
Reply

 internet connection problem after system sleeps




Thread Tools



Similar help and support threads for2: internet connection problem after system sleeps
Thread Forum
BSOD as system sleeps BSOD Help and Support
System crashing when PC sleeps BSOD Help and Support
internet connection problem Network & Sharing
Internet connection error or internet Download Manager problem Software
Hey guys, my internet connection seems to be slowing down my system Performance & Maintenance
Internet Connection Problem Network & Sharing
loosing internet connection 3-5 mins after starting system. Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:11 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33