Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Laptop slow to load pages

28 Jun 2016   #1
spottydog10

windows 7 enterprise 64-bit
 
 
Laptop slow to load pages

Certain sites, usually with a load of adverts go into whirring icon mode for a good 30 secs several times on my laptop which is i5, 8Gb, SSD, NVidia GeForce 825M. It's a recent-ish fresh install of Win 10.
This is both on IE and MS Edge.

The same sites are fine on my desktop i7, 8Gb, SSD, oldish ATi card.

Is this changeable in any way or do I just have to put up with the fact that the laptop will be inherently slower in this way?

Thanks.


My System SpecsSystem Spec
.
01 Jul 2016   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hello spotty mate I am assuming you mean both computers?? as IE I was under the impression is now Edge in 10.

Anyway sounds like you have picked up a lot of unwanted clutter so have you run any scans? if not run these

SUPERAntiSpyware | Remove Malware | Remove Spyware - AntiMalware, AntiSpyware, AntiAdware!
Malwarebytes | Malwarebytes Anti-Malware Premium
AdwCleaner Download
ADW download from bleeping computer delete any rubbish found with the malware scans
(NB If you are running Kaspersky as the main AV then it might need disabling it when trying ADW because it does not like it at times)

Now the SAS will always pick up a lot of Possibly Unwanted Programs (PUP's) and I run it regularly to keep the rubbish at bay.
My System SpecsSystem Spec
01 Jul 2016   #3
spottydog10

windows 7 enterprise 64-bit
 
 

Hi ICIT2LOL, I have Edge and IE installed on the Win 10 laptop.
The desktop is Win 7.
One of the worst offenders is:

Liverpool Echo: Latest Liverpool and Merseyside news, sports and what's on
I ran the SAS with no noticable improvement and have ran Malwarebytes previously with no improvement.
See if you get the same issues as me using a laptop.
Thanks mate
My System SpecsSystem Spec
.

02 Jul 2016   #4
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok mate now my bad for not reading that properly ie the fault is on the 10 on the lappy. Have you tried running the sfc on the machine yet?? SFC Command - Run in Windows 10 - Windows 10 Forums and myself I would even do this if the sfc comes up nothing Drive Error Checking in Windows 10 - Windows 10 Forums

Just as matter of interest how old is the laptop and hence the drive RAM etc?? Plus if we cannot come up with anything in here then maybe the tensforum might be worth a post at the top of this reply - same crew
My System SpecsSystem Spec
02 Jul 2016   #5
spottydog10

windows 7 enterprise 64-bit
 
 

I should have said that I put Win 10 on the laptop because win 7 was doing the same thing, slow page loading on certain sites, both were clean installs.

The laptop is about a year old, i5, 8Gb, and SSD. It has 2 video cards, an integrated Intel HD 4600 and an
NVidia Geforce 825m.
The way I understand it you can set the more powerful GEForce card to take over high resource tasks.
I have set it to take over for both Edge and IE with no improvement.

With regard to that Liverpool Echo site, try clicking through to one of the storys and see if it affects your speed or not.

Thanks mate,
Mike
My System SpecsSystem Spec
02 Jul 2016   #6
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Must be about the number of transfers from My boys to your.
Apparently there talking about having a referendum in regard to renaming your team to Southliverpool


Roy
My System SpecsSystem Spec
02 Jul 2016   #7
spottydog10

windows 7 enterprise 64-bit
 
 

Roy, my team is Everton mate. (ducks head)
My System SpecsSystem Spec
02 Jul 2016   #8
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Quote   Quote: Originally Posted by spottydog10 View Post
Roy, my team is Everton mate. (ducks head)
Go the Hammers woo hoo!

Forever blowin bubbles pretty bubbles in the air
My System SpecsSystem Spec
02 Jul 2016   #9
FerchogtX

Microsoft Windows 7 Home Premium SP1 64-bit Build 7600 / Microsoft Windows XP Professional SP3
 
 

Mhhh... this is weird.
In my sig, you can check my specs for the laptop I'm currently using... this PC is from 2009, and I can run the content quite smoothly -Except of course, flash videos, because Flash performance with HD stuff sucks, HTML5 runs much better.-

Navigation is fast, page loading is fast, I can scroll considerably fast taking in mind my type of machine.

Do you have the most up-to-date drivers for both your VGA cards? If you do, your nVidia card should take care of high load tasks (hardware acceleration) as it has better support for H264, Flash 3D acceleration and a couple of things. Check also if Windows 10 enables at least DirectX 11. I've tested it before, and drivers for my machne sucked hard (gave DX10 instead of 11, like W7 does), if you have less than DX11, performance regarding VGA will drop dramatically in many cases (DX11 is faster than DX10, 'cause of optimizations). If you can get higher than 11, it's better (even if some features of DX12 cannot be used, only 2015 cards can get advantage of DX12 features, as far as I know)

If the problem is load times, it might be either your ISP (speed being droped at times) or too many ads on that site, which would lead you another solution, that cannot be disscused here. Anyway, I don't see the problem with ads (if there are any, I tried in many ways, and I can't see ads, or slow loading times...)

Another thing to consider might be your type of connection... you use WiFi, I assume... Try using your LAN cable and see if that improves speed. If that does, you might be having bad signal spectrum, or probably, the Wi-Fi card is acting up, sometimes -rarely, but still- mine does, reseting the thing again does the trick.

I forgot to mention I'm using Firefox with e10s enabled for this, probably testing in Firefox can help to see if you get any improvements...
My System SpecsSystem Spec
03 Jul 2016   #10
spottydog10

windows 7 enterprise 64-bit
 
 

Hi FerchogtX

My version of DirexctX is 12.
I think it could be waiting for flash videos to load, there's usually a couple of flash adverts per page on that Echo site. Once flash has played it's unwanted videos the scroll bar can be used again.
Thanks, Mike
My System SpecsSystem Spec
Reply

 Laptop slow to load pages




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
IE 11 cannot load certain pages
Hello all, I have searched this problem and found many others have had it or similar. However none of the solutions seems to help. Everything had been working fine the it just stopped working. As I am the only administrator account no one could have downloaded anything, and I did not make changes....
Browsers & Mail
Some pages will not load.
When using Internet Explorer 11 I have a problem accessing some websites, I am often unable to go any further than the website homepage, for instance when using internet banking, After I log into an account itís here where the problem happens, I try to open a page within my account but nothing...
Browsers & Mail
Random web pages will not load.
It dose not matter the browser if it will not load I have to disable and re enable the network adapter, its only happening on one PC. I have Kaspersky Internet security 2013 installed. Going to uninstall it today and see if its fouled up and needs a clean reinstall but if that fails what else can I...
Browsers & Mail
IE very slow to load pages or respond to clicks
In Windows 7 (of course), my problem is that IE is very slow to load web pages and also slow to respond to clicks such as menu clicks. It became virtually unusable last evening, taking 30 minutes or more to load a single page, and then an equally long time to respond to every click. Here is what...
Browsers & Mail
Wont load certain pages.
No matter what browser i use. i just cant access the steam support. or community page. iv tried everything. stopping firewall. re-installing java. uninstalling nvidia network manager. etc. this is what i see when i try to load. and it dosnt matter where i am ( like if im round a friends...
Browsers & Mail
Firefox and IE won't load some pages
Hey everyone, does anyone have any idea why both my browsers are refusing to load fairly common websites like espn.com and my university's website?
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:31.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App