Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Google Chrome - browser lags every few seconds!


21 Nov 2009   #1

Windows 7
 
 
Google Chrome - browser lags every few seconds!

I am running Windows 7 Ultimate 64 bit, and every few seconds my Google Chrome browser will lag, and then catch up with its self several seconds after. Even whilst typing this message it has happened twice. I don't want to have to revert to crap browser! These are my computer specifications:
Dell studio 15
Intel Core i7 720, x1.6ghz
4GB DD2 Ram
6mb cache

Thanks


My System SpecsSystem Spec
.

26 Nov 2009   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

I am not familiar with Chrome, but I do know Explorer. In Explorer in the Internet Option box (Tools>Internet Options>Advanced, there is a button. It is labled reset. Now my help comes to an end, other than to say find the equivilent in Chrome and I think your problem will be solved.
My System SpecsSystem Spec
27 Nov 2009   #3

Windows 7
 
 

Mer, erm, no, there is no button like that... tbh, its a problem that is deep set in the browser, that will require something a lot more significant than a reset button I am afraid... thanks anyway.
My System SpecsSystem Spec
.


27 Nov 2009   #4

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Quote   Quote: Originally Posted by toxicwaste288 View Post
Mer, erm, no, there is no button like that... tbh, its a problem that is deep set in the browser, that will require something a lot more significant than a reset button I am afraid... thanks anyway.

Sounds like a bad installation. Set up a restore point, then uninstall and install the browser again. The restore point can bring you back to where you were prior to uninstalling.
My System SpecsSystem Spec
27 Nov 2009   #5

Windows 7
 
 

Sorry, tried that already. . . I have heard its a problem with all x64 Win 7 with intel core processors. I don't know how to fix it...
My System SpecsSystem Spec
27 Nov 2009   #6

Windows 7 Professional x64
 
 

I have same problem
Google Chrome laggs/freezes
My System SpecsSystem Spec
28 Nov 2009   #7

 

There is a reset button


Attached Images
 
My System SpecsSystem Spec
Reply

 Google Chrome - browser lags every few seconds!




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:19 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33