Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Google chrome on windows 7 x64


16 Dec 2009   #1

Windows 7 x64
 
 
Google chrome on windows 7 x64

Hi,

I have recently installed windows 7 64bit version. i really like it but i am disaponted becuase i couldn't install google chrome on it.

i have downloaded the installation file and when i double click it to install, it will begin donwloading and then it just go and doesn't continue with the installation.

is there a way to install google chrome, or do you know if there is a browser that is 64bit.???

thanks


My System SpecsSystem Spec
.

16 Dec 2009   #2

Windows 7 Pro x64
 
 

Google Chrome does not have 64 bit for Windows. That is only for Linux so that is not the problem. I've installed Chrome 10 times at least of different Windows 7 computers. I've never had a problem. Sometimes it does take a while for it to work. How long have you been waiting?
My System SpecsSystem Spec
16 Dec 2009   #3

Windows 7 Professional 64-bit
 
 

Chrome works perfectly in 64-bit Windows 7. The installer is silent, in other words there is no progress bar or anything helpful.

You should find Chrome installed at C:\Users\account\AppData\Local\Google\Chrome\Application.
My System SpecsSystem Spec
.


17 Dec 2009   #4

Windows 7 x64
 
 

Hi, I have waited for chrome installation progres for about 15min...

and about the location "C:\Users\account\AppData\Local\Google\Chrome\"
it doesn't exist on my computer.

i' don't know what is happening and why?
My System SpecsSystem Spec
17 Dec 2009   #5

W7 RTM Ultimate x64
 
 

Quote   Quote: Originally Posted by microbert View Post
Hi, I have waited for chrome installation progres for about 15min...

and about the location "C:\Users\account\AppData\Local\Google\Chrome\"
it doesn't exist on my computer.

i' don't know what is happening and why?
Tried re-downloading the installer?

I had the same symptoms as you, due to a corrupt installer.
My System SpecsSystem Spec
Reply

 Google chrome on windows 7 x64




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:00 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33