Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: IE 8 slow performance

12 Jan 2010   #1
codudi

Windows 7 x64
 
 
IE 8 slow performance

Today, suddenly IE 8 has a slow performance. It takes 10-15 secs until it loads a site and by clicking on a new tab, IE shows 'Connecting' for about 15-20 seconds. I have tried all the followings ideas, but non helped to resolve this:

1. Reset IE settings
2. Start IE under clean boot
3. 'Uninstall' and 'Reinstall' IE 8 (using the Win7 features)
4. Delete all cache, and temp files
5. Disable all add-ons

Note to mention that launching IE under administrator privilege, solve the 'connecting' issue, but sites loading is still slow. Also, similar behavior If I start IE as "InPrivate Browsing".

BTW, Firefox has none of those issues, thus this is not a networking problem.

Any new idea that I have not tried yet?

Thanks

Win 7 Pro x64


My System SpecsSystem Spec
.

12 Jan 2010   #2
Ch@n

 

Welcome codudi. One step missed by u and the final resort for u and me is, fire the following command in command prompt,

sfc /scannow
once complete, restart your machine and check IE performance.

Al the very best.
My System SpecsSystem Spec
12 Jan 2010   #3
codudi

Windows 7 x64
 
 

I did that (actually the first thing) and same slow performance issue.
My System SpecsSystem Spec
.


13 Jan 2010   #4
KylerIE8Team

Windows 7
 
 

One thing that can really slow down IE8 or even freeze it, is if there are a lot of 'add-ons' running while you are trying to browse, managing your add-ons can really speed up browsing. To fix try this:
In IE, go to ‘tools’ and ‘manage add-ons’.
Disabling any unnecessary add-ons may help your Internet run faster.
Try disabling add-ons with more than a .2 sec load time. (i.e. tool bars)
If you’re still not having any luck, I recommend you reinstall IE8 on your system.
-Kyler
IE 8 Outreach Team
My System SpecsSystem Spec
28 Feb 2010   #5
cjbiiv

Various (XP, Vista, and Seven) by Computer
 
 

Same exact problem as codudi: "...suddenly IE 8 has a slow performance. It takes [~20] secs until it loads a site and by clicking on a new tab, IE shows 'Connecting' for about [~20] seconds..."

I performed the following:
1. Chkdsk & sfc
2. Disk cleanup
3. Delete all IE cache, temp files, cookies, etc.
4. Start IE under clean boot
5. Disable all IE add on's
6. Installed Chrome - no problem (sites/news tabs were available <1 second
I noticed "Protected Mode: On" in the IE status bar. Once I turned it off, the performance problem disappeared.

My wife's laptop is behind a router, runs the Windows 7 firewall, and Microsoft Security Essentials. I may just leave protected mode off or run Chrome (or Firefox) unless someone has another thought? Thanks!
My System SpecsSystem Spec
Reply

 IE 8 slow performance




Thread Tools





Similar help and support threads
Thread Forum
Slow bootup, slow performance
I have a Dell Latitude E6520 i5-2520 (2.5GHz), 8GB RAM, 7200RPM HDD, Windows 7 Pro x64. After installation everything seems super ok . Bootup time, working in windows, etc. Then i decided to start the update (about few hundred megabytes). After the upgrade it seems that everything is...
Performance & Maintenance
very slow startup and slow performance over all
its about 6 months i m using the same window, but now it starts really slow and over all performance of my system is also down. i have dell n5110 i5 with 4gb ram, and please i dnt want to reinstall window :( also i am using selective startup Any suggestions?
General Discussion
Slow performance lately?
Greetings guys, My computer yesterday was working normally as it is supposed to. But today when I switched on my PC it acted very weird. The problem is that whenever I play a song (via Youtube/WMP/VLC media player Etc..) and scroll down on Facebook or browse through the folders, the songs...
Performance & Maintenance
slow performance
my laptop is compaq presario cq62. CORE i5 M430 2.27 Ghz 320 GB HDD 2 GB RAM but when i copy file to any file to pen drive it gives speed of 5-7 mbps. when i copy from pen drive to laptop it gives speed of 10-11mbps. when i copy file from one drive to another it gives speed of 20.4mbps.
Performance & Maintenance
Slow Performance, Slow Boot-up - Cause Undetermined!
Hello everyone, I have done a lot of research on Google as well as on this forum to find a solution to my problem. Unfortunately, people who have posted on the forums have SIMILAR but not the exact problem as I have. I would like to take this opportunity and explain exactly whats been going...
Performance & Maintenance
W7 Slow Boot Time and Overall Slow performance
Hi new to these forums and I'm hoping someone can help me out here. I formated my HDD and did a clean install (W7 7100 build) but I'm noticing slow boot times and slow performance compared to Vista x64. W7 boots at least 10secs slower and programs tend to lag (aren't as snappy compared to...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:09.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App