Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: IE 8 slow performance


12 Jan 2010   #1

Windows 7 x64
 
 
IE 8 slow performance

Today, suddenly IE 8 has a slow performance. It takes 10-15 secs until it loads a site and by clicking on a new tab, IE shows 'Connecting' for about 15-20 seconds. I have tried all the followings ideas, but non helped to resolve this:

1. Reset IE settings
2. Start IE under clean boot
3. 'Uninstall' and 'Reinstall' IE 8 (using the Windows 7 features)
4. Delete all cache, and temp files
5. Disable all add-ons

Note to mention that launching IE under administrator privilege, solve the 'connecting' issue, but sites loading is still slow. Also, similar behavior If I start IE as "InPrivate Browsing".

BTW, Firefox has none of those issues, thus this is not a networking problem.

Any new idea that I have not tried yet?

Thanks

Win 7 Pro x64

My System SpecsSystem Spec
.

12 Jan 2010   #2

 

Welcome codudi. One step missed by u and the final resort for u and me is, fire the following command in command prompt,

sfc /scannow
once complete, restart your machine and check IE performance.

Al the very best.
My System SpecsSystem Spec
12 Jan 2010   #3

Windows 7 x64
 
 

I did that (actually the first thing) and same slow performance issue.
My System SpecsSystem Spec
.


13 Jan 2010   #4

Windows 7
 
 

One thing that can really slow down IE8 or even freeze it, is if there are a lot of 'add-ons' running while you are trying to browse, managing your add-ons can really speed up browsing. To fix try this:
In IE, go to ‘tools’ and ‘manage add-ons’.
Disabling any unnecessary add-ons may help your Internet run faster.
Try disabling add-ons with more than a .2 sec load time. (i.e. tool bars)
If you’re still not having any luck, I recommend you reinstall IE8 on your system.
-Kyler
IE 8 Outreach Team
My System SpecsSystem Spec
28 Feb 2010   #5

Various (XP, Vista, and Seven) by Computer
 
 

Same exact problem as codudi: "...suddenly IE 8 has a slow performance. It takes [~20] secs until it loads a site and by clicking on a new tab, IE shows 'Connecting' for about [~20] seconds..."

I performed the following:
1. Chkdsk & sfc
2. Disk cleanup
3. Delete all IE cache, temp files, cookies, etc.
4. Start IE under clean boot
5. Disable all IE add on's
6. Installed Chrome - no problem (sites/news tabs were available <1 second
I noticed "Protected Mode: On" in the IE status bar. Once I turned it off, the performance problem disappeared.

My wife's laptop is behind a router, runs the Windows 7 firewall, and Microsoft Security Essentials. I may just leave protected mode off or run Chrome (or Firefox) unless someone has another thought? Thanks!
My System SpecsSystem Spec
Reply

 IE 8 slow performance




Thread Tools



Similar help and support threads for2: IE 8 slow performance
Thread Forum
Slow bootup, slow performance Performance & Maintenance
very slow startup and slow performance over all General Discussion
Slow performance Performance & Maintenance
Slow performance Performance & Maintenance
slow performance Performance & Maintenance
Slow Performance, Slow Boot-up - Cause Undetermined! Performance & Maintenance
W7 Slow Boot Time and Overall Slow performance Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:37 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33