Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow Browser or Internet Connection?

31 Jan 2010   #1
jonnyboss

Windows 7
 
 
Slow Browser or Internet Connection?

Hi guys,

I have a problem with accessing the internet. I have a 4MBit/s broadband connection, which I have tested and it is exactly 4 MBit/s. When I open up any browser (Opera, IE or Winfox/Firefox) it takes about 5 seconds for the google homepage to appear. This seems too slow to me, but maybe you know better? Other pages take much longer..20 seconds for a normal webpage.

Hope you can help

Cheers,

Jonny


My System SpecsSystem Spec
.
31 Jan 2010   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by jonnyboss View Post
Hi guys,

I have a problem with accessing the internet. I have a 4MBit/s broadband connection, which I have tested and it is exactly 4 MBit/s. When I open up any browser (Opera, IE or Winfox/Firefox) it takes about 5 seconds for the google homepage to appear. This seems too slow to me, but maybe you know better? Other pages take much longer..20 seconds for a normal webpage.

Hope you can help

Cheers,

Jonny

Johnny You have 4mb down but probably only 500K up. You can go to anyofthe commercial services and have that checked. I use speedtest.net. They will tell you actual. I suspect the delay may have more to do with your system than the connection

Ken
My System SpecsSystem Spec
31 Jan 2010   #3
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Run an antivirus scan. and try internet


Run malwarebytes. try internet
http://www.malwarebytes.org/mbam.php

Turn off the Antivirus. try internet.


Try each of these steps. If none work. We can look further.
My System SpecsSystem Spec
.

01 Feb 2010   #4
jonnyboss

Windows 7
 
 

Hi guys,

the maleware thing didn't work unfortunately.

Using the test I have: Download: 3.61Mb/s and Upload: 0.04 MB/s and Ping: 1310ms.

How are those values?

Cheers

Jonny
My System SpecsSystem Spec
01 Feb 2010   #5
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by jonnyboss View Post
Hi guys,

the maleware thing didn't work unfortunately.

Using the test I have: Download: 3.61Mb/s and Upload: 0.04 MB/s and Ping: 1310ms.

How are those values?

Cheers

Jonny

JB

Its the ping tiime that is killing you. 3,61 down is enough. Are you using homegroup for your networking? Are there any other machines running a different OS?

Ken
My System SpecsSystem Spec
01 Feb 2010   #6
seekermeister

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

If that ping time came from speedtest.net, try using a different server and run the test again, to rule out the possibility of a bad server downstream. You should also run a tracert from Command Prompt to another location on the web, so that you might be able to see where the bottleneck is. If you are unfamiliar, the screenshot should help:


Attached Thumbnails
-tracert.png  
My System SpecsSystem Spec
02 Feb 2010   #7
jonnyboss

Windows 7
 
 

Quote   Quote: Originally Posted by seekermeister View Post
If that ping time came from speedtest.net, try using a different server and run the test again, to rule out the possibility of a bad server downstream. You should also run a tracert from Command Prompt to another location on the web, so that you might be able to see where the bottleneck is. If you are unfamiliar, the screenshot should help:

Hi Seekermeister,

I did like you said and here is the result:

Tracing route to front.opera.com [195.189.143.147] over a maximum of 30 hops
1 3 ms 3 ms 3 ms 192.168.1.1
2 1758 ms 1447 ms 2362 ms rdsl-dsdf-de01.nw.mediaways.net [213.20.58.193]
3 2461 ms 1687 ms 2066 ms xmwc-dsdf-de02-chan-18.nw.mediaways.net [195.71.
242.118]
4 1820 ms 1829 ms 1857 ms ge7-0-0.ffm2nxg1.de.ip.tdc.net [80.81.192.16]
5 1830 ms 2280 ms 1693 ms 85.19.122.230
6 1778 ms 1682 ms 2290 ms 85.19.81.238
7 2438 ms 1986 ms 2067 ms front.opera.com [195.189.143.147]
Trace complete.


This doesn't look too healthy does it? Do you know anything that I can do about this?


Cheers


Jonny
My System SpecsSystem Spec
02 Feb 2010   #8
TGSoldier

 
 

Your pings are so high.

Hard reset on your modem and router.
My System SpecsSystem Spec
02 Feb 2010   #9
jonnyboss

Windows 7
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
Quote   Quote: Originally Posted by jonnyboss View Post
Hi guys,

the maleware thing didn't work unfortunately.

Using the test I have: Download: 3.61Mb/s and Upload: 0.04 MB/s and Ping: 1310ms.

How are those values?

Cheers

Jonny

JB

Its the ping tiime that is killing you. 3,61 down is enough. Are you using homegroup for your networking? Are there any other machines running a different OS?

Ken

Hi Ken,

no this is the only computer on the network. Strange, eh!

Cheers

Jonny
My System SpecsSystem Spec
02 Feb 2010   #10
seekermeister

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

I think that TGSoldier is correct, because the ping bottlenecks immediately between your machine and your ISP. In addition to resetting the router, do the same with the modem (I've never had DSL, but I assume that requires a modem like cable also). If resetting these don't help, I would call the ISP tech support, because it seems that either your router, or their modem is the problem (assuming that you don't own the modem).
My System SpecsSystem Spec
Reply

 Slow Browser or Internet Connection?




Thread Tools




Similar help and support threads
Thread Forum
No browser internet connection--Have internet access (Tried everything
Toshiba Laptop with W-7 Owner uses only for email, etc. Has no internet connection with IE, Firefox, Chrome in NORMAL mode. Have a connection, ipconfig OK, can Ping sites. Have a connection with all browsers in SAFE Mode. (Disclaimer-am IT for my own small SOHO PC business, been a member here...
Network & Sharing
I have internet connection but cannot connect to any browser
Last night i was using my pc but suddenly my internet disconnected, i use modem cable it says i have internet connection but when i go to anybrowser or i try to update any software it says i dont have internet connection i tried ipconfig/renew , netsh winsock or ip reset but still didnt got any...
Network & Sharing
Laptop says connection to internet, however cant even web browser
Hello everyone, to start off this is a wifi problem, with one router about 3 weeks ago it started I cant stay connected to the internet to web browser or play game or just about anything, however people right next to my on their laptops can do everything fine. Also this only happens with the...
Network & Sharing
Windows 7 internet connection, but no working browser
Hello All, I know this is a pretty old problem, but I can't seem to get the below solution to work for me. 1. Click start, type cmd in the Start Search box, right-click cmd.exe, click Run as administrator, and then press Continue. 2. Type netsh winsock reset at the command prompt, and...
Network & Sharing
Have internet connection but can't use browser and several programs
On a Laptop with Windows Home Premium (Acer OEM) I have Windows Defender installed. Then downloaded AVG Antivirus around 1:st week of August. After the end of trial period AVG asked me if I want to upgrade to paid version or remain using free version with restricted options. I chose to keep the...
Network & Sharing
Slow browser, slow internet, random audio ads: virus?
So yeah, I've these problems for the past couple days. My browsers (Opera and Firefox) used to load pages quickly, but now they're painfully slow. Opera lags and freezes often; Firefox doesn't, but it still takes a very long time to load pages. I'm also getting these occasional "invisible ads,"...
System Security


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:16.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App